%global _empty_manifest_terminate_build 0
Name: python-flask-marshmallow
Version: 0.15.0
Release: 1
Summary: Flask + marshmallow for beautiful APIs
License: MIT
URL: https://github.com/marshmallow-code/flask-marshmallow
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ac/8b/5c59b930375226c7d1d49b39d00a36696febb6fc1934aa82ce4f2c09cd0f/flask-marshmallow-0.15.0.tar.gz
BuildArch: noarch
Requires: python3-Flask
Requires: python3-marshmallow
Requires: python3-packaging
Requires: python3-flask-sqlalchemy
Requires: python3-marshmallow-sqlalchemy
Requires: python3-pytest
Requires: python3-mock
Requires: python3-tox
Requires: python3-pre-commit
Requires: python3-marshmallow-sqlalchemy
Requires: python3-Sphinx
Requires: python3-sphinx-issues
Requires: python3-flask-sqlalchemy
Requires: python3-marshmallow-sqlalchemy
Requires: python3-flask-sqlalchemy
Requires: python3-marshmallow-sqlalchemy
Requires: python3-pytest
Requires: python3-mock
%description
Flask-Marshmallow is a thin integration layer for `Flask`_ (a Python web framework) and `marshmallow`_ (an object serialization/deserialization library) that adds additional features to marshmallow, including URL and Hyperlinks fields for HATEOAS-ready APIs. It also (optionally) integrates with `Flask-SQLAlchemy `_.
%package -n python3-flask-marshmallow
Summary: Flask + marshmallow for beautiful APIs
Provides: python-flask-marshmallow
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flask-marshmallow
Flask-Marshmallow is a thin integration layer for `Flask`_ (a Python web framework) and `marshmallow`_ (an object serialization/deserialization library) that adds additional features to marshmallow, including URL and Hyperlinks fields for HATEOAS-ready APIs. It also (optionally) integrates with `Flask-SQLAlchemy `_.
%package help
Summary: Development documents and examples for flask-marshmallow
Provides: python3-flask-marshmallow-doc
%description help
Flask-Marshmallow is a thin integration layer for `Flask`_ (a Python web framework) and `marshmallow`_ (an object serialization/deserialization library) that adds additional features to marshmallow, including URL and Hyperlinks fields for HATEOAS-ready APIs. It also (optionally) integrates with `Flask-SQLAlchemy `_.
%prep
%autosetup -n flask-marshmallow-0.15.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flask-marshmallow -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 0.15.0-1
- Package Spec generated