%global _empty_manifest_terminate_build 0
Name:		python-workflow
Version:	2.1.6
Release:	1
Summary:	Simple workflows for Python
License:	BSD License
URL:		https://github.com/inveniosoftware/workflow
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c2/1e/4d569fc46b90baa51f2ba881fe5027f00ae8ac2c55092fd0c178a34538aa/workflow-2.1.6.tar.gz
BuildArch:	noarch

Requires:	python3-autosemver
Requires:	python3-configobj
Requires:	python3-blinker
Requires:	python3-six
Requires:	python3-enum34
Requires:	python3-Sphinx
Requires:	python3-coverage
Requires:	python3-mock
Requires:	python3-isort
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8
Requires:	python3-pytest
Requires:	python3-Sphinx
Requires:	python3-coverage
Requires:	python3-mock
Requires:	python3-isort
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8
Requires:	python3-pytest

%description


%package -n python3-workflow
Summary:	Simple workflows for Python
Provides:	python-workflow
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-workflow


%package help
Summary:	Development documents and examples for workflow
Provides:	python3-workflow-doc
%description help


%prep
%autosetup -n workflow-2.1.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-workflow -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.6-1
- Package Spec generated