%global _empty_manifest_terminate_build 0
Name:		python-langua
Version:	1.0.12
Release:	1
Summary:	Faster port of Language detection built by Shuyo in Python
License:	Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at
URL:		https://github.com/whiletruelearn/langua
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/40/72/ff0c66aa136aa97e2659cbe479d7ad302b165b3654a3faaa8f872e755aae/langua-1.0.12.tar.gz
BuildArch:	noarch

Requires:	python3-numpy
Requires:	python3-six

%description
            $ pip install langua
        Supported Python versions 2.7, 3.4+.

%package -n python3-langua
Summary:	Faster port of Language detection built by Shuyo in Python
Provides:	python-langua
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-langua
            $ pip install langua
        Supported Python versions 2.7, 3.4+.

%package help
Summary:	Development documents and examples for langua
Provides:	python3-langua-doc
%description help
            $ pip install langua
        Supported Python versions 2.7, 3.4+.

%prep
%autosetup -n langua-1.0.12

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-langua -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.12-1
- Package Spec generated