%global _empty_manifest_terminate_build 0
Name:		python-uplink
Version:	0.9.7
Release:	1
Summary:	A Declarative HTTP Client for Python.
License:	MIT
URL:		https://uplink.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e6/10/f93f050e6528346c78a4d96d7f92c2af0e25b98f108e4a36a96074fbd7e1/uplink-0.9.7.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-six
Requires:	python3-uritemplate
Requires:	python3-aiohttp
Requires:	python3-marshmallow
Requires:	python3-pydantic
Requires:	python3-pytest
Requires:	python3-pytest-mock
Requires:	python3-pytest-cov
Requires:	python3-pytest-twisted
Requires:	python3-pytest-asyncio
Requires:	python3-twisted
Requires:	python3-twisted
Requires:	python3-twisted
Requires:	python3-typing

%description
Uplink turns your HTTP API into a Python class.
   from uplink import Consumer, get, Path, Query
   class GitHub(Consumer):
       """A Python Client for the GitHub API."""
       @get("users/{user}/repos")
       def get_repos(self, user: Path, sort_by: Query("sort")):
           """Retrieves the user's public repositories."""
Build an instance to interact with the webservice.
   github = GitHub(base_url="https://api.github.com/")
Then, executing an HTTP request is as simply as invoking a method.
   repos = github.get_repos(user="octocat", sort_by="created")
The returned object is a friendly |requests.Response|_:
   print(repos.json())
   # Output: [{'id': 64778136, 'name': 'linguist', ...
For sending non-blocking requests, Uplink comes with support for
|aiohttp and twisted|_.
Ready to launch your first API client with Uplink? Start with this `quick tutorial`_!

%package -n python3-uplink
Summary:	A Declarative HTTP Client for Python.
Provides:	python-uplink
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-uplink
Uplink turns your HTTP API into a Python class.
   from uplink import Consumer, get, Path, Query
   class GitHub(Consumer):
       """A Python Client for the GitHub API."""
       @get("users/{user}/repos")
       def get_repos(self, user: Path, sort_by: Query("sort")):
           """Retrieves the user's public repositories."""
Build an instance to interact with the webservice.
   github = GitHub(base_url="https://api.github.com/")
Then, executing an HTTP request is as simply as invoking a method.
   repos = github.get_repos(user="octocat", sort_by="created")
The returned object is a friendly |requests.Response|_:
   print(repos.json())
   # Output: [{'id': 64778136, 'name': 'linguist', ...
For sending non-blocking requests, Uplink comes with support for
|aiohttp and twisted|_.
Ready to launch your first API client with Uplink? Start with this `quick tutorial`_!

%package help
Summary:	Development documents and examples for uplink
Provides:	python3-uplink-doc
%description help
Uplink turns your HTTP API into a Python class.
   from uplink import Consumer, get, Path, Query
   class GitHub(Consumer):
       """A Python Client for the GitHub API."""
       @get("users/{user}/repos")
       def get_repos(self, user: Path, sort_by: Query("sort")):
           """Retrieves the user's public repositories."""
Build an instance to interact with the webservice.
   github = GitHub(base_url="https://api.github.com/")
Then, executing an HTTP request is as simply as invoking a method.
   repos = github.get_repos(user="octocat", sort_by="created")
The returned object is a friendly |requests.Response|_:
   print(repos.json())
   # Output: [{'id': 64778136, 'name': 'linguist', ...
For sending non-blocking requests, Uplink comes with support for
|aiohttp and twisted|_.
Ready to launch your first API client with Uplink? Start with this `quick tutorial`_!

%prep
%autosetup -n uplink-0.9.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-uplink -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.7-1
- Package Spec generated