%global _empty_manifest_terminate_build 0
Name: python-flake8-commas
Version: 2.1.0
Release: 1
Summary: Flake8 lint for trailing commas.
License: MIT License
URL: https://github.com/PyCQA/flake8-commas/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/0e/83/814bc8eb02b8883bc004384a1fb8b1f45b4a0b892e579fec7c80a9368526/flake8-commas-2.1.0.tar.gz
BuildArch: noarch
Requires: python3-flake8
%description
**Note:** `Black `_, the uncompromising Python code
formatter, or `add-trailing-comma `_
can do all this comma insertion automatically. We recommend you use one of those tools
instead.
%package -n python3-flake8-commas
Summary: Flake8 lint for trailing commas.
Provides: python-flake8-commas
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-flake8-commas
**Note:** `Black `_, the uncompromising Python code
formatter, or `add-trailing-comma `_
can do all this comma insertion automatically. We recommend you use one of those tools
instead.
%package help
Summary: Development documents and examples for flake8-commas
Provides: python3-flake8-commas-doc
%description help
**Note:** `Black `_, the uncompromising Python code
formatter, or `add-trailing-comma `_
can do all this comma insertion automatically. We recommend you use one of those tools
instead.
%prep
%autosetup -n flake8-commas-2.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-flake8-commas -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri Apr 21 2023 Python_Bot - 2.1.0-1
- Package Spec generated