%global _empty_manifest_terminate_build 0
Name:		python-locustio
Version:	0.999
Release:	1
Summary:	Website load testing framework
License:	MIT
URL:		https://locust.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/bd/50/c4bafccbb1dd66a1968f3f6d96933889b338475f4a8e45a7785f7f275fc5/locustio-0.999.tar.gz
BuildArch:	noarch


%description
Locust is a python utility for doing easy, distributed load testing of a web site

%package -n python3-locustio
Summary:	Website load testing framework
Provides:	python-locustio
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-locustio
Locust is a python utility for doing easy, distributed load testing of a web site

%package help
Summary:	Development documents and examples for locustio
Provides:	python3-locustio-doc
%description help
Locust is a python utility for doing easy, distributed load testing of a web site

%prep
%autosetup -n locustio-0.999

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-locustio -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 0.999-1
- Package Spec generated