%global _empty_manifest_terminate_build 0
Name:		python-tink
Version:	1.6.1
Release:	1
Summary:	A multi-language, cross-platform library that provides cryptographic APIs that are secure, easy to use correctly, and hard(er) to misuse.
License:	Apache 2.0
URL:		https://github.com/google/tink
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ef/42/56e701ea3f14a7fef3345517dc2777fd9ea85d8f818d63143053534b7474/tink-1.6.1.tar.gz
BuildArch:	noarch

Requires:	python3-absl-py
Requires:	python3-protobuf
Requires:	python3-six

%description
# Tink

Using crypto in your application shouldn't have to feel like juggling chainsaws
in the dark. Tink is a crypto library written by a group of cryptographers and
security engineers at Google. It was born out of our extensive experience
working with Google's product teams, fixing weaknesses in implementations, and
providing simple APIs that can be used safely without needing a crypto
background.

Tink provides secure APIs that are easy to use correctly and hard(er) to misuse.
It reduces common crypto pitfalls with user-centered design, careful
implementation and code reviews, and extensive testing. At Google, Tink is
already being used to secure data of many products such as AdMob, Google Pay,
Google Assistant, Firebase, the Android Search App, etc.

## Documentation

For an overview of using Tink in Python, see the
[Python HOW-TO](../docs/PYTHON-HOWTO.md).

In addition, there are illustrative [examples of using Tink
Python](https://github.com/google/tink/tree/master/examples/python/) which can
used as a jumping off point.




%package -n python3-tink
Summary:	A multi-language, cross-platform library that provides cryptographic APIs that are secure, easy to use correctly, and hard(er) to misuse.
Provides:	python-tink
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-tink
# Tink

Using crypto in your application shouldn't have to feel like juggling chainsaws
in the dark. Tink is a crypto library written by a group of cryptographers and
security engineers at Google. It was born out of our extensive experience
working with Google's product teams, fixing weaknesses in implementations, and
providing simple APIs that can be used safely without needing a crypto
background.

Tink provides secure APIs that are easy to use correctly and hard(er) to misuse.
It reduces common crypto pitfalls with user-centered design, careful
implementation and code reviews, and extensive testing. At Google, Tink is
already being used to secure data of many products such as AdMob, Google Pay,
Google Assistant, Firebase, the Android Search App, etc.

## Documentation

For an overview of using Tink in Python, see the
[Python HOW-TO](../docs/PYTHON-HOWTO.md).

In addition, there are illustrative [examples of using Tink
Python](https://github.com/google/tink/tree/master/examples/python/) which can
used as a jumping off point.




%package help
Summary:	Development documents and examples for tink
Provides:	python3-tink-doc
%description help
# Tink

Using crypto in your application shouldn't have to feel like juggling chainsaws
in the dark. Tink is a crypto library written by a group of cryptographers and
security engineers at Google. It was born out of our extensive experience
working with Google's product teams, fixing weaknesses in implementations, and
providing simple APIs that can be used safely without needing a crypto
background.

Tink provides secure APIs that are easy to use correctly and hard(er) to misuse.
It reduces common crypto pitfalls with user-centered design, careful
implementation and code reviews, and extensive testing. At Google, Tink is
already being used to secure data of many products such as AdMob, Google Pay,
Google Assistant, Firebase, the Android Search App, etc.

## Documentation

For an overview of using Tink in Python, see the
[Python HOW-TO](../docs/PYTHON-HOWTO.md).

In addition, there are illustrative [examples of using Tink
Python](https://github.com/google/tink/tree/master/examples/python/) which can
used as a jumping off point.




%prep
%autosetup -n tink-1.6.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-tink -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.1-1
- Package Spec generated