%global _empty_manifest_terminate_build 0
Name:		python-testing.postgresql
Version:	1.3.0
Release:	1
Summary:	automatically setups a postgresql instance in a temporary directory, and destroys it after testing
License:	Apache License 2.0
URL:		https://github.com/tk0miya/testing.postgresql
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/3a/5b/3bf1323697c4f4f0e8fb5c14d082dc2f005385ea139b19646c0fc9f1dbb7/testing.postgresql-1.3.0.tar.gz
BuildArch:	noarch


%description
``testing.postgresql`` automatically setups a postgresql instance in a temporary directory, and destroys it after testing.
Documentation
  https://github.com/tk0miya/testing.postgresql
Issues
  https://github.com/tk0miya/testing.postgresql/issues
Download
  https://pypi.python.org/pypi/testing.postgresql

%package -n python3-testing.postgresql
Summary:	automatically setups a postgresql instance in a temporary directory, and destroys it after testing
Provides:	python-testing.postgresql
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-testing.postgresql
``testing.postgresql`` automatically setups a postgresql instance in a temporary directory, and destroys it after testing.
Documentation
  https://github.com/tk0miya/testing.postgresql
Issues
  https://github.com/tk0miya/testing.postgresql/issues
Download
  https://pypi.python.org/pypi/testing.postgresql

%package help
Summary:	Development documents and examples for testing.postgresql
Provides:	python3-testing.postgresql-doc
%description help
``testing.postgresql`` automatically setups a postgresql instance in a temporary directory, and destroys it after testing.
Documentation
  https://github.com/tk0miya/testing.postgresql
Issues
  https://github.com/tk0miya/testing.postgresql/issues
Download
  https://pypi.python.org/pypi/testing.postgresql

%prep
%autosetup -n testing.postgresql-1.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-testing.postgresql -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
- Package Spec generated