%global _empty_manifest_terminate_build 0
Name:		python-pusher
Version:	3.3.2
Release:	1
Summary:	A Python library to interract with the Pusher Channels API
License:	MIT
URL:		https://github.com/pusher/pusher-http-python
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/77/8f/eacb70f8a9b696a10927317f03fd32b46ac1358db292ebce16d929836f5d/pusher-3.3.2.tar.gz
BuildArch:	noarch

Requires:	python3-six
Requires:	python3-requests
Requires:	python3-urllib3
Requires:	python3-pyopenssl
Requires:	python3-ndg-httpsclient
Requires:	python3-pyasn1
Requires:	python3-pynacl
Requires:	python3-aiohttp
Requires:	python3-tornado

%description
A Python library to interract with the Pusher Channels API


%package -n python3-pusher
Summary:	A Python library to interract with the Pusher Channels API
Provides:	python-pusher
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pusher
A Python library to interract with the Pusher Channels API


%package help
Summary:	Development documents and examples for pusher
Provides:	python3-pusher-doc
%description help
A Python library to interract with the Pusher Channels API


%prep
%autosetup -n pusher-3.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pusher -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri Apr 21 2023 Python_Bot <Python_Bot@openeuler.org> - 3.3.2-1
- Package Spec generated