%global _empty_manifest_terminate_build 0 Name: python-emails Version: 0.6 Release: 1 Summary: Modern python library for emails. License: BSD License URL: https://github.com/lavr/python-emails Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d3/f9/c1e315aa82ed9f037186c30109200fb4b4c51b5483b8065daa0ca836a336/emails-0.6.tar.gz BuildArch: noarch Requires: python3-cssutils Requires: python3-lxml Requires: python3-chardet Requires: python3-dateutil Requires: python3-requests Requires: python3-premailer %description python-emails ~~~~~~~~~~~~~ Modern python library for email. Build message: >>> import emails >>> message = emails.html(html="
Hi! Hi! Hi!
Here is your receipt...",
subject="Your receipt No. 567098123",
mail_from=('Some Store', 'store@somestore.com'))
>>> message.attach(data=open('bill.pdf'), filename='bill.pdf')
send message and get response from smtp server:
>>> r = message.send(to='s@lavr.me', smtp={'host': 'aspmx.l.google.com', 'timeout': 5})
>>> assert r.status_code == 250
and more:
* DKIM signature
* Render body from template
* Flask extension and Django integration
* Message body transformation methods
* Load message from url or from file
Links
`````
* `documentation
Here is your receipt...",
subject="Your receipt No. 567098123",
mail_from=('Some Store', 'store@somestore.com'))
>>> message.attach(data=open('bill.pdf'), filename='bill.pdf')
send message and get response from smtp server:
>>> r = message.send(to='s@lavr.me', smtp={'host': 'aspmx.l.google.com', 'timeout': 5})
>>> assert r.status_code == 250
and more:
* DKIM signature
* Render body from template
* Flask extension and Django integration
* Message body transformation methods
* Load message from url or from file
Links
`````
* `documentation
Here is your receipt...",
subject="Your receipt No. 567098123",
mail_from=('Some Store', 'store@somestore.com'))
>>> message.attach(data=open('bill.pdf'), filename='bill.pdf')
send message and get response from smtp server:
>>> r = message.send(to='s@lavr.me', smtp={'host': 'aspmx.l.google.com', 'timeout': 5})
>>> assert r.status_code == 250
and more:
* DKIM signature
* Render body from template
* Flask extension and Django integration
* Message body transformation methods
* Load message from url or from file
Links
`````
* `documentation