%global _empty_manifest_terminate_build 0
Name: python-PasteScript
Version: 3.3.0
Release: 1
Summary: A pluggable command-line frontend, including commands to setup package file layouts
License: MIT
URL: https://pastescript.readthedocs.io/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c8/53/3fc0b9b231d71639c3f6352fd86ec9b0e80c9b2693c2d4a9074a0321c686/PasteScript-3.3.0.tar.gz
BuildArch: noarch
Requires: python3-Paste
Requires: python3-PasteDeploy
Requires: python3-six
Requires: python3-setuptools
Requires: python3-Cheetah
Requires: python3-PasteDeploy
Requires: python3-Flup
Requires: python3-PasteDeploy
Requires: python3-Cheetah
Requires: python3-WSGIserver
%description
PasteScript is a pluggable command-line tool.
**Note**: Paste Script is being maintained on life support. That
means that critical bugs will be fixed, and support for new versions
of Python will be handled, but other than that new features are not
being considered.
It includes some built-in features;
* Create file layouts for packages. For instance, ``paster create
--template=basic_package MyPackage`` will create a `setuptools
`_-ready
file layout.
* Serving up web applications, with configuration based on
`paste.deploy `_.
The latest version is available in a `GitHub repository
`_.
For the latest changes see the `news file
`_.
%package -n python3-PasteScript
Summary: A pluggable command-line frontend, including commands to setup package file layouts
Provides: python-PasteScript
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-PasteScript
PasteScript is a pluggable command-line tool.
**Note**: Paste Script is being maintained on life support. That
means that critical bugs will be fixed, and support for new versions
of Python will be handled, but other than that new features are not
being considered.
It includes some built-in features;
* Create file layouts for packages. For instance, ``paster create
--template=basic_package MyPackage`` will create a `setuptools
`_-ready
file layout.
* Serving up web applications, with configuration based on
`paste.deploy `_.
The latest version is available in a `GitHub repository
`_.
For the latest changes see the `news file
`_.
%package help
Summary: Development documents and examples for PasteScript
Provides: python3-PasteScript-doc
%description help
PasteScript is a pluggable command-line tool.
**Note**: Paste Script is being maintained on life support. That
means that critical bugs will be fixed, and support for new versions
of Python will be handled, but other than that new features are not
being considered.
It includes some built-in features;
* Create file layouts for packages. For instance, ``paster create
--template=basic_package MyPackage`` will create a `setuptools
`_-ready
file layout.
* Serving up web applications, with configuration based on
`paste.deploy `_.
The latest version is available in a `GitHub repository
`_.
For the latest changes see the `news file
`_.
%prep
%autosetup -n PasteScript-3.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-PasteScript -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 3.3.0-1
- Package Spec generated