%global _empty_manifest_terminate_build 0
Name: python-wsgi-request-logger
Version: 0.4.6
Release: 1
Summary: Apache-like combined logging for WSGI Web Applications
License: BSD
URL: https://github.com/pklaus/wsgi-request-logger
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/04/dd/5e6c52b96a841baec75e5c5647460214aa02e9c4902c7b250375352224c0/wsgi-request-logger-0.4.6.tar.gz
BuildArch: noarch
%description
This is a middleware which you can use to log requests to your WSGI
based site. It's even imitating Apache's combined log format to allow
you to use any of the many tools for Apache log file analysis.
By making use of Python's standard library logging facilities, you can
easily set it up to log to STDOUT, time rotated log files, email,
syslog, etc.
Installation
^^^^^^^^^^^^
Simply install this Python module via
pip install wsgi-request-logger
Usage
^^^^^
To add this middleware to your WSGI ``application`` and log to the file
*access.log*, do:
from requestlogger import WSGILogger, ApacheFormatter
from logging.handlers import TimedRotatingFileHandler
def application(environ, start_response):
response_body = 'The request method was %s' % environ['REQUEST_METHOD']
response_body = response_body.encode('utf-8')
response_headers = [('Content-Type', 'text/plain'),
('Content-Length', str(len(response_body)))]
start_response('200 OK', response_headers)
return [response_body]
handlers = [ TimedRotatingFileHandler('access.log', 'd', 7) , ]
loggingapp = WSGILogger(application, handlers, ApacheFormatter())
if __name__ == '__main__':
from wsgiref.simple_server import make_server
http = make_server('', 8080, loggingapp)
http.serve_forever()
The Authors
^^^^^^^^^^^
This WSGI middleware was originally developed under the name
`wsgilog `__ by **L. C. Rees**.
It was forked by **Philipp Klaus** in 2013 to build a WSGI middleware
for request logging rather than exception handling and logging.
License
^^^^^^^
This software, *wsgi-request-logger*, is published under a *3-clause BSD
license*.
Developers' Resources
^^^^^^^^^^^^^^^^^^^^^
- To read about your options for the logging handler, you may want to
read `Python's Logging
Cookbook `__.
- Documentation on Apache's log format can be found
`here `__.
- The
`WSGI `__
- Web Server Gateway Interface - is defined in `PEP
333 `__ with an update for
Python 3 in `PEP 3333 `__.
General References
^^^^^^^^^^^^^^^^^^
- PyPI's `listing of
wsgi-request-logger `__
- The source code for this Python module is `hosted on
Github `__.
- A blog post with more background information and usage examples:
`wsgi-request-logger – Logging HTTP Requests With Any WSGI Web
Application like Flask, Bottle or
Django `__
%package -n python3-wsgi-request-logger
Summary: Apache-like combined logging for WSGI Web Applications
Provides: python-wsgi-request-logger
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wsgi-request-logger
This is a middleware which you can use to log requests to your WSGI
based site. It's even imitating Apache's combined log format to allow
you to use any of the many tools for Apache log file analysis.
By making use of Python's standard library logging facilities, you can
easily set it up to log to STDOUT, time rotated log files, email,
syslog, etc.
Installation
^^^^^^^^^^^^
Simply install this Python module via
pip install wsgi-request-logger
Usage
^^^^^
To add this middleware to your WSGI ``application`` and log to the file
*access.log*, do:
from requestlogger import WSGILogger, ApacheFormatter
from logging.handlers import TimedRotatingFileHandler
def application(environ, start_response):
response_body = 'The request method was %s' % environ['REQUEST_METHOD']
response_body = response_body.encode('utf-8')
response_headers = [('Content-Type', 'text/plain'),
('Content-Length', str(len(response_body)))]
start_response('200 OK', response_headers)
return [response_body]
handlers = [ TimedRotatingFileHandler('access.log', 'd', 7) , ]
loggingapp = WSGILogger(application, handlers, ApacheFormatter())
if __name__ == '__main__':
from wsgiref.simple_server import make_server
http = make_server('', 8080, loggingapp)
http.serve_forever()
The Authors
^^^^^^^^^^^
This WSGI middleware was originally developed under the name
`wsgilog `__ by **L. C. Rees**.
It was forked by **Philipp Klaus** in 2013 to build a WSGI middleware
for request logging rather than exception handling and logging.
License
^^^^^^^
This software, *wsgi-request-logger*, is published under a *3-clause BSD
license*.
Developers' Resources
^^^^^^^^^^^^^^^^^^^^^
- To read about your options for the logging handler, you may want to
read `Python's Logging
Cookbook `__.
- Documentation on Apache's log format can be found
`here `__.
- The
`WSGI `__
- Web Server Gateway Interface - is defined in `PEP
333 `__ with an update for
Python 3 in `PEP 3333 `__.
General References
^^^^^^^^^^^^^^^^^^
- PyPI's `listing of
wsgi-request-logger `__
- The source code for this Python module is `hosted on
Github `__.
- A blog post with more background information and usage examples:
`wsgi-request-logger – Logging HTTP Requests With Any WSGI Web
Application like Flask, Bottle or
Django `__
%package help
Summary: Development documents and examples for wsgi-request-logger
Provides: python3-wsgi-request-logger-doc
%description help
This is a middleware which you can use to log requests to your WSGI
based site. It's even imitating Apache's combined log format to allow
you to use any of the many tools for Apache log file analysis.
By making use of Python's standard library logging facilities, you can
easily set it up to log to STDOUT, time rotated log files, email,
syslog, etc.
Installation
^^^^^^^^^^^^
Simply install this Python module via
pip install wsgi-request-logger
Usage
^^^^^
To add this middleware to your WSGI ``application`` and log to the file
*access.log*, do:
from requestlogger import WSGILogger, ApacheFormatter
from logging.handlers import TimedRotatingFileHandler
def application(environ, start_response):
response_body = 'The request method was %s' % environ['REQUEST_METHOD']
response_body = response_body.encode('utf-8')
response_headers = [('Content-Type', 'text/plain'),
('Content-Length', str(len(response_body)))]
start_response('200 OK', response_headers)
return [response_body]
handlers = [ TimedRotatingFileHandler('access.log', 'd', 7) , ]
loggingapp = WSGILogger(application, handlers, ApacheFormatter())
if __name__ == '__main__':
from wsgiref.simple_server import make_server
http = make_server('', 8080, loggingapp)
http.serve_forever()
The Authors
^^^^^^^^^^^
This WSGI middleware was originally developed under the name
`wsgilog `__ by **L. C. Rees**.
It was forked by **Philipp Klaus** in 2013 to build a WSGI middleware
for request logging rather than exception handling and logging.
License
^^^^^^^
This software, *wsgi-request-logger*, is published under a *3-clause BSD
license*.
Developers' Resources
^^^^^^^^^^^^^^^^^^^^^
- To read about your options for the logging handler, you may want to
read `Python's Logging
Cookbook `__.
- Documentation on Apache's log format can be found
`here `__.
- The
`WSGI `__
- Web Server Gateway Interface - is defined in `PEP
333 `__ with an update for
Python 3 in `PEP 3333 `__.
General References
^^^^^^^^^^^^^^^^^^
- PyPI's `listing of
wsgi-request-logger `__
- The source code for this Python module is `hosted on
Github `__.
- A blog post with more background information and usage examples:
`wsgi-request-logger – Logging HTTP Requests With Any WSGI Web
Application like Flask, Bottle or
Django `__
%prep
%autosetup -n wsgi-request-logger-0.4.6
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wsgi-request-logger -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.4.6-1
- Package Spec generated