%global _empty_manifest_terminate_build 0
Name:		python-sphinx-markdown-tables
Version:	0.0.17
Release:	1
Summary:	A Sphinx extension for rendering tables written in markdown
License:	GNU General Public License v3 (GPLv3)
URL:		https://github.com/ryanfox/sphinx-markdown-tables
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/fb/36/af0e0a4aa69298b4d664d5176243412ae96bfc207d7e3314e12b3a6f2ccc/sphinx-markdown-tables-0.0.17.tar.gz
BuildArch:	noarch

Requires:	python3-markdown

%description
# sphinx-markdown-tables

A [Sphinx](http://www.sphinx-doc.org/en/master/) extension for rendering markdown tables.

Sphinx supports markdown via [Recommonmark,](https://github.com/rtfd/recommonmark) which does not support tables. This
extension provides them.

It renders markdown tables as HTML, as defined by [python-markdown](https://python-markdown.github.io/)

## Installation

    pip install sphinx-markdown-tables

## Usage

### Quick version
Add `sphinx_markdown_tables` to `extensions` in `conf.py`, like so:

    extensions = [
        'sphinx_markdown_tables',
    ]

### Longer version
Sphinx needs to be configured to use markdown. First, you need `recommonmark`:

    pip install recommonmark

In `conf.py`, configure `source_parsers` and `source_suffix`:

    source_parsers = {
        '.md': 'recommonmark.parser.CommonMarkParser',
    }

    source_suffix = ['.rst', '.md']

Once Sphinx is configured appropriately, add `sphinx_markdown_tables` to `extensions`, like so:

    extensions = [
        'sphinx_markdown_tables',
    ]

For more information on Sphinx and markdown, see the
[Sphinx documentation.](http://www.sphinx-doc.org/en/master/usage/markdown.html)

## License
This project is available under the GPLv3 license. For other licensing arrangements contact
[Ryan Fox.](https://foxrow.com)


%package -n python3-sphinx-markdown-tables
Summary:	A Sphinx extension for rendering tables written in markdown
Provides:	python-sphinx-markdown-tables
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sphinx-markdown-tables
# sphinx-markdown-tables

A [Sphinx](http://www.sphinx-doc.org/en/master/) extension for rendering markdown tables.

Sphinx supports markdown via [Recommonmark,](https://github.com/rtfd/recommonmark) which does not support tables. This
extension provides them.

It renders markdown tables as HTML, as defined by [python-markdown](https://python-markdown.github.io/)

## Installation

    pip install sphinx-markdown-tables

## Usage

### Quick version
Add `sphinx_markdown_tables` to `extensions` in `conf.py`, like so:

    extensions = [
        'sphinx_markdown_tables',
    ]

### Longer version
Sphinx needs to be configured to use markdown. First, you need `recommonmark`:

    pip install recommonmark

In `conf.py`, configure `source_parsers` and `source_suffix`:

    source_parsers = {
        '.md': 'recommonmark.parser.CommonMarkParser',
    }

    source_suffix = ['.rst', '.md']

Once Sphinx is configured appropriately, add `sphinx_markdown_tables` to `extensions`, like so:

    extensions = [
        'sphinx_markdown_tables',
    ]

For more information on Sphinx and markdown, see the
[Sphinx documentation.](http://www.sphinx-doc.org/en/master/usage/markdown.html)

## License
This project is available under the GPLv3 license. For other licensing arrangements contact
[Ryan Fox.](https://foxrow.com)


%package help
Summary:	Development documents and examples for sphinx-markdown-tables
Provides:	python3-sphinx-markdown-tables-doc
%description help
# sphinx-markdown-tables

A [Sphinx](http://www.sphinx-doc.org/en/master/) extension for rendering markdown tables.

Sphinx supports markdown via [Recommonmark,](https://github.com/rtfd/recommonmark) which does not support tables. This
extension provides them.

It renders markdown tables as HTML, as defined by [python-markdown](https://python-markdown.github.io/)

## Installation

    pip install sphinx-markdown-tables

## Usage

### Quick version
Add `sphinx_markdown_tables` to `extensions` in `conf.py`, like so:

    extensions = [
        'sphinx_markdown_tables',
    ]

### Longer version
Sphinx needs to be configured to use markdown. First, you need `recommonmark`:

    pip install recommonmark

In `conf.py`, configure `source_parsers` and `source_suffix`:

    source_parsers = {
        '.md': 'recommonmark.parser.CommonMarkParser',
    }

    source_suffix = ['.rst', '.md']

Once Sphinx is configured appropriately, add `sphinx_markdown_tables` to `extensions`, like so:

    extensions = [
        'sphinx_markdown_tables',
    ]

For more information on Sphinx and markdown, see the
[Sphinx documentation.](http://www.sphinx-doc.org/en/master/usage/markdown.html)

## License
This project is available under the GPLv3 license. For other licensing arrangements contact
[Ryan Fox.](https://foxrow.com)


%prep
%autosetup -n sphinx-markdown-tables-0.0.17

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sphinx-markdown-tables -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.17-1
- Package Spec generated