%global _empty_manifest_terminate_build 0
Name:		python-pipefish
Version:	0.4.2
Release:	1
Summary:	Process JUnit XML and Cobertura coverage XML reports into Markdown
License:	GPLv3+
URL:		https://github.com/pytest-buildkite/pipefish
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ba/19/d1782551090785409ef8ce8bba8806de65453ac10da185264be67764f341/pipefish-0.4.2.tar.gz
BuildArch:	noarch

Requires:	python3-docopt
Requires:	python3-defusedxml

%description
# pipefish
Process JUnit XML and Cobertura coverage XML reports into Markdown

# Additional Documentation:
* [News](https://github.com/pytest-buildkite/pipefish/blob/master/NEWS.rst).
* [Code of Conduct](https://github.com/pytest-buildkite/pipefish/blob/master/CODE_OF_CONDUCT.md).
* [Contribution Guidelines](https://github.com/pytest-buildkite/pipefish/blob/master/CONTRIBUTING.md).




%package -n python3-pipefish
Summary:	Process JUnit XML and Cobertura coverage XML reports into Markdown
Provides:	python-pipefish
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pipefish
# pipefish
Process JUnit XML and Cobertura coverage XML reports into Markdown

# Additional Documentation:
* [News](https://github.com/pytest-buildkite/pipefish/blob/master/NEWS.rst).
* [Code of Conduct](https://github.com/pytest-buildkite/pipefish/blob/master/CODE_OF_CONDUCT.md).
* [Contribution Guidelines](https://github.com/pytest-buildkite/pipefish/blob/master/CONTRIBUTING.md).




%package help
Summary:	Development documents and examples for pipefish
Provides:	python3-pipefish-doc
%description help
# pipefish
Process JUnit XML and Cobertura coverage XML reports into Markdown

# Additional Documentation:
* [News](https://github.com/pytest-buildkite/pipefish/blob/master/NEWS.rst).
* [Code of Conduct](https://github.com/pytest-buildkite/pipefish/blob/master/CODE_OF_CONDUCT.md).
* [Contribution Guidelines](https://github.com/pytest-buildkite/pipefish/blob/master/CONTRIBUTING.md).




%prep
%autosetup -n pipefish-0.4.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pipefish -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.2-1
- Package Spec generated