%global _empty_manifest_terminate_build 0
Name:		python-pylama
Version:	8.4.1
Release:	1
Summary:	Code audit tool for python
License:	MIT
URL:		https://github.com/klen/pylama
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/bf/4f/b6e14fa7fcc805bdfc970c2505535722bcfac7d2a2ad4da826f4865dc0ef/pylama-8.4.1.tar.gz
BuildArch:	noarch

Requires:	python3-mccabe
Requires:	python3-pycodestyle
Requires:	python3-pydocstyle
Requires:	python3-pyflakes
Requires:	python3-pylint
Requires:	python3-eradicate
Requires:	python3-radon
Requires:	python3-mypy
Requires:	python3-vulture
Requires:	python3-eradicate
Requires:	python3-mypy
Requires:	python3-pylint
Requires:	python3-radon
Requires:	python3-pytest
Requires:	python3-pytest-mypy
Requires:	python3-eradicate
Requires:	python3-radon
Requires:	python3-mypy
Requires:	python3-pylint
Requires:	python3-pylama-quotes
Requires:	python3-toml
Requires:	python3-vulture
Requires:	python3-types-setuptools
Requires:	python3-types-toml
Requires:	python3-toml
Requires:	python3-vulture

%description
- Python (3.7, 3.8, 3.9, 3.10)
- If your tests are failing on Win platform you are missing: ``curses`` -
  http://www.lfd.uci.edu/~gohlke/pythonlibs/ (The curses library supplies a
  terminal-independent screen-painting and keyboard-handling facility for
  text-based terminals)
For python versions < 3.7 install pylama 7.7.1

%package -n python3-pylama
Summary:	Code audit tool for python
Provides:	python-pylama
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pylama
- Python (3.7, 3.8, 3.9, 3.10)
- If your tests are failing on Win platform you are missing: ``curses`` -
  http://www.lfd.uci.edu/~gohlke/pythonlibs/ (The curses library supplies a
  terminal-independent screen-painting and keyboard-handling facility for
  text-based terminals)
For python versions < 3.7 install pylama 7.7.1

%package help
Summary:	Development documents and examples for pylama
Provides:	python3-pylama-doc
%description help
- Python (3.7, 3.8, 3.9, 3.10)
- If your tests are failing on Win platform you are missing: ``curses`` -
  http://www.lfd.uci.edu/~gohlke/pythonlibs/ (The curses library supplies a
  terminal-independent screen-painting and keyboard-handling facility for
  text-based terminals)
For python versions < 3.7 install pylama 7.7.1

%prep
%autosetup -n pylama-8.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pylama -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 8.4.1-1
- Package Spec generated