%global _empty_manifest_terminate_build 0
Name: python-recsim
Version: 0.2.4
Release: 1
Summary: RecSim: A Configurable Recommender Systems Simulation Platform
License: Apache 2.0
URL: https://github.com/google-research/recsim
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bb/5a/bbd19e986fd3448de90a2808010ddec29d048cff21cd940401c14c8666d6/recsim-0.2.4.tar.gz
BuildArch: noarch
Requires: python3-absl-py
Requires: python3-dopamine-rl
Requires: python3-gin-config
Requires: python3-gym
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-tensorflow
%description
# RecSim: A Configurable Recommender Systems Simulation Platform
RecSim is a configurable platform for authoring simulation environments for
recommender systems (RSs) that naturally supports **sequential interaction**
with users. RecSim allows the creation of new environments that reflect
particular aspects of user behavior and item structure at a level of abstraction
well-suited to pushing the limits of current reinforcement learning (RL) and RS
techniques in sequential interactive recommendation problems. Environments can
be easily configured that vary assumptions about: user preferences and item
familiarity; user latent state and its dynamics; and choice models and other
user response behavior. We outline how RecSim offers value to RL and RS
researchers and practitioners, and how it can serve as a vehicle for
academic-industrial collaboration. For a detailed description of the RecSim
architecture please read [Ie et al](https://arxiv.org/abs/1909.04847). Please
cite the paper if you use the code from this repository in your work.
### Bibtex
```
@article{ie2019recsim,
title={RecSim: A Configurable Simulation Platform for Recommender Systems},
author={Eugene Ie and Chih-wei Hsu and Martin Mladenov and Vihan Jain and Sanmit Narvekar and Jing Wang and Rui Wu and Craig Boutilier},
year={2019},
eprint={1909.04847},
archivePrefix={arXiv},
primaryClass={cs.LG}
}
```
## Disclaimer
This is not an officially supported Google product.
## What's new
* **12/13/2019:** Added (abstract) classes for both multi-user environments
and agents. Added bandit algorithms for generalized linear models.
## Installation and Sample Usage
It is recommended to install RecSim using (https://pypi.org/project/recsim/):
```shell
pip install recsim
```
However, the latest version of Dopamine is not in PyPI as of December, 2019. We
want to install the latest version from Dopamine's repository like the following
before we install RecSim. Note that Dopamine requires Tensorflow 1.15.0 which is
the final 1.x release including GPU support for Ubuntu and Windows.
```
pip install git+https://github.com/google/dopamine.git
```
Here are some sample commands you could use for testing the installation:
```
git clone https://github.com/google-research/recsim
cd recsim/recsim
python main.py --logtostderr \
--base_dir="/tmp/recsim/interest_exploration_full_slate_q" \
--agent_name=full_slate_q \
--environment_name=interest_exploration \
--episode_log_file='episode_logs.tfrecord' \
--gin_bindings=simulator.runner_lib.Runner.max_steps_per_episode=100 \
--gin_bindings=simulator.runner_lib.TrainRunner.num_iterations=10 \
--gin_bindings=simulator.runner_lib.TrainRunner.max_training_steps=100 \
--gin_bindings=simulator.runner_lib.EvalRunner.max_eval_episodes=5
```
You could then start a tensorboard and view the output
```
tensorboard --logdir=/tmp/recsim/interest_exploration_full_slate_q/ --port=2222
```
You could also find the simulated logs in /tmp/recsim/episode_logs.tfrecord
## Tutorials
To get started, please check out our Colab tutorials. In
[**RecSim: Overview**](recsim/colab/RecSim_Overview.ipynb),
we give a brief overview about RecSim. We then talk about each configurable
component:
[**environment**](recsim/colab/RecSim_Developing_an_Environment.ipynb)
and
[**recommender agent**](recsim/colab/RecSim_Developing_an_Agent.ipynb).
## Documentation
Please refer to the [white paper](http://arxiv.org/abs/1909.04847) for the
high-level design.
%package -n python3-recsim
Summary: RecSim: A Configurable Recommender Systems Simulation Platform
Provides: python-recsim
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-recsim
# RecSim: A Configurable Recommender Systems Simulation Platform
RecSim is a configurable platform for authoring simulation environments for
recommender systems (RSs) that naturally supports **sequential interaction**
with users. RecSim allows the creation of new environments that reflect
particular aspects of user behavior and item structure at a level of abstraction
well-suited to pushing the limits of current reinforcement learning (RL) and RS
techniques in sequential interactive recommendation problems. Environments can
be easily configured that vary assumptions about: user preferences and item
familiarity; user latent state and its dynamics; and choice models and other
user response behavior. We outline how RecSim offers value to RL and RS
researchers and practitioners, and how it can serve as a vehicle for
academic-industrial collaboration. For a detailed description of the RecSim
architecture please read [Ie et al](https://arxiv.org/abs/1909.04847). Please
cite the paper if you use the code from this repository in your work.
### Bibtex
```
@article{ie2019recsim,
title={RecSim: A Configurable Simulation Platform for Recommender Systems},
author={Eugene Ie and Chih-wei Hsu and Martin Mladenov and Vihan Jain and Sanmit Narvekar and Jing Wang and Rui Wu and Craig Boutilier},
year={2019},
eprint={1909.04847},
archivePrefix={arXiv},
primaryClass={cs.LG}
}
```
## Disclaimer
This is not an officially supported Google product.
## What's new
* **12/13/2019:** Added (abstract) classes for both multi-user environments
and agents. Added bandit algorithms for generalized linear models.
## Installation and Sample Usage
It is recommended to install RecSim using (https://pypi.org/project/recsim/):
```shell
pip install recsim
```
However, the latest version of Dopamine is not in PyPI as of December, 2019. We
want to install the latest version from Dopamine's repository like the following
before we install RecSim. Note that Dopamine requires Tensorflow 1.15.0 which is
the final 1.x release including GPU support for Ubuntu and Windows.
```
pip install git+https://github.com/google/dopamine.git
```
Here are some sample commands you could use for testing the installation:
```
git clone https://github.com/google-research/recsim
cd recsim/recsim
python main.py --logtostderr \
--base_dir="/tmp/recsim/interest_exploration_full_slate_q" \
--agent_name=full_slate_q \
--environment_name=interest_exploration \
--episode_log_file='episode_logs.tfrecord' \
--gin_bindings=simulator.runner_lib.Runner.max_steps_per_episode=100 \
--gin_bindings=simulator.runner_lib.TrainRunner.num_iterations=10 \
--gin_bindings=simulator.runner_lib.TrainRunner.max_training_steps=100 \
--gin_bindings=simulator.runner_lib.EvalRunner.max_eval_episodes=5
```
You could then start a tensorboard and view the output
```
tensorboard --logdir=/tmp/recsim/interest_exploration_full_slate_q/ --port=2222
```
You could also find the simulated logs in /tmp/recsim/episode_logs.tfrecord
## Tutorials
To get started, please check out our Colab tutorials. In
[**RecSim: Overview**](recsim/colab/RecSim_Overview.ipynb),
we give a brief overview about RecSim. We then talk about each configurable
component:
[**environment**](recsim/colab/RecSim_Developing_an_Environment.ipynb)
and
[**recommender agent**](recsim/colab/RecSim_Developing_an_Agent.ipynb).
## Documentation
Please refer to the [white paper](http://arxiv.org/abs/1909.04847) for the
high-level design.
%package help
Summary: Development documents and examples for recsim
Provides: python3-recsim-doc
%description help
# RecSim: A Configurable Recommender Systems Simulation Platform
RecSim is a configurable platform for authoring simulation environments for
recommender systems (RSs) that naturally supports **sequential interaction**
with users. RecSim allows the creation of new environments that reflect
particular aspects of user behavior and item structure at a level of abstraction
well-suited to pushing the limits of current reinforcement learning (RL) and RS
techniques in sequential interactive recommendation problems. Environments can
be easily configured that vary assumptions about: user preferences and item
familiarity; user latent state and its dynamics; and choice models and other
user response behavior. We outline how RecSim offers value to RL and RS
researchers and practitioners, and how it can serve as a vehicle for
academic-industrial collaboration. For a detailed description of the RecSim
architecture please read [Ie et al](https://arxiv.org/abs/1909.04847). Please
cite the paper if you use the code from this repository in your work.
### Bibtex
```
@article{ie2019recsim,
title={RecSim: A Configurable Simulation Platform for Recommender Systems},
author={Eugene Ie and Chih-wei Hsu and Martin Mladenov and Vihan Jain and Sanmit Narvekar and Jing Wang and Rui Wu and Craig Boutilier},
year={2019},
eprint={1909.04847},
archivePrefix={arXiv},
primaryClass={cs.LG}
}
```
## Disclaimer
This is not an officially supported Google product.
## What's new
* **12/13/2019:** Added (abstract) classes for both multi-user environments
and agents. Added bandit algorithms for generalized linear models.
## Installation and Sample Usage
It is recommended to install RecSim using (https://pypi.org/project/recsim/):
```shell
pip install recsim
```
However, the latest version of Dopamine is not in PyPI as of December, 2019. We
want to install the latest version from Dopamine's repository like the following
before we install RecSim. Note that Dopamine requires Tensorflow 1.15.0 which is
the final 1.x release including GPU support for Ubuntu and Windows.
```
pip install git+https://github.com/google/dopamine.git
```
Here are some sample commands you could use for testing the installation:
```
git clone https://github.com/google-research/recsim
cd recsim/recsim
python main.py --logtostderr \
--base_dir="/tmp/recsim/interest_exploration_full_slate_q" \
--agent_name=full_slate_q \
--environment_name=interest_exploration \
--episode_log_file='episode_logs.tfrecord' \
--gin_bindings=simulator.runner_lib.Runner.max_steps_per_episode=100 \
--gin_bindings=simulator.runner_lib.TrainRunner.num_iterations=10 \
--gin_bindings=simulator.runner_lib.TrainRunner.max_training_steps=100 \
--gin_bindings=simulator.runner_lib.EvalRunner.max_eval_episodes=5
```
You could then start a tensorboard and view the output
```
tensorboard --logdir=/tmp/recsim/interest_exploration_full_slate_q/ --port=2222
```
You could also find the simulated logs in /tmp/recsim/episode_logs.tfrecord
## Tutorials
To get started, please check out our Colab tutorials. In
[**RecSim: Overview**](recsim/colab/RecSim_Overview.ipynb),
we give a brief overview about RecSim. We then talk about each configurable
component:
[**environment**](recsim/colab/RecSim_Developing_an_Environment.ipynb)
and
[**recommender agent**](recsim/colab/RecSim_Developing_an_Agent.ipynb).
## Documentation
Please refer to the [white paper](http://arxiv.org/abs/1909.04847) for the
high-level design.
%prep
%autosetup -n recsim-0.2.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-recsim -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.2.4-1
- Package Spec generated