%global _empty_manifest_terminate_build 0
Name: python-SuperSuit
Version: 3.7.2
Release: 1
Summary: Wrappers for Gymnasium and PettingZoo
License: MIT License
URL: https://github.com/Farama-Foundation/SuperSuit
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/46/a966520971d4dc1c5159b13d4cfb0b7e15ebf12e5a8aafd98d807ee2c93d/SuperSuit-3.7.2.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-gymnasium
%description
SuperSuit introduces a collection of small functions which can wrap reinforcement learning environments to do preprocessing ('microwrappers').
We support Gymnasium for single agent environments and PettingZoo for multi-agent environments (both AECEnv and ParallelEnv environments).
Using it with Gymnasium to convert space invaders to have a grey scale observation space and stack the last 4 frames looks like:
```
import gymnasium
from supersuit import color_reduction_v0, frame_stack_v1
env = gymnasium.make('SpaceInvaders-v0')
env = frame_stack_v1(color_reduction_v0(env, 'full'), 4)
```
Similarly, using SuperSuit with PettingZoo environments looks like
```
from pettingzoo.butterfly import pistonball_v0
env = pistonball_v0.env()
env = frame_stack_v1(color_reduction_v0(env, 'full'), 4)
```
**Please note**: Once the planned wrapper rewrite of Gymnasium is complete and the vector API is stabilized, this project will be deprecated and rewritten as part of a new wrappers package in PettingZoo and the vectorized API will be redone, taking inspiration from the functionality currently in Gymnasium.
## Installing SuperSuit
To install SuperSuit from pypi:
```
python3 -m venv env
source env/bin/activate
pip install --upgrade pip
pip install supersuit
```
Alternatively, to install SuperSuit from source, clone this repo, `cd` to it, and then:
```
python3 -m venv env
source env/bin/activate
pip install --upgrade pip
pip install -e .
```
%package -n python3-SuperSuit
Summary: Wrappers for Gymnasium and PettingZoo
Provides: python-SuperSuit
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-SuperSuit
SuperSuit introduces a collection of small functions which can wrap reinforcement learning environments to do preprocessing ('microwrappers').
We support Gymnasium for single agent environments and PettingZoo for multi-agent environments (both AECEnv and ParallelEnv environments).
Using it with Gymnasium to convert space invaders to have a grey scale observation space and stack the last 4 frames looks like:
```
import gymnasium
from supersuit import color_reduction_v0, frame_stack_v1
env = gymnasium.make('SpaceInvaders-v0')
env = frame_stack_v1(color_reduction_v0(env, 'full'), 4)
```
Similarly, using SuperSuit with PettingZoo environments looks like
```
from pettingzoo.butterfly import pistonball_v0
env = pistonball_v0.env()
env = frame_stack_v1(color_reduction_v0(env, 'full'), 4)
```
**Please note**: Once the planned wrapper rewrite of Gymnasium is complete and the vector API is stabilized, this project will be deprecated and rewritten as part of a new wrappers package in PettingZoo and the vectorized API will be redone, taking inspiration from the functionality currently in Gymnasium.
## Installing SuperSuit
To install SuperSuit from pypi:
```
python3 -m venv env
source env/bin/activate
pip install --upgrade pip
pip install supersuit
```
Alternatively, to install SuperSuit from source, clone this repo, `cd` to it, and then:
```
python3 -m venv env
source env/bin/activate
pip install --upgrade pip
pip install -e .
```
%package help
Summary: Development documents and examples for SuperSuit
Provides: python3-SuperSuit-doc
%description help
SuperSuit introduces a collection of small functions which can wrap reinforcement learning environments to do preprocessing ('microwrappers').
We support Gymnasium for single agent environments and PettingZoo for multi-agent environments (both AECEnv and ParallelEnv environments).
Using it with Gymnasium to convert space invaders to have a grey scale observation space and stack the last 4 frames looks like:
```
import gymnasium
from supersuit import color_reduction_v0, frame_stack_v1
env = gymnasium.make('SpaceInvaders-v0')
env = frame_stack_v1(color_reduction_v0(env, 'full'), 4)
```
Similarly, using SuperSuit with PettingZoo environments looks like
```
from pettingzoo.butterfly import pistonball_v0
env = pistonball_v0.env()
env = frame_stack_v1(color_reduction_v0(env, 'full'), 4)
```
**Please note**: Once the planned wrapper rewrite of Gymnasium is complete and the vector API is stabilized, this project will be deprecated and rewritten as part of a new wrappers package in PettingZoo and the vectorized API will be redone, taking inspiration from the functionality currently in Gymnasium.
## Installing SuperSuit
To install SuperSuit from pypi:
```
python3 -m venv env
source env/bin/activate
pip install --upgrade pip
pip install supersuit
```
Alternatively, to install SuperSuit from source, clone this repo, `cd` to it, and then:
```
python3 -m venv env
source env/bin/activate
pip install --upgrade pip
pip install -e .
```
%prep
%autosetup -n SuperSuit-3.7.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-SuperSuit -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 3.7.2-1
- Package Spec generated