%global _empty_manifest_terminate_build 0
Name: python-apache-airflow-providers-jdbc
Version: 3.3.0
Release: 1
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-jdbc package
License: Apache License 2.0
URL: https://airflow.apache.org/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e1/f2/f5b4a89f357d631a5b08cb08ddc679ed2746810c7580a16cad31519f1e30/apache-airflow-providers-jdbc-3.3.0.tar.gz
BuildArch: noarch
Requires: python3-apache-airflow-providers-common-sql
Requires: python3-apache-airflow
Requires: python3-jaydebeapi
Requires: python3-apache-airflow-providers-common-sql
%description
This is a provider package for ``jdbc`` provider. All classes for this provider package
are in ``airflow.providers.jdbc`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package -n python3-apache-airflow-providers-jdbc
Summary: Provider for Apache Airflow. Implements apache-airflow-providers-jdbc package
Provides: python-apache-airflow-providers-jdbc
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-apache-airflow-providers-jdbc
This is a provider package for ``jdbc`` provider. All classes for this provider package
are in ``airflow.providers.jdbc`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%package help
Summary: Development documents and examples for apache-airflow-providers-jdbc
Provides: python3-apache-airflow-providers-jdbc-doc
%description help
This is a provider package for ``jdbc`` provider. All classes for this provider package
are in ``airflow.providers.jdbc`` python package.
You can find package information and changelog for the provider
in the `documentation `_.
%prep
%autosetup -n apache-airflow-providers-jdbc-3.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-apache-airflow-providers-jdbc -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 3.3.0-1
- Package Spec generated