%global _empty_manifest_terminate_build 0
Name: python-pyreadstat
Version: 1.2.1
Release: 1
Summary: Reads and Writes SAS, SPSS and Stata files into/from pandas data frames.
License: Apache License Version 2.0
URL: https://github.com/Roche/pyreadstat
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fa/09/da9434b5ca5cbb7f04aaeee1cd77340c9482e16424b703c0cabfef5b04f6/pyreadstat-1.2.1.tar.gz
Requires: python3-pandas
%description
A Python package to read and write SAS
(sas7bdat, sas7bcat, xport/xpt), SPSS (sav, zsav, por) and Stata (dta) files into/from pandas data frames. It is a wrapper
around the C library readstat.
Please visit out project home page for more information:
https://github.com/Roche/pyreadstat
%package -n python3-pyreadstat
Summary: Reads and Writes SAS, SPSS and Stata files into/from pandas data frames.
Provides: python-pyreadstat
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-pyreadstat
A Python package to read and write SAS
(sas7bdat, sas7bcat, xport/xpt), SPSS (sav, zsav, por) and Stata (dta) files into/from pandas data frames. It is a wrapper
around the C library readstat.
Please visit out project home page for more information:
https://github.com/Roche/pyreadstat
%package help
Summary: Development documents and examples for pyreadstat
Provides: python3-pyreadstat-doc
%description help
A Python package to read and write SAS
(sas7bdat, sas7bcat, xport/xpt), SPSS (sav, zsav, por) and Stata (dta) files into/from pandas data frames. It is a wrapper
around the C library readstat.
Please visit out project home page for more information:
https://github.com/Roche/pyreadstat
%prep
%autosetup -n pyreadstat-1.2.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyreadstat -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.2.1-1
- Package Spec generated