%global _empty_manifest_terminate_build 0
Name:		python-geog
Version:	0.0.2
Release:	1
Summary:	Numpy-based vectorized geospatial functions
License:	MIT
URL:		https://github.com/jwass/geog
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/cd/04/5cee7294d377214811b7d4d56fbc3da38e9d68e7ec50e53c6fb583a93965/geog-0.0.2.tar.gz
BuildArch:	noarch


%description
A pure numpy implementation for geodesic functions. The interfaces are
vectorized according to numpy broadcasting rules compatible with a variety of
inputs including lists, numpy arrays, and
[Shapely](http://toblerity.org/shapely/) geometries - allowing for 1-to-1,
N-to-1, or the element-wise N-to-N calculations in a single call.
`geog` uses a spherical Earth model (subject to change) with radius 6371.0 km.
`geog` draws inspiration from [TurfJS](https://www.turfjs.org)

%package -n python3-geog
Summary:	Numpy-based vectorized geospatial functions
Provides:	python-geog
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-geog
A pure numpy implementation for geodesic functions. The interfaces are
vectorized according to numpy broadcasting rules compatible with a variety of
inputs including lists, numpy arrays, and
[Shapely](http://toblerity.org/shapely/) geometries - allowing for 1-to-1,
N-to-1, or the element-wise N-to-N calculations in a single call.
`geog` uses a spherical Earth model (subject to change) with radius 6371.0 km.
`geog` draws inspiration from [TurfJS](https://www.turfjs.org)

%package help
Summary:	Development documents and examples for geog
Provides:	python3-geog-doc
%description help
A pure numpy implementation for geodesic functions. The interfaces are
vectorized according to numpy broadcasting rules compatible with a variety of
inputs including lists, numpy arrays, and
[Shapely](http://toblerity.org/shapely/) geometries - allowing for 1-to-1,
N-to-1, or the element-wise N-to-N calculations in a single call.
`geog` uses a spherical Earth model (subject to change) with radius 6371.0 km.
`geog` draws inspiration from [TurfJS](https://www.turfjs.org)

%prep
%autosetup -n geog-0.0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-geog -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.2-1
- Package Spec generated