%global _empty_manifest_terminate_build 0
Name:		python-google-cloud-securitycenter
Version:	1.21.0
Release:	1
Summary:	Google Cloud Securitycenter API client library
License:	Apache 2.0
URL:		https://github.com/googleapis/python-securitycenter
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e6/fe/fc815d9b348a146c00638fdfd52f268981bb4d77f737754683ecd1295e2a/google-cloud-securitycenter-1.21.0.tar.gz
BuildArch:	noarch

Requires:	python3-google-api-core[grpc]
Requires:	python3-proto-plus
Requires:	python3-protobuf
Requires:	python3-grpc-google-iam-v1
Requires:	python3-proto-plus

%description
|stable| |pypi| |versions|
`Google Cloud Security Command Center API`_: makes it easier for you to prevent, detect, and respond to threats. Identify security misconfigurations in virtual machines, networks, applications, and storage buckets from a centralized dashboard. Take action on them before they can potentially result in business damage or loss. Built-in capabilities can quickly surface suspicious activity in your Stackdriver security logs or indicate compromised virtual machines. Respond to threats by following actionable recommendations or exporting logs to your SIEM for further investigation.
- `Client Library Documentation`_
- `Product Documentation`_

%package -n python3-google-cloud-securitycenter
Summary:	Google Cloud Securitycenter API client library
Provides:	python-google-cloud-securitycenter
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-google-cloud-securitycenter
|stable| |pypi| |versions|
`Google Cloud Security Command Center API`_: makes it easier for you to prevent, detect, and respond to threats. Identify security misconfigurations in virtual machines, networks, applications, and storage buckets from a centralized dashboard. Take action on them before they can potentially result in business damage or loss. Built-in capabilities can quickly surface suspicious activity in your Stackdriver security logs or indicate compromised virtual machines. Respond to threats by following actionable recommendations or exporting logs to your SIEM for further investigation.
- `Client Library Documentation`_
- `Product Documentation`_

%package help
Summary:	Development documents and examples for google-cloud-securitycenter
Provides:	python3-google-cloud-securitycenter-doc
%description help
|stable| |pypi| |versions|
`Google Cloud Security Command Center API`_: makes it easier for you to prevent, detect, and respond to threats. Identify security misconfigurations in virtual machines, networks, applications, and storage buckets from a centralized dashboard. Take action on them before they can potentially result in business damage or loss. Built-in capabilities can quickly surface suspicious activity in your Stackdriver security logs or indicate compromised virtual machines. Respond to threats by following actionable recommendations or exporting logs to your SIEM for further investigation.
- `Client Library Documentation`_
- `Product Documentation`_

%prep
%autosetup -n google-cloud-securitycenter-1.21.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-google-cloud-securitycenter -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.21.0-1
- Package Spec generated