%global _empty_manifest_terminate_build 0
Name:		python-data
Version:	0.4
Release:	1
Summary:	Work with unicode/non-unicode data from files or strings uniformly.
License:	MIT
URL:		http://github.com/mbr/data
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ed/e9/623be82fac4250fc614741f5b1ead83d339794f94b19ac8665b6ea12ee05/data-0.4.tar.gz
BuildArch:	noarch


%description
``data`` is a small Python module that allows you to treat input in a singular
way and leave it up to the caller to supply a byte-string, a unicode object, a
file-like or a filename.
    >>> open('helloworld.txt', 'w').write('hello, world from a file')
    >>> from data import Data as I
    >>> a = I(u'hello, world')
    >>> b = I(file='helloworld.txt')
    >>> c = I(open('helloworld.txt'))
    >>> print unicode(a)
    hello, world
    >>> print unicode(b)
    hello, world from a file
    >>> print unicode(c)
    hello, world from a file
This can be made even more convenient using the ``data`` decorator:
    >>> from data.decorators import data
    >>> @data('buf')
    >>> parse_buffer('hello')
    "buf passed in as Data(data='hello', encoding='utf8')"
    >>> rv = parse_buffer(open('helloworld.txt'))
    >>> assert 'file=' in rv

%package -n python3-data
Summary:	Work with unicode/non-unicode data from files or strings uniformly.
Provides:	python-data
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-data
``data`` is a small Python module that allows you to treat input in a singular
way and leave it up to the caller to supply a byte-string, a unicode object, a
file-like or a filename.
    >>> open('helloworld.txt', 'w').write('hello, world from a file')
    >>> from data import Data as I
    >>> a = I(u'hello, world')
    >>> b = I(file='helloworld.txt')
    >>> c = I(open('helloworld.txt'))
    >>> print unicode(a)
    hello, world
    >>> print unicode(b)
    hello, world from a file
    >>> print unicode(c)
    hello, world from a file
This can be made even more convenient using the ``data`` decorator:
    >>> from data.decorators import data
    >>> @data('buf')
    >>> parse_buffer('hello')
    "buf passed in as Data(data='hello', encoding='utf8')"
    >>> rv = parse_buffer(open('helloworld.txt'))
    >>> assert 'file=' in rv

%package help
Summary:	Development documents and examples for data
Provides:	python3-data-doc
%description help
``data`` is a small Python module that allows you to treat input in a singular
way and leave it up to the caller to supply a byte-string, a unicode object, a
file-like or a filename.
    >>> open('helloworld.txt', 'w').write('hello, world from a file')
    >>> from data import Data as I
    >>> a = I(u'hello, world')
    >>> b = I(file='helloworld.txt')
    >>> c = I(open('helloworld.txt'))
    >>> print unicode(a)
    hello, world
    >>> print unicode(b)
    hello, world from a file
    >>> print unicode(c)
    hello, world from a file
This can be made even more convenient using the ``data`` decorator:
    >>> from data.decorators import data
    >>> @data('buf')
    >>> parse_buffer('hello')
    "buf passed in as Data(data='hello', encoding='utf8')"
    >>> rv = parse_buffer(open('helloworld.txt'))
    >>> assert 'file=' in rv

%prep
%autosetup -n data-0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-data -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4-1
- Package Spec generated