%global _empty_manifest_terminate_build 0
Name:		python-pymoo
Version:	0.6.0.1
Release:	1
Summary:	Multi-Objective Optimization in Python
License:	Apache License 2.0
URL:		https://pymoo.org
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c1/cb/b382ee907d83cfb28c0c364155703395abe54688ffa3e1713fe62d90a7cd/pymoo-0.6.0.1.tar.gz

Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-matplotlib
Requires:	python3-autograd
Requires:	python3-cma
Requires:	python3-alive-progress
Requires:	python3-dill
Requires:	python3-Deprecated

%description
Our open-source framework pymoo offers state of the art single- and multi-objective algorithms and many more features
related to multi-objective optimization such as visualization and decision making.
Installation
********************************************************************************
First, make sure you have a Python 3 environment installed. We recommend miniconda3 or anaconda3.
The official release is always available at PyPi:
    pip install -U pymoo
For the current developer version:
    git clone https://github.com/anyoptimization/pymoo
    cd pymoo
    pip install .
Since for speedup, some of the modules are also available compiled, you can double-check
if the compilation worked. When executing the command, be sure not already being in the local pymoo
directory because otherwise not the in site-packages installed version will be used.
    python -c "from pymoo.util.function_loader import is_compiled;print('Compiled Extensions: ', is_compiled())"
Usage
********************************************************************************
We refer here to our documentation for all the details.
However, for instance, executing NSGA2:
    from pymoo.algorithms.moo.nsga2 import NSGA2
    from pymoo.problems import get_problem
    from pymoo.optimize import minimize
    from pymoo.visualization.scatter import Scatter
    problem = get_problem("zdt1")
    algorithm = NSGA2(pop_size=100)
    res = minimize(problem,
                   algorithm,
                   ('n_gen', 200),
                   seed=1,
                   verbose=True)
    plot = Scatter()
    plot.add(problem.pareto_front(), plot_type="line", color="black", alpha=0.7)
    plot.add(res.F, color="red")
    plot.show()
A representative run of NSGA2 looks as follows:
|animation|
Citation
********************************************************************************
If you have used our framework for research purposes, you can cite our publication by:
| `J. Blank and K. Deb, pymoo: Multi-Objective Optimization in Python, in IEEE Access, vol. 8, pp. 89497-89509, 2020, doi: 10.1109/ACCESS.2020.2990567 <https://ieeexplore.ieee.org/document/9078759>`_
|
| BibTex:
    @ARTICLE{pymoo,
        author={J. {Blank} and K. {Deb}},
        journal={IEEE Access},
        title={pymoo: Multi-Objective Optimization in Python},
        year={2020},
        volume={8},
        number={},
        pages={89497-89509},
    }
Contact
********************************************************************************
Feel free to contact me if you have any questions:
| `Julian Blank <http://julianblank.com>`_  (blankjul [at] msu.edu)
| Michigan State University
| Computational Optimization and Innovation Laboratory (COIN)
| East Lansing, MI 48824, USA

%package -n python3-pymoo
Summary:	Multi-Objective Optimization in Python
Provides:	python-pymoo
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-pymoo
Our open-source framework pymoo offers state of the art single- and multi-objective algorithms and many more features
related to multi-objective optimization such as visualization and decision making.
Installation
********************************************************************************
First, make sure you have a Python 3 environment installed. We recommend miniconda3 or anaconda3.
The official release is always available at PyPi:
    pip install -U pymoo
For the current developer version:
    git clone https://github.com/anyoptimization/pymoo
    cd pymoo
    pip install .
Since for speedup, some of the modules are also available compiled, you can double-check
if the compilation worked. When executing the command, be sure not already being in the local pymoo
directory because otherwise not the in site-packages installed version will be used.
    python -c "from pymoo.util.function_loader import is_compiled;print('Compiled Extensions: ', is_compiled())"
Usage
********************************************************************************
We refer here to our documentation for all the details.
However, for instance, executing NSGA2:
    from pymoo.algorithms.moo.nsga2 import NSGA2
    from pymoo.problems import get_problem
    from pymoo.optimize import minimize
    from pymoo.visualization.scatter import Scatter
    problem = get_problem("zdt1")
    algorithm = NSGA2(pop_size=100)
    res = minimize(problem,
                   algorithm,
                   ('n_gen', 200),
                   seed=1,
                   verbose=True)
    plot = Scatter()
    plot.add(problem.pareto_front(), plot_type="line", color="black", alpha=0.7)
    plot.add(res.F, color="red")
    plot.show()
A representative run of NSGA2 looks as follows:
|animation|
Citation
********************************************************************************
If you have used our framework for research purposes, you can cite our publication by:
| `J. Blank and K. Deb, pymoo: Multi-Objective Optimization in Python, in IEEE Access, vol. 8, pp. 89497-89509, 2020, doi: 10.1109/ACCESS.2020.2990567 <https://ieeexplore.ieee.org/document/9078759>`_
|
| BibTex:
    @ARTICLE{pymoo,
        author={J. {Blank} and K. {Deb}},
        journal={IEEE Access},
        title={pymoo: Multi-Objective Optimization in Python},
        year={2020},
        volume={8},
        number={},
        pages={89497-89509},
    }
Contact
********************************************************************************
Feel free to contact me if you have any questions:
| `Julian Blank <http://julianblank.com>`_  (blankjul [at] msu.edu)
| Michigan State University
| Computational Optimization and Innovation Laboratory (COIN)
| East Lansing, MI 48824, USA

%package help
Summary:	Development documents and examples for pymoo
Provides:	python3-pymoo-doc
%description help
Our open-source framework pymoo offers state of the art single- and multi-objective algorithms and many more features
related to multi-objective optimization such as visualization and decision making.
Installation
********************************************************************************
First, make sure you have a Python 3 environment installed. We recommend miniconda3 or anaconda3.
The official release is always available at PyPi:
    pip install -U pymoo
For the current developer version:
    git clone https://github.com/anyoptimization/pymoo
    cd pymoo
    pip install .
Since for speedup, some of the modules are also available compiled, you can double-check
if the compilation worked. When executing the command, be sure not already being in the local pymoo
directory because otherwise not the in site-packages installed version will be used.
    python -c "from pymoo.util.function_loader import is_compiled;print('Compiled Extensions: ', is_compiled())"
Usage
********************************************************************************
We refer here to our documentation for all the details.
However, for instance, executing NSGA2:
    from pymoo.algorithms.moo.nsga2 import NSGA2
    from pymoo.problems import get_problem
    from pymoo.optimize import minimize
    from pymoo.visualization.scatter import Scatter
    problem = get_problem("zdt1")
    algorithm = NSGA2(pop_size=100)
    res = minimize(problem,
                   algorithm,
                   ('n_gen', 200),
                   seed=1,
                   verbose=True)
    plot = Scatter()
    plot.add(problem.pareto_front(), plot_type="line", color="black", alpha=0.7)
    plot.add(res.F, color="red")
    plot.show()
A representative run of NSGA2 looks as follows:
|animation|
Citation
********************************************************************************
If you have used our framework for research purposes, you can cite our publication by:
| `J. Blank and K. Deb, pymoo: Multi-Objective Optimization in Python, in IEEE Access, vol. 8, pp. 89497-89509, 2020, doi: 10.1109/ACCESS.2020.2990567 <https://ieeexplore.ieee.org/document/9078759>`_
|
| BibTex:
    @ARTICLE{pymoo,
        author={J. {Blank} and K. {Deb}},
        journal={IEEE Access},
        title={pymoo: Multi-Objective Optimization in Python},
        year={2020},
        volume={8},
        number={},
        pages={89497-89509},
    }
Contact
********************************************************************************
Feel free to contact me if you have any questions:
| `Julian Blank <http://julianblank.com>`_  (blankjul [at] msu.edu)
| Michigan State University
| Computational Optimization and Innovation Laboratory (COIN)
| East Lansing, MI 48824, USA

%prep
%autosetup -n pymoo-0.6.0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pymoo -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0.1-1
- Package Spec generated