%global _empty_manifest_terminate_build 0
Name:		python-apache-airflow-providers-jenkins
Version:	3.2.1
Release:	1
Summary:	Provider for Apache Airflow. Implements apache-airflow-providers-jenkins package
License:	Apache License 2.0
URL:		https://airflow.apache.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b2/b0/eb584ddffd6ba96bedb3e13a9607eeaf1b05ca95689edc9459cdebc267d5/apache-airflow-providers-jenkins-3.2.1.tar.gz
BuildArch:	noarch

Requires:	python3-apache-airflow
Requires:	python3-jenkins

%description
This is a provider package for ``jenkins`` provider. All classes for this provider package
are in ``airflow.providers.jenkins`` python package.
You can find package information and changelog for the provider
in the `documentation <https://airflow.apache.org/docs/apache-airflow-providers-jenkins/3.2.1/>`_.

%package -n python3-apache-airflow-providers-jenkins
Summary:	Provider for Apache Airflow. Implements apache-airflow-providers-jenkins package
Provides:	python-apache-airflow-providers-jenkins
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-apache-airflow-providers-jenkins
This is a provider package for ``jenkins`` provider. All classes for this provider package
are in ``airflow.providers.jenkins`` python package.
You can find package information and changelog for the provider
in the `documentation <https://airflow.apache.org/docs/apache-airflow-providers-jenkins/3.2.1/>`_.

%package help
Summary:	Development documents and examples for apache-airflow-providers-jenkins
Provides:	python3-apache-airflow-providers-jenkins-doc
%description help
This is a provider package for ``jenkins`` provider. All classes for this provider package
are in ``airflow.providers.jenkins`` python package.
You can find package information and changelog for the provider
in the `documentation <https://airflow.apache.org/docs/apache-airflow-providers-jenkins/3.2.1/>`_.

%prep
%autosetup -n apache-airflow-providers-jenkins-3.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-apache-airflow-providers-jenkins -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.1-1
- Package Spec generated