%global _empty_manifest_terminate_build 0
Name: python-selectolax
Version: 0.3.12
Release: 1
Summary: Fast HTML5 parser with CSS selectors.
License: MIT license
URL: https://github.com/rushter/selectolax
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/29/5939f583c89c8c0785e1e97c5e240ba559b6d22a5206444fafef13ad5b58/selectolax-0.3.12.tar.gz
Requires: python3-Cython
%description
A fast HTML5 parser with CSS selectors using `Modest `_ and
`Lexbor `_ engines.
%package -n python3-selectolax
Summary: Fast HTML5 parser with CSS selectors.
Provides: python-selectolax
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-selectolax
A fast HTML5 parser with CSS selectors using `Modest `_ and
`Lexbor `_ engines.
%package help
Summary: Development documents and examples for selectolax
Provides: python3-selectolax-doc
%description help
A fast HTML5 parser with CSS selectors using `Modest `_ and
`Lexbor `_ engines.
%prep
%autosetup -n selectolax-0.3.12
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-selectolax -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.3.12-1
- Package Spec generated