%global _empty_manifest_terminate_build 0 Name: python-resnest Version: 0.0.5 Release: 1 Summary: ResNeSt License: Apache-2.0 URL: https://github.com/zhanghang1989/ResNeSt Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ab/71/bae271e8467f3eb5c917cc688a54c8413bc793c0d033f60c466670fba4ba/resnest-0.0.5.tar.gz BuildArch: noarch Requires: python3-numpy Requires: python3-tqdm Requires: python3-nose Requires: python3-torch Requires: python3-Pillow Requires: python3-scipy Requires: python3-requests %description [![PyPI](https://img.shields.io/pypi/v/resnest.svg)](https://pypi.python.org/pypi/resnest) [![PyPI Pre-release](https://img.shields.io/badge/pypi--prerelease-v0.0.5-ff69b4.svg)](https://pypi.org/project/resnest/#history) [![PyPI Nightly](https://github.com/zhanghang1989/ResNeSt/workflows/Pypi%20Nightly/badge.svg)](https://github.com/zhanghang1989/ResNeSt/actions) [![Downloads](http://pepy.tech/badge/resnest)](http://pepy.tech/project/resnest) [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0) [![Unit Test](https://github.com/zhanghang1989/ResNeSt/workflows/Unit%20Test/badge.svg)](https://github.com/zhanghang1989/ResNeSt/actions) [![arXiv](http://img.shields.io/badge/cs.CV-arXiv%3A2004.08955-B31B1B.svg)](https://arxiv.org/abs/2004.08955) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/instance-segmentation-on-coco)](https://paperswithcode.com/sota/instance-segmentation-on-coco?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/object-detection-on-coco)](https://paperswithcode.com/sota/object-detection-on-coco?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/panoptic-segmentation-on-coco-panoptic)](https://paperswithcode.com/sota/panoptic-segmentation-on-coco-panoptic?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-ade20k)](https://paperswithcode.com/sota/semantic-segmentation-on-ade20k?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-cityscapes-val)](https://paperswithcode.com/sota/semantic-segmentation-on-cityscapes-val?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-pascal-context)](https://paperswithcode.com/sota/semantic-segmentation-on-pascal-context?p=resnest-split-attention-networks) # ResNeSt Split-Attention Network, A New ResNet Variant. It significantly boosts the performance of downstream models such as Mask R-CNN, Cascade R-CNN and DeepLabV3. ![](./miscs/abstract.jpg) ### Table of Contents 0. [Pretrained Models](#pretrained-models) 0. [Transfer Learning Models](#transfer-learning-models) 0. [Verify Backbone Models](#verify-backbone-models) 0. [How to Train](#how-to-train) 0. [Reference](#reference) ### Pypi / GitHub Install 0. Install this package repo, note that you only need to choose one of the options ```bash # using github url pip install git+https://github.com/zhanghang1989/ResNeSt # using pypi pip install resnest --pre ``` ## Pretrained Models | | crop size | PyTorch | Gluon | |-------------|-----------|---------|-------| | ResNeSt-50 | 224 | 81.03 | 81.04 | | ResNeSt-101 | 256 | 82.83 | 82.81 | | ResNeSt-200 | 320 | 83.84 | 83.88 | | ResNeSt-269 | 416 | 84.54 | 84.53 | - **3rd party implementations** are available: [Tensorflow](https://github.com/QiaoranC/tf_ResNeSt_RegNet_model), [Caffe](https://github.com/NetEase-GameAI/ResNeSt-caffe). - Extra ablation study models are available in [link](./ablation.md) ### PyTorch Models - Load using Torch Hub ```python import torch # get list of models torch.hub.list('zhanghang1989/ResNeSt', force_reload=True) # load pretrained models, using ResNeSt-50 as an example net = torch.hub.load('zhanghang1989/ResNeSt', 'resnest50', pretrained=True) ``` - Load using python package ```python # using ResNeSt-50 as an example from resnest.torch import resnest50 net = resnest50(pretrained=True) ``` ### Gluon Models - Load pretrained model: ```python # using ResNeSt-50 as an example from resnest.gluon import resnest50 net = resnest50(pretrained=True) ``` ## Transfer Learning Models ### Detectron Models Training code and pretrained models are released at our [Detectron2 Fork](https://github.com/zhanghang1989/detectron2-ResNeSt). #### Object Detection on MS-COCO validation set
Method Backbone mAP%
Faster R-CNN ResNet-50 39.25
ResNet-101 41.37
ResNeSt-50 (ours) 42.33
ResNeSt-101 (ours) 44.72
Cascade R-CNN ResNet-50 42.52
ResNet-101 44.03
ResNeSt-50 (ours) 45.41
ResNeSt-101 (ours) 47.50
ResNeSt-200 (ours) 49.03
#### Instance Segmentation
Method Backbone bbox mask
Mask R-CNN ResNet-50 39.97 36.05
ResNet-101 41.78 37.51
ResNeSt-50 (ours) 42.81 38.14
ResNeSt-101 (ours) 45.75 40.65
Cascade R-CNN ResNet-50 43.06 37.19
ResNet-101 44.79 38.52
ResNeSt-50 (ours) 46.19 39.55
ResNeSt-101 (ours) 48.30 41.56
ResNeSt-200 (w/ tricks ours) 50.54 44.21
ResNeSt-200-dcn (w/ tricks ours) 50.91 44.50
53.30* 47.10*
All of results are reported on COCO-2017 validation dataset. The values with * demonstrate the mutli-scale testing performance on the test-dev2019. ## Panoptic Segmentation
Backbone bbox mask PQ
ResNeSt-200 51.00 43.68 47.90
### Semantic Segmentation - PyTorch models and training: Please visit [PyTorch Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/segmentation.html). - Training with Gluon: Please visit [GluonCV Toolkit](https://gluon-cv.mxnet.io/model_zoo/segmentation.html#ade20k-dataset). #### Results on ADE20K
Method Backbone pixAcc% mIoU%
Deeplab-V3
ResNet-50 80.39 42.1
ResNet-101 81.11 44.14
ResNeSt-50 (ours) 81.17 45.12
ResNeSt-101 (ours) 82.07 46.91
ResNeSt-200 (ours) 82.45 48.36
ResNeSt-269 (ours) 82.62 47.60
#### Results on Cityscapes
Method Backbone Split w Mapillary mIoU%
Deeplab-V3+
ResNeSt-200 (ours) Validation no 82.7
ResNeSt-200 (ours) Validation yes 83.8
ResNeSt-200 (ours) Test yes 83.3
## Verify Backbone Models: **Note:** the inference speed reported in the paper are tested using Gluon implementation with RecordIO data. ### Prepare ImageNet dataset: Here we use raw image data format for simplicity, please follow [GluonCV tutorial](https://gluon-cv.mxnet.io/build/examples_datasets/recordio.html) if you would like to use RecordIO format. ```bash cd scripts/dataset/ # assuming you have downloaded the dataset in the current folder python prepare_imagenet.py --download-dir ./ ``` ### Torch Model ```bash # use resnest50 as an example cd scripts/torch/ python verify.py --model resnest50 --crop-size 224 ``` ### Gluon Model ```bash # use resnest50 as an example cd scripts/gluon/ python verify.py --model resnest50 --crop-size 224 ``` ## How to Train ### ImageNet Models - Training with MXNet Gluon: Please visit [Gluon folder](./scripts/gluon/). - Training with PyTorch: Please visit [PyTorch Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/imagenet.html) (slightly worse than Gluon implementation). ### Detectron Models For object detection and instance segmentation models, please visit our [detectron2-ResNeSt fork](https://github.com/zhanghang1989/detectron2-ResNeSt). ### Semantic Segmentation - Training with PyTorch: [Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/segmentation.html). - Training with MXNet: [GluonCV Toolkit](https://gluon-cv.mxnet.io/model_zoo/segmentation.html#ade20k-dataset). ## Reference **ResNeSt: Split-Attention Networks** [[arXiv](https://arxiv.org/pdf/2004.08955.pdf)] Hang Zhang, Chongruo Wu, Zhongyue Zhang, Yi Zhu, Zhi Zhang, Haibin Lin, Yue Sun, Tong He, Jonas Muller, R. Manmatha, Mu Li and Alex Smola ``` @article{zhang2020resnest, title={ResNeSt: Split-Attention Networks}, author={Zhang, Hang and Wu, Chongruo and Zhang, Zhongyue and Zhu, Yi and Zhang, Zhi and Lin, Haibin and Sun, Yue and He, Tong and Muller, Jonas and Manmatha, R. and Li, Mu and Smola, Alexander}, journal={arXiv preprint arXiv:2004.08955}, year={2020} } ``` ### Major Contributors - ResNeSt Backbone ([Hang Zhang](https://hangzhang.org/)) - Detectron Models ([Chongruo Wu](https://github.com/chongruo), [Zhongyue Zhang](http://zhongyuezhang.com/)) - Semantic Segmentation ([Yi Zhu](https://sites.google.com/view/yizhu/home)) - Distributed Training ([Haibin Lin](https://sites.google.com/view/haibinlin/)) %package -n python3-resnest Summary: ResNeSt Provides: python-resnest BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-resnest [![PyPI](https://img.shields.io/pypi/v/resnest.svg)](https://pypi.python.org/pypi/resnest) [![PyPI Pre-release](https://img.shields.io/badge/pypi--prerelease-v0.0.5-ff69b4.svg)](https://pypi.org/project/resnest/#history) [![PyPI Nightly](https://github.com/zhanghang1989/ResNeSt/workflows/Pypi%20Nightly/badge.svg)](https://github.com/zhanghang1989/ResNeSt/actions) [![Downloads](http://pepy.tech/badge/resnest)](http://pepy.tech/project/resnest) [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0) [![Unit Test](https://github.com/zhanghang1989/ResNeSt/workflows/Unit%20Test/badge.svg)](https://github.com/zhanghang1989/ResNeSt/actions) [![arXiv](http://img.shields.io/badge/cs.CV-arXiv%3A2004.08955-B31B1B.svg)](https://arxiv.org/abs/2004.08955) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/instance-segmentation-on-coco)](https://paperswithcode.com/sota/instance-segmentation-on-coco?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/object-detection-on-coco)](https://paperswithcode.com/sota/object-detection-on-coco?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/panoptic-segmentation-on-coco-panoptic)](https://paperswithcode.com/sota/panoptic-segmentation-on-coco-panoptic?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-ade20k)](https://paperswithcode.com/sota/semantic-segmentation-on-ade20k?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-cityscapes-val)](https://paperswithcode.com/sota/semantic-segmentation-on-cityscapes-val?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-pascal-context)](https://paperswithcode.com/sota/semantic-segmentation-on-pascal-context?p=resnest-split-attention-networks) # ResNeSt Split-Attention Network, A New ResNet Variant. It significantly boosts the performance of downstream models such as Mask R-CNN, Cascade R-CNN and DeepLabV3. ![](./miscs/abstract.jpg) ### Table of Contents 0. [Pretrained Models](#pretrained-models) 0. [Transfer Learning Models](#transfer-learning-models) 0. [Verify Backbone Models](#verify-backbone-models) 0. [How to Train](#how-to-train) 0. [Reference](#reference) ### Pypi / GitHub Install 0. Install this package repo, note that you only need to choose one of the options ```bash # using github url pip install git+https://github.com/zhanghang1989/ResNeSt # using pypi pip install resnest --pre ``` ## Pretrained Models | | crop size | PyTorch | Gluon | |-------------|-----------|---------|-------| | ResNeSt-50 | 224 | 81.03 | 81.04 | | ResNeSt-101 | 256 | 82.83 | 82.81 | | ResNeSt-200 | 320 | 83.84 | 83.88 | | ResNeSt-269 | 416 | 84.54 | 84.53 | - **3rd party implementations** are available: [Tensorflow](https://github.com/QiaoranC/tf_ResNeSt_RegNet_model), [Caffe](https://github.com/NetEase-GameAI/ResNeSt-caffe). - Extra ablation study models are available in [link](./ablation.md) ### PyTorch Models - Load using Torch Hub ```python import torch # get list of models torch.hub.list('zhanghang1989/ResNeSt', force_reload=True) # load pretrained models, using ResNeSt-50 as an example net = torch.hub.load('zhanghang1989/ResNeSt', 'resnest50', pretrained=True) ``` - Load using python package ```python # using ResNeSt-50 as an example from resnest.torch import resnest50 net = resnest50(pretrained=True) ``` ### Gluon Models - Load pretrained model: ```python # using ResNeSt-50 as an example from resnest.gluon import resnest50 net = resnest50(pretrained=True) ``` ## Transfer Learning Models ### Detectron Models Training code and pretrained models are released at our [Detectron2 Fork](https://github.com/zhanghang1989/detectron2-ResNeSt). #### Object Detection on MS-COCO validation set
Method Backbone mAP%
Faster R-CNN ResNet-50 39.25
ResNet-101 41.37
ResNeSt-50 (ours) 42.33
ResNeSt-101 (ours) 44.72
Cascade R-CNN ResNet-50 42.52
ResNet-101 44.03
ResNeSt-50 (ours) 45.41
ResNeSt-101 (ours) 47.50
ResNeSt-200 (ours) 49.03
#### Instance Segmentation
Method Backbone bbox mask
Mask R-CNN ResNet-50 39.97 36.05
ResNet-101 41.78 37.51
ResNeSt-50 (ours) 42.81 38.14
ResNeSt-101 (ours) 45.75 40.65
Cascade R-CNN ResNet-50 43.06 37.19
ResNet-101 44.79 38.52
ResNeSt-50 (ours) 46.19 39.55
ResNeSt-101 (ours) 48.30 41.56
ResNeSt-200 (w/ tricks ours) 50.54 44.21
ResNeSt-200-dcn (w/ tricks ours) 50.91 44.50
53.30* 47.10*
All of results are reported on COCO-2017 validation dataset. The values with * demonstrate the mutli-scale testing performance on the test-dev2019. ## Panoptic Segmentation
Backbone bbox mask PQ
ResNeSt-200 51.00 43.68 47.90
### Semantic Segmentation - PyTorch models and training: Please visit [PyTorch Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/segmentation.html). - Training with Gluon: Please visit [GluonCV Toolkit](https://gluon-cv.mxnet.io/model_zoo/segmentation.html#ade20k-dataset). #### Results on ADE20K
Method Backbone pixAcc% mIoU%
Deeplab-V3
ResNet-50 80.39 42.1
ResNet-101 81.11 44.14
ResNeSt-50 (ours) 81.17 45.12
ResNeSt-101 (ours) 82.07 46.91
ResNeSt-200 (ours) 82.45 48.36
ResNeSt-269 (ours) 82.62 47.60
#### Results on Cityscapes
Method Backbone Split w Mapillary mIoU%
Deeplab-V3+
ResNeSt-200 (ours) Validation no 82.7
ResNeSt-200 (ours) Validation yes 83.8
ResNeSt-200 (ours) Test yes 83.3
## Verify Backbone Models: **Note:** the inference speed reported in the paper are tested using Gluon implementation with RecordIO data. ### Prepare ImageNet dataset: Here we use raw image data format for simplicity, please follow [GluonCV tutorial](https://gluon-cv.mxnet.io/build/examples_datasets/recordio.html) if you would like to use RecordIO format. ```bash cd scripts/dataset/ # assuming you have downloaded the dataset in the current folder python prepare_imagenet.py --download-dir ./ ``` ### Torch Model ```bash # use resnest50 as an example cd scripts/torch/ python verify.py --model resnest50 --crop-size 224 ``` ### Gluon Model ```bash # use resnest50 as an example cd scripts/gluon/ python verify.py --model resnest50 --crop-size 224 ``` ## How to Train ### ImageNet Models - Training with MXNet Gluon: Please visit [Gluon folder](./scripts/gluon/). - Training with PyTorch: Please visit [PyTorch Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/imagenet.html) (slightly worse than Gluon implementation). ### Detectron Models For object detection and instance segmentation models, please visit our [detectron2-ResNeSt fork](https://github.com/zhanghang1989/detectron2-ResNeSt). ### Semantic Segmentation - Training with PyTorch: [Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/segmentation.html). - Training with MXNet: [GluonCV Toolkit](https://gluon-cv.mxnet.io/model_zoo/segmentation.html#ade20k-dataset). ## Reference **ResNeSt: Split-Attention Networks** [[arXiv](https://arxiv.org/pdf/2004.08955.pdf)] Hang Zhang, Chongruo Wu, Zhongyue Zhang, Yi Zhu, Zhi Zhang, Haibin Lin, Yue Sun, Tong He, Jonas Muller, R. Manmatha, Mu Li and Alex Smola ``` @article{zhang2020resnest, title={ResNeSt: Split-Attention Networks}, author={Zhang, Hang and Wu, Chongruo and Zhang, Zhongyue and Zhu, Yi and Zhang, Zhi and Lin, Haibin and Sun, Yue and He, Tong and Muller, Jonas and Manmatha, R. and Li, Mu and Smola, Alexander}, journal={arXiv preprint arXiv:2004.08955}, year={2020} } ``` ### Major Contributors - ResNeSt Backbone ([Hang Zhang](https://hangzhang.org/)) - Detectron Models ([Chongruo Wu](https://github.com/chongruo), [Zhongyue Zhang](http://zhongyuezhang.com/)) - Semantic Segmentation ([Yi Zhu](https://sites.google.com/view/yizhu/home)) - Distributed Training ([Haibin Lin](https://sites.google.com/view/haibinlin/)) %package help Summary: Development documents and examples for resnest Provides: python3-resnest-doc %description help [![PyPI](https://img.shields.io/pypi/v/resnest.svg)](https://pypi.python.org/pypi/resnest) [![PyPI Pre-release](https://img.shields.io/badge/pypi--prerelease-v0.0.5-ff69b4.svg)](https://pypi.org/project/resnest/#history) [![PyPI Nightly](https://github.com/zhanghang1989/ResNeSt/workflows/Pypi%20Nightly/badge.svg)](https://github.com/zhanghang1989/ResNeSt/actions) [![Downloads](http://pepy.tech/badge/resnest)](http://pepy.tech/project/resnest) [![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0) [![Unit Test](https://github.com/zhanghang1989/ResNeSt/workflows/Unit%20Test/badge.svg)](https://github.com/zhanghang1989/ResNeSt/actions) [![arXiv](http://img.shields.io/badge/cs.CV-arXiv%3A2004.08955-B31B1B.svg)](https://arxiv.org/abs/2004.08955) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/instance-segmentation-on-coco)](https://paperswithcode.com/sota/instance-segmentation-on-coco?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/object-detection-on-coco)](https://paperswithcode.com/sota/object-detection-on-coco?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/panoptic-segmentation-on-coco-panoptic)](https://paperswithcode.com/sota/panoptic-segmentation-on-coco-panoptic?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-ade20k)](https://paperswithcode.com/sota/semantic-segmentation-on-ade20k?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-cityscapes-val)](https://paperswithcode.com/sota/semantic-segmentation-on-cityscapes-val?p=resnest-split-attention-networks) [![PWC](https://img.shields.io/endpoint.svg?url=https://paperswithcode.com/badge/resnest-split-attention-networks/semantic-segmentation-on-pascal-context)](https://paperswithcode.com/sota/semantic-segmentation-on-pascal-context?p=resnest-split-attention-networks) # ResNeSt Split-Attention Network, A New ResNet Variant. It significantly boosts the performance of downstream models such as Mask R-CNN, Cascade R-CNN and DeepLabV3. ![](./miscs/abstract.jpg) ### Table of Contents 0. [Pretrained Models](#pretrained-models) 0. [Transfer Learning Models](#transfer-learning-models) 0. [Verify Backbone Models](#verify-backbone-models) 0. [How to Train](#how-to-train) 0. [Reference](#reference) ### Pypi / GitHub Install 0. Install this package repo, note that you only need to choose one of the options ```bash # using github url pip install git+https://github.com/zhanghang1989/ResNeSt # using pypi pip install resnest --pre ``` ## Pretrained Models | | crop size | PyTorch | Gluon | |-------------|-----------|---------|-------| | ResNeSt-50 | 224 | 81.03 | 81.04 | | ResNeSt-101 | 256 | 82.83 | 82.81 | | ResNeSt-200 | 320 | 83.84 | 83.88 | | ResNeSt-269 | 416 | 84.54 | 84.53 | - **3rd party implementations** are available: [Tensorflow](https://github.com/QiaoranC/tf_ResNeSt_RegNet_model), [Caffe](https://github.com/NetEase-GameAI/ResNeSt-caffe). - Extra ablation study models are available in [link](./ablation.md) ### PyTorch Models - Load using Torch Hub ```python import torch # get list of models torch.hub.list('zhanghang1989/ResNeSt', force_reload=True) # load pretrained models, using ResNeSt-50 as an example net = torch.hub.load('zhanghang1989/ResNeSt', 'resnest50', pretrained=True) ``` - Load using python package ```python # using ResNeSt-50 as an example from resnest.torch import resnest50 net = resnest50(pretrained=True) ``` ### Gluon Models - Load pretrained model: ```python # using ResNeSt-50 as an example from resnest.gluon import resnest50 net = resnest50(pretrained=True) ``` ## Transfer Learning Models ### Detectron Models Training code and pretrained models are released at our [Detectron2 Fork](https://github.com/zhanghang1989/detectron2-ResNeSt). #### Object Detection on MS-COCO validation set
Method Backbone mAP%
Faster R-CNN ResNet-50 39.25
ResNet-101 41.37
ResNeSt-50 (ours) 42.33
ResNeSt-101 (ours) 44.72
Cascade R-CNN ResNet-50 42.52
ResNet-101 44.03
ResNeSt-50 (ours) 45.41
ResNeSt-101 (ours) 47.50
ResNeSt-200 (ours) 49.03
#### Instance Segmentation
Method Backbone bbox mask
Mask R-CNN ResNet-50 39.97 36.05
ResNet-101 41.78 37.51
ResNeSt-50 (ours) 42.81 38.14
ResNeSt-101 (ours) 45.75 40.65
Cascade R-CNN ResNet-50 43.06 37.19
ResNet-101 44.79 38.52
ResNeSt-50 (ours) 46.19 39.55
ResNeSt-101 (ours) 48.30 41.56
ResNeSt-200 (w/ tricks ours) 50.54 44.21
ResNeSt-200-dcn (w/ tricks ours) 50.91 44.50
53.30* 47.10*
All of results are reported on COCO-2017 validation dataset. The values with * demonstrate the mutli-scale testing performance on the test-dev2019. ## Panoptic Segmentation
Backbone bbox mask PQ
ResNeSt-200 51.00 43.68 47.90
### Semantic Segmentation - PyTorch models and training: Please visit [PyTorch Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/segmentation.html). - Training with Gluon: Please visit [GluonCV Toolkit](https://gluon-cv.mxnet.io/model_zoo/segmentation.html#ade20k-dataset). #### Results on ADE20K
Method Backbone pixAcc% mIoU%
Deeplab-V3
ResNet-50 80.39 42.1
ResNet-101 81.11 44.14
ResNeSt-50 (ours) 81.17 45.12
ResNeSt-101 (ours) 82.07 46.91
ResNeSt-200 (ours) 82.45 48.36
ResNeSt-269 (ours) 82.62 47.60
#### Results on Cityscapes
Method Backbone Split w Mapillary mIoU%
Deeplab-V3+
ResNeSt-200 (ours) Validation no 82.7
ResNeSt-200 (ours) Validation yes 83.8
ResNeSt-200 (ours) Test yes 83.3
## Verify Backbone Models: **Note:** the inference speed reported in the paper are tested using Gluon implementation with RecordIO data. ### Prepare ImageNet dataset: Here we use raw image data format for simplicity, please follow [GluonCV tutorial](https://gluon-cv.mxnet.io/build/examples_datasets/recordio.html) if you would like to use RecordIO format. ```bash cd scripts/dataset/ # assuming you have downloaded the dataset in the current folder python prepare_imagenet.py --download-dir ./ ``` ### Torch Model ```bash # use resnest50 as an example cd scripts/torch/ python verify.py --model resnest50 --crop-size 224 ``` ### Gluon Model ```bash # use resnest50 as an example cd scripts/gluon/ python verify.py --model resnest50 --crop-size 224 ``` ## How to Train ### ImageNet Models - Training with MXNet Gluon: Please visit [Gluon folder](./scripts/gluon/). - Training with PyTorch: Please visit [PyTorch Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/imagenet.html) (slightly worse than Gluon implementation). ### Detectron Models For object detection and instance segmentation models, please visit our [detectron2-ResNeSt fork](https://github.com/zhanghang1989/detectron2-ResNeSt). ### Semantic Segmentation - Training with PyTorch: [Encoding Toolkit](https://hangzhang.org/PyTorch-Encoding/model_zoo/segmentation.html). - Training with MXNet: [GluonCV Toolkit](https://gluon-cv.mxnet.io/model_zoo/segmentation.html#ade20k-dataset). ## Reference **ResNeSt: Split-Attention Networks** [[arXiv](https://arxiv.org/pdf/2004.08955.pdf)] Hang Zhang, Chongruo Wu, Zhongyue Zhang, Yi Zhu, Zhi Zhang, Haibin Lin, Yue Sun, Tong He, Jonas Muller, R. Manmatha, Mu Li and Alex Smola ``` @article{zhang2020resnest, title={ResNeSt: Split-Attention Networks}, author={Zhang, Hang and Wu, Chongruo and Zhang, Zhongyue and Zhu, Yi and Zhang, Zhi and Lin, Haibin and Sun, Yue and He, Tong and Muller, Jonas and Manmatha, R. and Li, Mu and Smola, Alexander}, journal={arXiv preprint arXiv:2004.08955}, year={2020} } ``` ### Major Contributors - ResNeSt Backbone ([Hang Zhang](https://hangzhang.org/)) - Detectron Models ([Chongruo Wu](https://github.com/chongruo), [Zhongyue Zhang](http://zhongyuezhang.com/)) - Semantic Segmentation ([Yi Zhu](https://sites.google.com/view/yizhu/home)) - Distributed Training ([Haibin Lin](https://sites.google.com/view/haibinlin/)) %prep %autosetup -n resnest-0.0.5 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-resnest -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Sun Apr 23 2023 Python_Bot - 0.0.5-1 - Package Spec generated