%global _empty_manifest_terminate_build 0
Name:		python-django-sequences
Version:	2.7
Release:	1
Summary:	Generate gapless sequences of integer values.
License:	BSD-3-Clause
URL:		https://github.com/aaugustin/django-sequences
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/1a/b9/e9e47563ffe1e72ab874f50754715fab945f8358c44a93e122097a636100/django-sequences-2.7.tar.gz
BuildArch:	noarch

Requires:	python3-django

%description
* `Getting started`_
* `Database support`_
* `Multiple databases`_
* `Isolation levels`_
* `Contributing`_
* `Releasing`_
* `Changelog`_

%package -n python3-django-sequences
Summary:	Generate gapless sequences of integer values.
Provides:	python-django-sequences
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-sequences
* `Getting started`_
* `Database support`_
* `Multiple databases`_
* `Isolation levels`_
* `Contributing`_
* `Releasing`_
* `Changelog`_

%package help
Summary:	Development documents and examples for django-sequences
Provides:	python3-django-sequences-doc
%description help
* `Getting started`_
* `Database support`_
* `Multiple databases`_
* `Isolation levels`_
* `Contributing`_
* `Releasing`_
* `Changelog`_

%prep
%autosetup -n django-sequences-2.7

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-sequences -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 2.7-1
- Package Spec generated