%global _empty_manifest_terminate_build 0
Name: python-sqlmodel
Version: 0.0.8
Release: 1
Summary: SQLModel, SQL databases in Python, designed for simplicity, compatibility, and robustness.
License: MIT
URL: https://github.com/tiangolo/sqlmodel
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/64/ba/ad07004536e94e71f99aaae5e667bb6f7230f7e0fbc0b0266e88960dda5f/sqlmodel-0.0.8.tar.gz
BuildArch: noarch
Requires: python3-SQLAlchemy
Requires: python3-pydantic
Requires: python3-sqlalchemy2-stubs
%description
**Documentation**: https://sqlmodel.tiangolo.com
%package -n python3-sqlmodel
Summary: SQLModel, SQL databases in Python, designed for simplicity, compatibility, and robustness.
Provides: python-sqlmodel
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-sqlmodel
**Documentation**: https://sqlmodel.tiangolo.com
%package help
Summary: Development documents and examples for sqlmodel
Provides: python3-sqlmodel-doc
%description help
**Documentation**: https://sqlmodel.tiangolo.com
%prep
%autosetup -n sqlmodel-0.0.8
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-sqlmodel -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.0.8-1
- Package Spec generated