%global _empty_manifest_terminate_build 0
Name:		python-orange-widget-base
Version:	4.20.0
Release:	1
Summary:	Base Widget for Orange Canvas
License:	GPLv3+
URL:		http://orange.biolab.si/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/31/e5/35313760abd04a9ab16eb186d5afa50cc7c72774a17fdf4a2fc153e9976b/orange-widget-base-4.20.0.tar.gz
BuildArch:	noarch

Requires:	python3-matplotlib
Requires:	python3-pyqtgraph
Requires:	python3-AnyQt
Requires:	python3-typing-extensions
Requires:	python3-orange-canvas-core
Requires:	python3-appnope

%description

This project implements the base OWBaseWidget class and utilities for use in
Orange Canvas workflows.

Provides:

    * `OWBaseWidget` class
    * `gui` module for building GUI
    * `WidgetsScheme` the workflow execution model/bridge
    * basic configuration for a workflow based application



%package -n python3-orange-widget-base
Summary:	Base Widget for Orange Canvas
Provides:	python-orange-widget-base
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-orange-widget-base

This project implements the base OWBaseWidget class and utilities for use in
Orange Canvas workflows.

Provides:

    * `OWBaseWidget` class
    * `gui` module for building GUI
    * `WidgetsScheme` the workflow execution model/bridge
    * basic configuration for a workflow based application



%package help
Summary:	Development documents and examples for orange-widget-base
Provides:	python3-orange-widget-base-doc
%description help

This project implements the base OWBaseWidget class and utilities for use in
Orange Canvas workflows.

Provides:

    * `OWBaseWidget` class
    * `gui` module for building GUI
    * `WidgetsScheme` the workflow execution model/bridge
    * basic configuration for a workflow based application



%prep
%autosetup -n orange-widget-base-4.20.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-orange-widget-base -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 4.20.0-1
- Package Spec generated