%global _empty_manifest_terminate_build 0
Name: python-dwave-ocean-sdk
Version: 6.3.0
Release: 1
Summary: Software development kit for open source D-Wave tools
License: Apache 2.0
URL: https://github.com/dwavesystems/dwave-ocean-sdk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c9/f0/ec67a29c1124a06667d6d8d6d61717fd5cb40ddfc758866edc32a502486d/dwave-ocean-sdk-6.3.0.tar.gz
BuildArch: noarch
Requires: python3-dimod
Requires: python3-dwave-cloud-client
Requires: python3-dwave-greedy
Requires: python3-dwave-hybrid
Requires: python3-dwave-inspector
Requires: python3-dwave-neal
Requires: python3-dwave-networkx
Requires: python3-dwave-preprocessing
Requires: python3-dwave-samplers
Requires: python3-dwave-system
Requires: python3-dwave-tabu
Requires: python3-dwavebinarycsp
Requires: python3-minorminer
Requires: python3-penaltymodel
Requires: python3-pyqubo
Requires: python3-dwave-gate
%description
Installation from `PyPI `_:
pip install dwave-ocean-sdk
For more information, see the Ocean documentation's
`installation `_
page.
%package -n python3-dwave-ocean-sdk
Summary: Software development kit for open source D-Wave tools
Provides: python-dwave-ocean-sdk
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dwave-ocean-sdk
Installation from `PyPI `_:
pip install dwave-ocean-sdk
For more information, see the Ocean documentation's
`installation `_
page.
%package help
Summary: Development documents and examples for dwave-ocean-sdk
Provides: python3-dwave-ocean-sdk-doc
%description help
Installation from `PyPI `_:
pip install dwave-ocean-sdk
For more information, see the Ocean documentation's
`installation `_
page.
%prep
%autosetup -n dwave-ocean-sdk-6.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dwave-ocean-sdk -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 6.3.0-1
- Package Spec generated