%global _empty_manifest_terminate_build 0
Name:		python-numerize
Version:	0.12
Release:	1
Summary:	Convert large numbers into readable numbers for humans.
License:	MIT
URL:		https://github.com/davidsa03/numerize
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6a/cf/c5dfa6ca5b6553f30860337020d76c582fd81b48da58982a6f2ff1f1fe40/numerize-0.12.tar.gz
BuildArch:	noarch


%description
[![Build Status](https://travis-ci.org/davidsa03/numerize.svg?branch=master)](https://travis-ci.org/davidsa03/numerize)
![Python 2.7](https://img.shields.io/badge/python-2.7-green.svg)
![Python 3.6](https://img.shields.io/badge/python-3.6-green.svg)
[![license](https://img.shields.io/github/license/mashape/apistatus.svg?maxAge=2592000)](https://github.com/davidsa03/numerize/blob/master/LICENSE)
# Numerize

Numerize is a Python (2 and 3) library for converting large numbers into readable strings.
Similar to what Twitter and Instagram use for large follower counts.

| Number | Numerized |
|------|:---------:|
| 1  | **1**  |
| 1000  | **1K**  |
| 1500  | **1.5K**  |
| 1000000  | **1M**  |
| 1500000  | **1.5M**  |
| 1000000000  | **1B**  |
| 1500000000  | **1.5B**  |
| 1000000000000  | **1T**  |
| 1500000000000  | **1.5T**  |
| 21324314       | **21.32M**|
| -21324314       | **-21.32M**|

## Installation

```
$ pip install numerize
```

## Usage

numerize(number_to_numerize, decimal_places_to_round[optional])

```
>>> from numerize import numerize
>>> numerize(1234567.12)
'1.23M'
>>> numerize(12134.123, 3)
'12.134K'
```
This will convert large numbers like 1234567.12 into 1.23M

## Requirements
- Python >= 2.7 or >= 3.4

## Contributing
[How to contribute](https://github.com/davidsa03/numerize/blob/master/CONTRIBUTING.md)

## Testing

```
$ python numerize/test.py
```

## License
MIT licensed.


%package -n python3-numerize
Summary:	Convert large numbers into readable numbers for humans.
Provides:	python-numerize
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-numerize
[![Build Status](https://travis-ci.org/davidsa03/numerize.svg?branch=master)](https://travis-ci.org/davidsa03/numerize)
![Python 2.7](https://img.shields.io/badge/python-2.7-green.svg)
![Python 3.6](https://img.shields.io/badge/python-3.6-green.svg)
[![license](https://img.shields.io/github/license/mashape/apistatus.svg?maxAge=2592000)](https://github.com/davidsa03/numerize/blob/master/LICENSE)
# Numerize

Numerize is a Python (2 and 3) library for converting large numbers into readable strings.
Similar to what Twitter and Instagram use for large follower counts.

| Number | Numerized |
|------|:---------:|
| 1  | **1**  |
| 1000  | **1K**  |
| 1500  | **1.5K**  |
| 1000000  | **1M**  |
| 1500000  | **1.5M**  |
| 1000000000  | **1B**  |
| 1500000000  | **1.5B**  |
| 1000000000000  | **1T**  |
| 1500000000000  | **1.5T**  |
| 21324314       | **21.32M**|
| -21324314       | **-21.32M**|

## Installation

```
$ pip install numerize
```

## Usage

numerize(number_to_numerize, decimal_places_to_round[optional])

```
>>> from numerize import numerize
>>> numerize(1234567.12)
'1.23M'
>>> numerize(12134.123, 3)
'12.134K'
```
This will convert large numbers like 1234567.12 into 1.23M

## Requirements
- Python >= 2.7 or >= 3.4

## Contributing
[How to contribute](https://github.com/davidsa03/numerize/blob/master/CONTRIBUTING.md)

## Testing

```
$ python numerize/test.py
```

## License
MIT licensed.


%package help
Summary:	Development documents and examples for numerize
Provides:	python3-numerize-doc
%description help
[![Build Status](https://travis-ci.org/davidsa03/numerize.svg?branch=master)](https://travis-ci.org/davidsa03/numerize)
![Python 2.7](https://img.shields.io/badge/python-2.7-green.svg)
![Python 3.6](https://img.shields.io/badge/python-3.6-green.svg)
[![license](https://img.shields.io/github/license/mashape/apistatus.svg?maxAge=2592000)](https://github.com/davidsa03/numerize/blob/master/LICENSE)
# Numerize

Numerize is a Python (2 and 3) library for converting large numbers into readable strings.
Similar to what Twitter and Instagram use for large follower counts.

| Number | Numerized |
|------|:---------:|
| 1  | **1**  |
| 1000  | **1K**  |
| 1500  | **1.5K**  |
| 1000000  | **1M**  |
| 1500000  | **1.5M**  |
| 1000000000  | **1B**  |
| 1500000000  | **1.5B**  |
| 1000000000000  | **1T**  |
| 1500000000000  | **1.5T**  |
| 21324314       | **21.32M**|
| -21324314       | **-21.32M**|

## Installation

```
$ pip install numerize
```

## Usage

numerize(number_to_numerize, decimal_places_to_round[optional])

```
>>> from numerize import numerize
>>> numerize(1234567.12)
'1.23M'
>>> numerize(12134.123, 3)
'12.134K'
```
This will convert large numbers like 1234567.12 into 1.23M

## Requirements
- Python >= 2.7 or >= 3.4

## Contributing
[How to contribute](https://github.com/davidsa03/numerize/blob/master/CONTRIBUTING.md)

## Testing

```
$ python numerize/test.py
```

## License
MIT licensed.


%prep
%autosetup -n numerize-0.12

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-numerize -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.12-1
- Package Spec generated