%global _empty_manifest_terminate_build 0
Name: python-dialogflow
Version: 2.0.0
Release: 1
Summary: Client library for the Dialogflow API
License: Apache 2.0
URL: https://github.com/googleapis/dialogflow-python-client-v2
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5b/2c/0ec7101d88a788c9f0694d5cca666abe85c6aded4ff99a29980626060ce5/dialogflow-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-google-api-core[grpc]
%description
The package `dialogflow`_ has been renamed to `google-cloud-dialogflow`_.
`dialogflow`_ will no longer be updated.
For help upgrading to ``google-cloud-dialogflow>=2.0.0``, see the `Migration Guide`_.
After **October 28, 2021**, importing code from the latest release of `dialogflow`_ will result in a ``RuntimeError``. If you need to continue to use `dialogflow`_ after this date, please pin to a specific version of `dialogflow`_ (e.g., ``dialogflow==1.1.1``). If you have questions, please `file an issue`_.
Python idiomatic client for `Google Cloud Dialogflow `_
`Google Cloud Dialogflow `_ is an enterprise-grade NLU platform that makes it easy for
developers to design and integrate conversational user interfaces into
mobile apps, web applications, devices, and bots.
* `Dialogflow Python Client API Reference `_
* `Dialogflow Standard Edition Documentation `_
* `Dialogflow Enterprise Edition Documentation `_
Read more about the client libraries for Cloud APIs, including the older
Google APIs Client Libraries, in
`Client Libraries Explained `_.
%package -n python3-dialogflow
Summary: Client library for the Dialogflow API
Provides: python-dialogflow
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-dialogflow
The package `dialogflow`_ has been renamed to `google-cloud-dialogflow`_.
`dialogflow`_ will no longer be updated.
For help upgrading to ``google-cloud-dialogflow>=2.0.0``, see the `Migration Guide`_.
After **October 28, 2021**, importing code from the latest release of `dialogflow`_ will result in a ``RuntimeError``. If you need to continue to use `dialogflow`_ after this date, please pin to a specific version of `dialogflow`_ (e.g., ``dialogflow==1.1.1``). If you have questions, please `file an issue`_.
Python idiomatic client for `Google Cloud Dialogflow `_
`Google Cloud Dialogflow `_ is an enterprise-grade NLU platform that makes it easy for
developers to design and integrate conversational user interfaces into
mobile apps, web applications, devices, and bots.
* `Dialogflow Python Client API Reference `_
* `Dialogflow Standard Edition Documentation `_
* `Dialogflow Enterprise Edition Documentation `_
Read more about the client libraries for Cloud APIs, including the older
Google APIs Client Libraries, in
`Client Libraries Explained `_.
%package help
Summary: Development documents and examples for dialogflow
Provides: python3-dialogflow-doc
%description help
The package `dialogflow`_ has been renamed to `google-cloud-dialogflow`_.
`dialogflow`_ will no longer be updated.
For help upgrading to ``google-cloud-dialogflow>=2.0.0``, see the `Migration Guide`_.
After **October 28, 2021**, importing code from the latest release of `dialogflow`_ will result in a ``RuntimeError``. If you need to continue to use `dialogflow`_ after this date, please pin to a specific version of `dialogflow`_ (e.g., ``dialogflow==1.1.1``). If you have questions, please `file an issue`_.
Python idiomatic client for `Google Cloud Dialogflow `_
`Google Cloud Dialogflow `_ is an enterprise-grade NLU platform that makes it easy for
developers to design and integrate conversational user interfaces into
mobile apps, web applications, devices, and bots.
* `Dialogflow Python Client API Reference `_
* `Dialogflow Standard Edition Documentation `_
* `Dialogflow Enterprise Edition Documentation `_
Read more about the client libraries for Cloud APIs, including the older
Google APIs Client Libraries, in
`Client Libraries Explained `_.
%prep
%autosetup -n dialogflow-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-dialogflow -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.0.0-1
- Package Spec generated