%global _empty_manifest_terminate_build 0
Name: python-Pweave
Version: 0.30.3
Release: 1
Summary: Scientific reports with embedded python computations with reST, LaTeX or markdown
License: LICENSE.txt
URL: http://mpastell.com/pweave
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4d/19/1d26e59f8928592062cfd4cd40084285be770b3a4735fff2aa38b97d1aaf/Pweave-0.30.3.tar.gz
BuildArch: noarch
%description
Pweave is a scientific report generator and a literate programming
tool for Python. Pweave can capture the results and plots from data
analysis and works well with NumPy, SciPy and matplotlib. It is able to run
python code from source document and include the results and capture
`matplotlib `_ plots in the output.
Pweave is good for creating reports, tutorials, presentations etc. with embedded python
code It can also be used to make websites together with e.g. Sphinx or rest2web.
%package -n python3-Pweave
Summary: Scientific reports with embedded python computations with reST, LaTeX or markdown
Provides: python-Pweave
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Pweave
Pweave is a scientific report generator and a literate programming
tool for Python. Pweave can capture the results and plots from data
analysis and works well with NumPy, SciPy and matplotlib. It is able to run
python code from source document and include the results and capture
`matplotlib `_ plots in the output.
Pweave is good for creating reports, tutorials, presentations etc. with embedded python
code It can also be used to make websites together with e.g. Sphinx or rest2web.
%package help
Summary: Development documents and examples for Pweave
Provides: python3-Pweave-doc
%description help
Pweave is a scientific report generator and a literate programming
tool for Python. Pweave can capture the results and plots from data
analysis and works well with NumPy, SciPy and matplotlib. It is able to run
python code from source document and include the results and capture
`matplotlib `_ plots in the output.
Pweave is good for creating reports, tutorials, presentations etc. with embedded python
code It can also be used to make websites together with e.g. Sphinx or rest2web.
%prep
%autosetup -n Pweave-0.30.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Pweave -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.30.3-1
- Package Spec generated