%global _empty_manifest_terminate_build 0
Name:		python-bioblend
Version:	1.1.1
Release:	1
Summary:	Library for interacting with the Galaxy API
License:	MIT
URL:		https://bioblend.readthedocs.io/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/61/62/365fa03e894336b8f388bd4c61ab3268605256b7e30f571902b3a9dec1c4/bioblend-1.1.1.tar.gz
BuildArch:	noarch

Requires:	python3-requests
Requires:	python3-requests-toolbelt
Requires:	python3-tuspy
Requires:	python3-typing-extensions
Requires:	python3-pytest

%description
.. image:: https://img.shields.io/pypi/v/bioblend.svg
    :target: https://pypi.org/project/bioblend/
    :alt: latest version available on PyPI

.. image:: https://readthedocs.org/projects/bioblend/badge/
    :alt: Documentation Status
    :target: https://bioblend.readthedocs.io/

.. image:: https://badges.gitter.im/galaxyproject/bioblend.svg
   :alt: Join the chat at https://gitter.im/galaxyproject/bioblend
   :target: https://gitter.im/galaxyproject/bioblend?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge


BioBlend is a Python library for interacting with the `Galaxy`_ API.

BioBlend is supported and tested on:

- Python 3.7 - 3.11
- Galaxy release 17.09 and later.

Full docs are available at https://bioblend.readthedocs.io/ with a quick library
overview also available in `ABOUT.rst <./ABOUT.rst>`_.

.. References/hyperlinks used above
.. _Galaxy: https://galaxyproject.org/


%package -n python3-bioblend
Summary:	Library for interacting with the Galaxy API
Provides:	python-bioblend
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-bioblend
.. image:: https://img.shields.io/pypi/v/bioblend.svg
    :target: https://pypi.org/project/bioblend/
    :alt: latest version available on PyPI

.. image:: https://readthedocs.org/projects/bioblend/badge/
    :alt: Documentation Status
    :target: https://bioblend.readthedocs.io/

.. image:: https://badges.gitter.im/galaxyproject/bioblend.svg
   :alt: Join the chat at https://gitter.im/galaxyproject/bioblend
   :target: https://gitter.im/galaxyproject/bioblend?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge


BioBlend is a Python library for interacting with the `Galaxy`_ API.

BioBlend is supported and tested on:

- Python 3.7 - 3.11
- Galaxy release 17.09 and later.

Full docs are available at https://bioblend.readthedocs.io/ with a quick library
overview also available in `ABOUT.rst <./ABOUT.rst>`_.

.. References/hyperlinks used above
.. _Galaxy: https://galaxyproject.org/


%package help
Summary:	Development documents and examples for bioblend
Provides:	python3-bioblend-doc
%description help
.. image:: https://img.shields.io/pypi/v/bioblend.svg
    :target: https://pypi.org/project/bioblend/
    :alt: latest version available on PyPI

.. image:: https://readthedocs.org/projects/bioblend/badge/
    :alt: Documentation Status
    :target: https://bioblend.readthedocs.io/

.. image:: https://badges.gitter.im/galaxyproject/bioblend.svg
   :alt: Join the chat at https://gitter.im/galaxyproject/bioblend
   :target: https://gitter.im/galaxyproject/bioblend?utm_source=badge&utm_medium=badge&utm_campaign=pr-badge&utm_content=badge


BioBlend is a Python library for interacting with the `Galaxy`_ API.

BioBlend is supported and tested on:

- Python 3.7 - 3.11
- Galaxy release 17.09 and later.

Full docs are available at https://bioblend.readthedocs.io/ with a quick library
overview also available in `ABOUT.rst <./ABOUT.rst>`_.

.. References/hyperlinks used above
.. _Galaxy: https://galaxyproject.org/


%prep
%autosetup -n bioblend-1.1.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-bioblend -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
- Package Spec generated