%global _empty_manifest_terminate_build 0
Name: python-texthero
Version: 1.1.0
Release: 1
Summary: Text preprocessing, representation and visualization from zero to hero.
License: MIT
URL: https://github.com/jbesomi/texthero
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/6b/90e53fc4daf79ae1b8ce11c43d57ac70ea8334794e1510ccd92c813fa5fc/texthero-1.1.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-scikit-learn
Requires: python3-spacy
Requires: python3-tqdm
Requires: python3-nltk
Requires: python3-plotly
Requires: python3-pandas
Requires: python3-wordcloud
Requires: python3-unidecode
Requires: python3-gensim
Requires: python3-matplotlib
Requires: python3-black
Requires: python3-pytest
Requires: python3-Sphinx
Requires: python3-sphinx-markdown-builder
Requires: python3-recommonmark
Requires: python3-nbsphinx
%description
Text preprocessing, representation and visualization from zero to hero.
From zero to hero •
Installation •
Getting Started •
Examples •
API •
FAQ •
Contributions
From zero to hero
Texthero is a python toolkit to work with text-based dataset quickly and effortlessly. Texthero is very simple to learn and designed to be used on top of Pandas. Texthero has the same expressiveness and power of Pandas and is extensively documented. Texthero is modern and conceived for programmers of the 2020 decade with little knowledge if any in linguistic.
You can think of Texthero as a tool to help you _understand_ and work with text-based dataset. Given a tabular dataset, it's easy to _grasp the main concept_. Instead, given a text dataset, it's harder to have quick insights into the underline data. With Texthero, preprocessing text data, map it into vectors and visualize the obtained vector space takes just a couple of lines.
Texthero include tools for:
* Preprocess text data: it offers both out-of-the-box solutions but it's also flexible for custom-solutions.
* Natural Language Processing: keyphrases and keywords extraction, and named entity recognition.
* Text representation: TF-IDF, term frequency, and custom word-embeddings (wip)
* Vector space analysis: clustering (K-means, Meanshift, DBSAN and Hierarchical), topic modelling (wip) and interpretation.
* Text visualization: vector space visualization, place localization on maps (wip).
Texthero is free, open source and [well documented](https://texthero.org/docs) (and that's what we love most by the way!).
We hope you will find pleasure working with Texthero as we had during his development.
Hablas español?
Texthero has been developed for the whole NLP community. We know of hard is to deal with different NLP tools (NLTK, SpaCy, Gensim, TextBlob, Sklearn): that's why we developed Texthero, to simplify things.
Now, the next main milestone is to provide *multilingual support* and for this big step, we need the help of all of you. ¿Hablas español? Sie sprechen Deutsch? 你会说中文? 日本語が話せるのか? Fala português? Parli Italiano? Вы говорите по-русски? If yes or you speak another language not mentioned, then you might help us develop multilingual support! Even if you haven't contributed before or you just started with NLP contact us or open a Github issue, there is always a first time :) We promise you will learn a lot, and, ... who knows? It might help you find your new job as an NLP-developer!
For improving the python toolkit and provide an even better experience, your aid and feedback are crucial. If you have any problem or suggestion please open a Github [issue](https://github.com/jbesomi/texthero/issues), we will be glad to support you and help you.
Installation
Install texthero via `pip`:
```bash
pip install texthero
```
> ☝️Under the hoods, Texthero makes use of multiple NLP and machine learning toolkits such as Gensim, NLTK, SpaCy and scikit-learn. You don't need to install them all separately, pip will take care of that.
> For fast performance, make sure you have installed Spacy version >= 2.2. Also, make sure you have a recent version of python, the higher, the best.
Getting started
The best way to learn Texthero is through the Getting Started docs.
In case you are an advanced python user, then `help(texthero)` should do the work.
Examples
1. Text cleaning, TF-IDF representation and visualization
```python
import texthero as hero
import pandas as pd
df = pd.read_csv(
"https://github.com/jbesomi/texthero/raw/master/dataset/bbcsport.csv"
)
df['pca'] = (
df['text']
.pipe(hero.clean)
.pipe(hero.tfidf)
.pipe(hero.pca)
)
hero.scatterplot(df, 'pca', color='topic', title="PCA BBC Sport news")
```
2. Text preprocessing, TF-IDF, K-means and visualization
```python
import texthero as hero
import pandas as pd
df = pd.read_csv(
"https://github.com/jbesomi/texthero/raw/master/dataset/bbcsport.csv"
)
df['tfidf'] = (
df['text']
.pipe(hero.clean)
.pipe(hero.tfidf)
)
df['kmeans_labels'] = (
df['tfidf']
.pipe(hero.kmeans, n_clusters=5)
.astype(str)
)
df['pca'] = df['tfidf'].pipe(hero.pca)
hero.scatterplot(df, 'pca', color='kmeans_labels', title="K-means BBC Sport news")
```
3. Simple pipeline for text cleaning
```python
>>> import texthero as hero
>>> import pandas as pd
>>> text = "This sèntencé (123 /) needs to [OK!] be cleaned! "
>>> s = pd.Series(text)
>>> s
0 This sèntencé (123 /) needs to [OK!] be cleane...
dtype: object
```
Remove all digits:
```python
>>> s = hero.remove_digits(s)
>>> s
0 This sèntencé ( /) needs to [OK!] be cleaned!
dtype: object
```
> Remove digits replace only blocks of digits. The digits in the string "hello123" will not be removed. If we want to remove all digits, you need to set only_blocks to false.
Remove all type of brackets and their content.
```python
>>> s = hero.remove_brackets(s)
>>> s
0 This sèntencé needs to be cleaned!
dtype: object
```
Remove diacritics.
```python
>>> s = hero.remove_diacritics(s)
>>> s
0 This sentence needs to be cleaned!
dtype: object
```
Remove punctuation.
```python
>>> s = hero.remove_punctuation(s)
>>> s
0 This sentence needs to be cleaned
dtype: object
```
Remove extra white-spaces.
```python
>>> s = hero.remove_whitespace(s)
>>> s
0 This sentence needs to be cleaned
dtype: object
```
Sometimes we also wants to get rid of stop-words.
```python
>>> s = hero.remove_stopwords(s)
>>> s
0 This sentence needs cleaned
dtype: object
```
API
Texthero is composed of four modules: [preprocessing.py](/texthero/preprocessing.py), [nlp.py](/texthero/nlp.py), [representation.py](/texthero/representation.py) and [visualization.py](/texthero/visualization.py).
1. Preprocessing
**Scope:** prepare **text** data for further analysis.
Full documentation: [preprocessing](https://texthero.org/docs/api-preprocessing)
2. NLP
**Scope:** provide classic natural language processing tools such as `named_entity` and `noun_phrases`.
Full documentation: [nlp](https://texthero.org/docs/api-nlp)
2. Representation
**Scope:** map text data into vectors and do dimensionality reduction.
Supported **representation** algorithms:
1. Term frequency (`count`)
1. Term frequency-inverse document frequency (`tfidf`)
Supported **clustering** algorithms:
1. K-means (`kmeans`)
1. Density-Based Spatial Clustering of Applications with Noise (`dbscan`)
1. Meanshift (`meanshift`)
Supported **dimensionality reduction** algorithms:
1. Principal component analysis (`pca`)
1. t-distributed stochastic neighbor embedding (`tsne`)
1. Non-negative matrix factorization (`nmf`)
Full documentation: [representation](https://texthero.org/docs/api-representation)
3. Visualization
**Scope:** summarize the main facts regarding the text data and visualize it. This module is opinionable. It's handy for anyone that needs a quick solution to visualize on screen the text data, for instance during a text exploratory data analysis (EDA).
Supported functions:
- Text scatterplot (`scatterplot`)
- Most common words (`top_words`)
Full documentation: [visualization](https://texthero.org/docs/api-visualization)
FAQ
Why Texthero
Sometimes we just want things done, right? Texthero help with that. It helps makes things easier and give to the developer more time to focus on his custom requirements. We believe that start cleaning text should just take a minute. Same for finding the most important part of a text and same for representing it.
In a very pragmatic way, texthero has just one goal: make the developer spare time. Working with text data can be a pain and in most cases, a default pipeline can be quite good to start. There is always the time to come back and improve the preprocessing pipeline.
Contributions
Pull requests are amazing and most welcome. Start by fork this repository and [open an issue](https://github.com/jbesomi/texthero/issues).
Texthero is also looking for maintainers and contributors. In case of interest, just drop a line at jonathanbesomi__AT__gmail.com
Contributors (in chronological order)
- [Selim Al Awwa](https://github.com/selimelawwa/)
- [Parth Gandhi](https://github.com/ParthGandhi)
- [Dan Keefe](https://github.com/Peritract)
%package -n python3-texthero
Summary: Text preprocessing, representation and visualization from zero to hero.
Provides: python-texthero
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-texthero
Text preprocessing, representation and visualization from zero to hero.
From zero to hero •
Installation •
Getting Started •
Examples •
API •
FAQ •
Contributions
From zero to hero
Texthero is a python toolkit to work with text-based dataset quickly and effortlessly. Texthero is very simple to learn and designed to be used on top of Pandas. Texthero has the same expressiveness and power of Pandas and is extensively documented. Texthero is modern and conceived for programmers of the 2020 decade with little knowledge if any in linguistic.
You can think of Texthero as a tool to help you _understand_ and work with text-based dataset. Given a tabular dataset, it's easy to _grasp the main concept_. Instead, given a text dataset, it's harder to have quick insights into the underline data. With Texthero, preprocessing text data, map it into vectors and visualize the obtained vector space takes just a couple of lines.
Texthero include tools for:
* Preprocess text data: it offers both out-of-the-box solutions but it's also flexible for custom-solutions.
* Natural Language Processing: keyphrases and keywords extraction, and named entity recognition.
* Text representation: TF-IDF, term frequency, and custom word-embeddings (wip)
* Vector space analysis: clustering (K-means, Meanshift, DBSAN and Hierarchical), topic modelling (wip) and interpretation.
* Text visualization: vector space visualization, place localization on maps (wip).
Texthero is free, open source and [well documented](https://texthero.org/docs) (and that's what we love most by the way!).
We hope you will find pleasure working with Texthero as we had during his development.
Hablas español?
Texthero has been developed for the whole NLP community. We know of hard is to deal with different NLP tools (NLTK, SpaCy, Gensim, TextBlob, Sklearn): that's why we developed Texthero, to simplify things.
Now, the next main milestone is to provide *multilingual support* and for this big step, we need the help of all of you. ¿Hablas español? Sie sprechen Deutsch? 你会说中文? 日本語が話せるのか? Fala português? Parli Italiano? Вы говорите по-русски? If yes or you speak another language not mentioned, then you might help us develop multilingual support! Even if you haven't contributed before or you just started with NLP contact us or open a Github issue, there is always a first time :) We promise you will learn a lot, and, ... who knows? It might help you find your new job as an NLP-developer!
For improving the python toolkit and provide an even better experience, your aid and feedback are crucial. If you have any problem or suggestion please open a Github [issue](https://github.com/jbesomi/texthero/issues), we will be glad to support you and help you.
Installation
Install texthero via `pip`:
```bash
pip install texthero
```
> ☝️Under the hoods, Texthero makes use of multiple NLP and machine learning toolkits such as Gensim, NLTK, SpaCy and scikit-learn. You don't need to install them all separately, pip will take care of that.
> For fast performance, make sure you have installed Spacy version >= 2.2. Also, make sure you have a recent version of python, the higher, the best.
Getting started
The best way to learn Texthero is through the Getting Started docs.
In case you are an advanced python user, then `help(texthero)` should do the work.
Examples
1. Text cleaning, TF-IDF representation and visualization
```python
import texthero as hero
import pandas as pd
df = pd.read_csv(
"https://github.com/jbesomi/texthero/raw/master/dataset/bbcsport.csv"
)
df['pca'] = (
df['text']
.pipe(hero.clean)
.pipe(hero.tfidf)
.pipe(hero.pca)
)
hero.scatterplot(df, 'pca', color='topic', title="PCA BBC Sport news")
```
2. Text preprocessing, TF-IDF, K-means and visualization
```python
import texthero as hero
import pandas as pd
df = pd.read_csv(
"https://github.com/jbesomi/texthero/raw/master/dataset/bbcsport.csv"
)
df['tfidf'] = (
df['text']
.pipe(hero.clean)
.pipe(hero.tfidf)
)
df['kmeans_labels'] = (
df['tfidf']
.pipe(hero.kmeans, n_clusters=5)
.astype(str)
)
df['pca'] = df['tfidf'].pipe(hero.pca)
hero.scatterplot(df, 'pca', color='kmeans_labels', title="K-means BBC Sport news")
```
3. Simple pipeline for text cleaning
```python
>>> import texthero as hero
>>> import pandas as pd
>>> text = "This sèntencé (123 /) needs to [OK!] be cleaned! "
>>> s = pd.Series(text)
>>> s
0 This sèntencé (123 /) needs to [OK!] be cleane...
dtype: object
```
Remove all digits:
```python
>>> s = hero.remove_digits(s)
>>> s
0 This sèntencé ( /) needs to [OK!] be cleaned!
dtype: object
```
> Remove digits replace only blocks of digits. The digits in the string "hello123" will not be removed. If we want to remove all digits, you need to set only_blocks to false.
Remove all type of brackets and their content.
```python
>>> s = hero.remove_brackets(s)
>>> s
0 This sèntencé needs to be cleaned!
dtype: object
```
Remove diacritics.
```python
>>> s = hero.remove_diacritics(s)
>>> s
0 This sentence needs to be cleaned!
dtype: object
```
Remove punctuation.
```python
>>> s = hero.remove_punctuation(s)
>>> s
0 This sentence needs to be cleaned
dtype: object
```
Remove extra white-spaces.
```python
>>> s = hero.remove_whitespace(s)
>>> s
0 This sentence needs to be cleaned
dtype: object
```
Sometimes we also wants to get rid of stop-words.
```python
>>> s = hero.remove_stopwords(s)
>>> s
0 This sentence needs cleaned
dtype: object
```
API
Texthero is composed of four modules: [preprocessing.py](/texthero/preprocessing.py), [nlp.py](/texthero/nlp.py), [representation.py](/texthero/representation.py) and [visualization.py](/texthero/visualization.py).
1. Preprocessing
**Scope:** prepare **text** data for further analysis.
Full documentation: [preprocessing](https://texthero.org/docs/api-preprocessing)
2. NLP
**Scope:** provide classic natural language processing tools such as `named_entity` and `noun_phrases`.
Full documentation: [nlp](https://texthero.org/docs/api-nlp)
2. Representation
**Scope:** map text data into vectors and do dimensionality reduction.
Supported **representation** algorithms:
1. Term frequency (`count`)
1. Term frequency-inverse document frequency (`tfidf`)
Supported **clustering** algorithms:
1. K-means (`kmeans`)
1. Density-Based Spatial Clustering of Applications with Noise (`dbscan`)
1. Meanshift (`meanshift`)
Supported **dimensionality reduction** algorithms:
1. Principal component analysis (`pca`)
1. t-distributed stochastic neighbor embedding (`tsne`)
1. Non-negative matrix factorization (`nmf`)
Full documentation: [representation](https://texthero.org/docs/api-representation)
3. Visualization
**Scope:** summarize the main facts regarding the text data and visualize it. This module is opinionable. It's handy for anyone that needs a quick solution to visualize on screen the text data, for instance during a text exploratory data analysis (EDA).
Supported functions:
- Text scatterplot (`scatterplot`)
- Most common words (`top_words`)
Full documentation: [visualization](https://texthero.org/docs/api-visualization)
FAQ
Why Texthero
Sometimes we just want things done, right? Texthero help with that. It helps makes things easier and give to the developer more time to focus on his custom requirements. We believe that start cleaning text should just take a minute. Same for finding the most important part of a text and same for representing it.
In a very pragmatic way, texthero has just one goal: make the developer spare time. Working with text data can be a pain and in most cases, a default pipeline can be quite good to start. There is always the time to come back and improve the preprocessing pipeline.
Contributions
Pull requests are amazing and most welcome. Start by fork this repository and [open an issue](https://github.com/jbesomi/texthero/issues).
Texthero is also looking for maintainers and contributors. In case of interest, just drop a line at jonathanbesomi__AT__gmail.com
Contributors (in chronological order)
- [Selim Al Awwa](https://github.com/selimelawwa/)
- [Parth Gandhi](https://github.com/ParthGandhi)
- [Dan Keefe](https://github.com/Peritract)
%package help
Summary: Development documents and examples for texthero
Provides: python3-texthero-doc
%description help
Text preprocessing, representation and visualization from zero to hero.
From zero to hero •
Installation •
Getting Started •
Examples •
API •
FAQ •
Contributions
From zero to hero
Texthero is a python toolkit to work with text-based dataset quickly and effortlessly. Texthero is very simple to learn and designed to be used on top of Pandas. Texthero has the same expressiveness and power of Pandas and is extensively documented. Texthero is modern and conceived for programmers of the 2020 decade with little knowledge if any in linguistic.
You can think of Texthero as a tool to help you _understand_ and work with text-based dataset. Given a tabular dataset, it's easy to _grasp the main concept_. Instead, given a text dataset, it's harder to have quick insights into the underline data. With Texthero, preprocessing text data, map it into vectors and visualize the obtained vector space takes just a couple of lines.
Texthero include tools for:
* Preprocess text data: it offers both out-of-the-box solutions but it's also flexible for custom-solutions.
* Natural Language Processing: keyphrases and keywords extraction, and named entity recognition.
* Text representation: TF-IDF, term frequency, and custom word-embeddings (wip)
* Vector space analysis: clustering (K-means, Meanshift, DBSAN and Hierarchical), topic modelling (wip) and interpretation.
* Text visualization: vector space visualization, place localization on maps (wip).
Texthero is free, open source and [well documented](https://texthero.org/docs) (and that's what we love most by the way!).
We hope you will find pleasure working with Texthero as we had during his development.
Hablas español?
Texthero has been developed for the whole NLP community. We know of hard is to deal with different NLP tools (NLTK, SpaCy, Gensim, TextBlob, Sklearn): that's why we developed Texthero, to simplify things.
Now, the next main milestone is to provide *multilingual support* and for this big step, we need the help of all of you. ¿Hablas español? Sie sprechen Deutsch? 你会说中文? 日本語が話せるのか? Fala português? Parli Italiano? Вы говорите по-русски? If yes or you speak another language not mentioned, then you might help us develop multilingual support! Even if you haven't contributed before or you just started with NLP contact us or open a Github issue, there is always a first time :) We promise you will learn a lot, and, ... who knows? It might help you find your new job as an NLP-developer!
For improving the python toolkit and provide an even better experience, your aid and feedback are crucial. If you have any problem or suggestion please open a Github [issue](https://github.com/jbesomi/texthero/issues), we will be glad to support you and help you.
Installation
Install texthero via `pip`:
```bash
pip install texthero
```
> ☝️Under the hoods, Texthero makes use of multiple NLP and machine learning toolkits such as Gensim, NLTK, SpaCy and scikit-learn. You don't need to install them all separately, pip will take care of that.
> For fast performance, make sure you have installed Spacy version >= 2.2. Also, make sure you have a recent version of python, the higher, the best.
Getting started
The best way to learn Texthero is through the Getting Started docs.
In case you are an advanced python user, then `help(texthero)` should do the work.
Examples
1. Text cleaning, TF-IDF representation and visualization
```python
import texthero as hero
import pandas as pd
df = pd.read_csv(
"https://github.com/jbesomi/texthero/raw/master/dataset/bbcsport.csv"
)
df['pca'] = (
df['text']
.pipe(hero.clean)
.pipe(hero.tfidf)
.pipe(hero.pca)
)
hero.scatterplot(df, 'pca', color='topic', title="PCA BBC Sport news")
```
2. Text preprocessing, TF-IDF, K-means and visualization
```python
import texthero as hero
import pandas as pd
df = pd.read_csv(
"https://github.com/jbesomi/texthero/raw/master/dataset/bbcsport.csv"
)
df['tfidf'] = (
df['text']
.pipe(hero.clean)
.pipe(hero.tfidf)
)
df['kmeans_labels'] = (
df['tfidf']
.pipe(hero.kmeans, n_clusters=5)
.astype(str)
)
df['pca'] = df['tfidf'].pipe(hero.pca)
hero.scatterplot(df, 'pca', color='kmeans_labels', title="K-means BBC Sport news")
```
3. Simple pipeline for text cleaning
```python
>>> import texthero as hero
>>> import pandas as pd
>>> text = "This sèntencé (123 /) needs to [OK!] be cleaned! "
>>> s = pd.Series(text)
>>> s
0 This sèntencé (123 /) needs to [OK!] be cleane...
dtype: object
```
Remove all digits:
```python
>>> s = hero.remove_digits(s)
>>> s
0 This sèntencé ( /) needs to [OK!] be cleaned!
dtype: object
```
> Remove digits replace only blocks of digits. The digits in the string "hello123" will not be removed. If we want to remove all digits, you need to set only_blocks to false.
Remove all type of brackets and their content.
```python
>>> s = hero.remove_brackets(s)
>>> s
0 This sèntencé needs to be cleaned!
dtype: object
```
Remove diacritics.
```python
>>> s = hero.remove_diacritics(s)
>>> s
0 This sentence needs to be cleaned!
dtype: object
```
Remove punctuation.
```python
>>> s = hero.remove_punctuation(s)
>>> s
0 This sentence needs to be cleaned
dtype: object
```
Remove extra white-spaces.
```python
>>> s = hero.remove_whitespace(s)
>>> s
0 This sentence needs to be cleaned
dtype: object
```
Sometimes we also wants to get rid of stop-words.
```python
>>> s = hero.remove_stopwords(s)
>>> s
0 This sentence needs cleaned
dtype: object
```
API
Texthero is composed of four modules: [preprocessing.py](/texthero/preprocessing.py), [nlp.py](/texthero/nlp.py), [representation.py](/texthero/representation.py) and [visualization.py](/texthero/visualization.py).
1. Preprocessing
**Scope:** prepare **text** data for further analysis.
Full documentation: [preprocessing](https://texthero.org/docs/api-preprocessing)
2. NLP
**Scope:** provide classic natural language processing tools such as `named_entity` and `noun_phrases`.
Full documentation: [nlp](https://texthero.org/docs/api-nlp)
2. Representation
**Scope:** map text data into vectors and do dimensionality reduction.
Supported **representation** algorithms:
1. Term frequency (`count`)
1. Term frequency-inverse document frequency (`tfidf`)
Supported **clustering** algorithms:
1. K-means (`kmeans`)
1. Density-Based Spatial Clustering of Applications with Noise (`dbscan`)
1. Meanshift (`meanshift`)
Supported **dimensionality reduction** algorithms:
1. Principal component analysis (`pca`)
1. t-distributed stochastic neighbor embedding (`tsne`)
1. Non-negative matrix factorization (`nmf`)
Full documentation: [representation](https://texthero.org/docs/api-representation)
3. Visualization
**Scope:** summarize the main facts regarding the text data and visualize it. This module is opinionable. It's handy for anyone that needs a quick solution to visualize on screen the text data, for instance during a text exploratory data analysis (EDA).
Supported functions:
- Text scatterplot (`scatterplot`)
- Most common words (`top_words`)
Full documentation: [visualization](https://texthero.org/docs/api-visualization)
FAQ
Why Texthero
Sometimes we just want things done, right? Texthero help with that. It helps makes things easier and give to the developer more time to focus on his custom requirements. We believe that start cleaning text should just take a minute. Same for finding the most important part of a text and same for representing it.
In a very pragmatic way, texthero has just one goal: make the developer spare time. Working with text data can be a pain and in most cases, a default pipeline can be quite good to start. There is always the time to come back and improve the preprocessing pipeline.
Contributions
Pull requests are amazing and most welcome. Start by fork this repository and [open an issue](https://github.com/jbesomi/texthero/issues).
Texthero is also looking for maintainers and contributors. In case of interest, just drop a line at jonathanbesomi__AT__gmail.com
Contributors (in chronological order)
- [Selim Al Awwa](https://github.com/selimelawwa/)
- [Parth Gandhi](https://github.com/ParthGandhi)
- [Dan Keefe](https://github.com/Peritract)
%prep
%autosetup -n texthero-1.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-texthero -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 1.1.0-1
- Package Spec generated