%global _empty_manifest_terminate_build 0
Name:		python-samino
Version:	2.5.3
Release:	1
Summary:	Amino Bots with python!
License:	MIT
URL:		https://github.com/SirLez/SAmino
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/a4/54/3ce1f689210ef4a7495886715f75c069f15b99950e3b951743daf14cba28/samino-2.5.3.tar.gz
BuildArch:	noarch


%description
## SAmino
SAmino is unofficial client for [Aminoapps](https://aminoapps.com/) API in Python. 

## Installation
You can use either `python3 setup.py install` or `pip3 install samino` to install. This module is tested on Python 3.9+.

## Contributing
SAmino is open source module, anyone can contribute. Please see the [Github Repository](https://github.com/SirLez/SAmino)

## Discord
You can join the [Discord Server](https://discord.gg/AXn8PD5vDg) to add suggestions or to report problems
and to get new updates and changes

## Features
- Faster than other [Aminoapps](https://aminoapps.com/) python modules
- Supports async and sockets, events
- Easy and sample to use
- No `Too many requests.`
- Continual updates and bug fixes
- Have alot of useful functions

## Examples
#### Get SessionID
```py
import samino

client = samino.Client()
client.login("< email >", "< password >")
print(client.sid)
```
#### Login with SessionID
```py
import samino

client = samino.Client()
client.sid_login("< sid >")
print(client.sid)
```
#### Send a message in chat
```py
import samino

client = samino.Client()
client.login("< email >", "< password >")
path = client.get_from_link("< chat link >")
local = samino.Local(path.comId)
local.send_message(path.objectId, "< message >")
```




%package -n python3-samino
Summary:	Amino Bots with python!
Provides:	python-samino
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-samino
## SAmino
SAmino is unofficial client for [Aminoapps](https://aminoapps.com/) API in Python. 

## Installation
You can use either `python3 setup.py install` or `pip3 install samino` to install. This module is tested on Python 3.9+.

## Contributing
SAmino is open source module, anyone can contribute. Please see the [Github Repository](https://github.com/SirLez/SAmino)

## Discord
You can join the [Discord Server](https://discord.gg/AXn8PD5vDg) to add suggestions or to report problems
and to get new updates and changes

## Features
- Faster than other [Aminoapps](https://aminoapps.com/) python modules
- Supports async and sockets, events
- Easy and sample to use
- No `Too many requests.`
- Continual updates and bug fixes
- Have alot of useful functions

## Examples
#### Get SessionID
```py
import samino

client = samino.Client()
client.login("< email >", "< password >")
print(client.sid)
```
#### Login with SessionID
```py
import samino

client = samino.Client()
client.sid_login("< sid >")
print(client.sid)
```
#### Send a message in chat
```py
import samino

client = samino.Client()
client.login("< email >", "< password >")
path = client.get_from_link("< chat link >")
local = samino.Local(path.comId)
local.send_message(path.objectId, "< message >")
```




%package help
Summary:	Development documents and examples for samino
Provides:	python3-samino-doc
%description help
## SAmino
SAmino is unofficial client for [Aminoapps](https://aminoapps.com/) API in Python. 

## Installation
You can use either `python3 setup.py install` or `pip3 install samino` to install. This module is tested on Python 3.9+.

## Contributing
SAmino is open source module, anyone can contribute. Please see the [Github Repository](https://github.com/SirLez/SAmino)

## Discord
You can join the [Discord Server](https://discord.gg/AXn8PD5vDg) to add suggestions or to report problems
and to get new updates and changes

## Features
- Faster than other [Aminoapps](https://aminoapps.com/) python modules
- Supports async and sockets, events
- Easy and sample to use
- No `Too many requests.`
- Continual updates and bug fixes
- Have alot of useful functions

## Examples
#### Get SessionID
```py
import samino

client = samino.Client()
client.login("< email >", "< password >")
print(client.sid)
```
#### Login with SessionID
```py
import samino

client = samino.Client()
client.sid_login("< sid >")
print(client.sid)
```
#### Send a message in chat
```py
import samino

client = samino.Client()
client.login("< email >", "< password >")
path = client.get_from_link("< chat link >")
local = samino.Local(path.comId)
local.send_message(path.objectId, "< message >")
```




%prep
%autosetup -n samino-2.5.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-samino -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 2.5.3-1
- Package Spec generated