%global _empty_manifest_terminate_build 0
Name: python-wiremock
Version: 2.3.1
Release: 1
Summary: Wiremock Admin API Client
License: Apache Software License 2.0
URL: https://github.com/platinummonkey/python-wiremock
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/b5/bffe74ca9e59a97a7047c7033b91f7d7cba39369c5aaed7f7485c3777ec3/wiremock-2.3.1.tar.gz
BuildArch: noarch
Requires: python3-setuptools
Requires: python3-requests
Requires: python3-Sphinx
Requires: python3-black
Requires: python3-coverage
Requires: python3-detox
Requires: python3-mock
Requires: python3-nose
Requires: python3-coveralls
Requires: python3-responses
Requires: python3-requests
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-watchdog
Requires: python3-wheel
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-watchdog
%description
wiremock is an API Client to the Admin API for WireMock Standalone installation: https://wiremock.org/docs
`Documentation `_
`Report a Bug `_
%package -n python3-wiremock
Summary: Wiremock Admin API Client
Provides: python-wiremock
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wiremock
wiremock is an API Client to the Admin API for WireMock Standalone installation: https://wiremock.org/docs
`Documentation `_
`Report a Bug `_
%package help
Summary: Development documents and examples for wiremock
Provides: python3-wiremock-doc
%description help
wiremock is an API Client to the Admin API for WireMock Standalone installation: https://wiremock.org/docs
`Documentation `_
`Report a Bug `_
%prep
%autosetup -n wiremock-2.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wiremock -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.3.1-1
- Package Spec generated