%global _empty_manifest_terminate_build 0
Name:		python-backpack
Version:	0.1
Release:	1
Summary:	Useful utilities for Python.
License:	MIT
URL:		https://github.com/sdispater/backpack
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4e/d1/cd2034b49a3bea4cdc368a96d9d11043c71e6c13056f61976da720d89884/backpack-0.1.tar.gz
BuildArch:	noarch


%description
The ``Collection`` class provides a fluent, convenient wrapper for working with list  of data.
To instantiatte a ``Collection`` you can also use the ``collection()`` helper.
Available Methods
*****************
For the remainder of this documentation, we'll discuss each method available on the ``Collection`` class.
Remember, all of these methods may be chained for fluently manipulating the underlying list or dict.
Furthermore, almost every method returns a new ``Collection`` instance,
allowing you to preserve the original copy of the collection when necessary.
You may select any method from this table to see an example of its usage:
* all_
* avg_
* chunk_
* collapse_
* contains_
* count_
* diff_
* each_
* every_
* filter_
* first_
* flatten_
* forget_
* for_page_
* get_
* implode_
* is_empty_
* last_
* map_
* merge_
* pluck_
* pop_
* prepend_
* pull_
* push_
* put_
* reduce_
* reject_
* reverse_
* serialize_
* shift_
* sort_
* sum_
* take_
* to_json_
* transform_
* unique_
* where_
* zip_
Methods Listing
***************

%package -n python3-backpack
Summary:	Useful utilities for Python.
Provides:	python-backpack
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-backpack
The ``Collection`` class provides a fluent, convenient wrapper for working with list  of data.
To instantiatte a ``Collection`` you can also use the ``collection()`` helper.
Available Methods
*****************
For the remainder of this documentation, we'll discuss each method available on the ``Collection`` class.
Remember, all of these methods may be chained for fluently manipulating the underlying list or dict.
Furthermore, almost every method returns a new ``Collection`` instance,
allowing you to preserve the original copy of the collection when necessary.
You may select any method from this table to see an example of its usage:
* all_
* avg_
* chunk_
* collapse_
* contains_
* count_
* diff_
* each_
* every_
* filter_
* first_
* flatten_
* forget_
* for_page_
* get_
* implode_
* is_empty_
* last_
* map_
* merge_
* pluck_
* pop_
* prepend_
* pull_
* push_
* put_
* reduce_
* reject_
* reverse_
* serialize_
* shift_
* sort_
* sum_
* take_
* to_json_
* transform_
* unique_
* where_
* zip_
Methods Listing
***************

%package help
Summary:	Development documents and examples for backpack
Provides:	python3-backpack-doc
%description help
The ``Collection`` class provides a fluent, convenient wrapper for working with list  of data.
To instantiatte a ``Collection`` you can also use the ``collection()`` helper.
Available Methods
*****************
For the remainder of this documentation, we'll discuss each method available on the ``Collection`` class.
Remember, all of these methods may be chained for fluently manipulating the underlying list or dict.
Furthermore, almost every method returns a new ``Collection`` instance,
allowing you to preserve the original copy of the collection when necessary.
You may select any method from this table to see an example of its usage:
* all_
* avg_
* chunk_
* collapse_
* contains_
* count_
* diff_
* each_
* every_
* filter_
* first_
* flatten_
* forget_
* for_page_
* get_
* implode_
* is_empty_
* last_
* map_
* merge_
* pluck_
* pop_
* prepend_
* pull_
* push_
* put_
* reduce_
* reject_
* reverse_
* serialize_
* shift_
* sort_
* sum_
* take_
* to_json_
* transform_
* unique_
* where_
* zip_
Methods Listing
***************

%prep
%autosetup -n backpack-0.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-backpack -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1-1
- Package Spec generated