%global _empty_manifest_terminate_build 0
Name: python-brython
Version: 3.11.2
Release: 1
Summary: Brython is an implementation of Python 3 running in the browser
License: BSD License
URL: https://brython.info
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bc/10/2af8f59dc75484712a2f517a0751530f401e8b3ee77da3784cfa8626697e/brython-3.11.2.tar.gz
BuildArch: noarch
%description
With Brython you can write browser programs in Python instead of Javascript,
by inserting Python code in an HTML page by:
Usage:
pip install brython
Then in an empty folder:
brython-cli --install
or in a folder with older versions already present:
brython-cli --update
The package includes a page **demo.html** with examples of use. For more
information see the [Brython site](http://brython.info).
%package -n python3-brython
Summary: Brython is an implementation of Python 3 running in the browser
Provides: python-brython
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-brython
With Brython you can write browser programs in Python instead of Javascript,
by inserting Python code in an HTML page by:
Usage:
pip install brython
Then in an empty folder:
brython-cli --install
or in a folder with older versions already present:
brython-cli --update
The package includes a page **demo.html** with examples of use. For more
information see the [Brython site](http://brython.info).
%package help
Summary: Development documents and examples for brython
Provides: python3-brython-doc
%description help
With Brython you can write browser programs in Python instead of Javascript,
by inserting Python code in an HTML page by:
Usage:
pip install brython
Then in an empty folder:
brython-cli --install
or in a folder with older versions already present:
brython-cli --update
The package includes a page **demo.html** with examples of use. For more
information see the [Brython site](http://brython.info).
%prep
%autosetup -n brython-3.11.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-brython -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 3.11.2-1
- Package Spec generated