%global _empty_manifest_terminate_build 0
Name: python-urbanairship
Version: 6.1.0
Release: 1
Summary: Python package for using the Airship API
License: BSD License
URL: https://airship.com/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f9/18/d97b2b309295c30a60dedbb72c2364f96ae730a622196724240a84f81203/urbanairship-6.1.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-six
Requires: python3-backoff
%description
``urbanairship`` is a Python library for using the `Airship
`_ REST API for push notifications, message
center messages, email, and SMS.
%package -n python3-urbanairship
Summary: Python package for using the Airship API
Provides: python-urbanairship
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-urbanairship
``urbanairship`` is a Python library for using the `Airship
`_ REST API for push notifications, message
center messages, email, and SMS.
%package help
Summary: Development documents and examples for urbanairship
Provides: python3-urbanairship-doc
%description help
``urbanairship`` is a Python library for using the `Airship
`_ REST API for push notifications, message
center messages, email, and SMS.
%prep
%autosetup -n urbanairship-6.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-urbanairship -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 6.1.0-1
- Package Spec generated