%global _empty_manifest_terminate_build 0
Name:		python-ladybug-geometry-polyskel
Version:	1.4.14
Release:	1
Summary:	A library with poly skeleton methods using ladybug-geometry
License:	AGPL-3.0
URL:		https://github.com/ladybug-tools/ladybug-geometry-polyskel
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/98/8c/48cb63981134b0997831b192bf64c9be0344e2024bd804cde1e2388d9745/ladybug-geometry-polyskel-1.4.14.tar.gz
BuildArch:	noarch

Requires:	python3-ladybug-geometry

%description
[![Build Status](https://travis-ci.com/ladybug-tools/ladybug-geometry-polyskel.svg?branch=master)](https://travis-ci.com/ladybug-tools/ladybug-geometry-polyskel)
[![Coverage Status](https://coveralls.io/repos/github/ladybug-tools/ladybug-geometry-polyskel/badge.svg?branch=master)](https://coveralls.io/github/ladybug-tools/ladybug-geometry-polyskel)

[![Python 3.7](https://img.shields.io/badge/python-3.7-blue.svg)](https://www.python.org/downloads/release/python-370/) [![Python 2.7](https://img.shields.io/badge/python-2.7-green.svg)](https://www.python.org/downloads/release/python-270/) [![IronPython](https://img.shields.io/badge/ironpython-2.7-red.svg)](https://github.com/IronLanguages/ironpython2/releases/tag/ipy-2.7.8/)

# ladybug-geometry-polyskel

A library with straight skeleton methods using ladybug-geometry.

## Credits

Ladybug-geometry-polyskel is a derivative work of the the [polyskel package](https://github.com/Botffy/polyskel)
by [Ármin Scipiades](https://github.com/Botffy) (@Bottfy), which is, itself, a Python 3
implementation of the straight skeleton algorithm as described by Felkel and Obdržálek
in their 1998 conference paper [Straight skeleton implementation](https://github.com/Botffy/polyskel/blob/master/doc/StraightSkeletonImplementation.pdf).

Key differences between Bottfy's original implementation and this package are:

* It has been modified for compatibility with both Python 2.7 and Python 3.7.
* The code as been re-stylized to conform to the PEP8 style guide.
* Modules have been added to extract core/perimeter polygons from the straight skeleton.

## Installation

```console
pip install -U ladybug-geometry-polyskel
```

## QuickStart

```python
import ladybug_geometry_polyskel

```

## [API Documentation](http://ladybug-tools.github.io/ladybug-geometry-polyskel/docs)

## Local Development
1. Clone this repo locally
```console
git clone git@github.com:ladybug-tools/ladybug-geometry-polyskel

# or

git clone https://github.com/ladybug-tools/ladybug-geometry-polyskel
```
2. Install dependencies:
```console
cd ladybug-geometry-polyskel
pip install -r dev-requirements.txt
pip install -r requirements.txt
```

3. Run Tests:
```console
python -m pytest tests/
```

4. Generate Documentation:
```console
sphinx-apidoc -f -e -d 4 -o ./docs ./ladybug_geometry_polyskel
sphinx-build -b html ./docs ./docs/_build/docs
```

## Copyright 

Ladybug Geometry Polyskel, Copyright (c) 2021, Ármin Scipiades, Ladybug Tools LLC
and other contributors. All rights reserved.


%package -n python3-ladybug-geometry-polyskel
Summary:	A library with poly skeleton methods using ladybug-geometry
Provides:	python-ladybug-geometry-polyskel
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ladybug-geometry-polyskel
[![Build Status](https://travis-ci.com/ladybug-tools/ladybug-geometry-polyskel.svg?branch=master)](https://travis-ci.com/ladybug-tools/ladybug-geometry-polyskel)
[![Coverage Status](https://coveralls.io/repos/github/ladybug-tools/ladybug-geometry-polyskel/badge.svg?branch=master)](https://coveralls.io/github/ladybug-tools/ladybug-geometry-polyskel)

[![Python 3.7](https://img.shields.io/badge/python-3.7-blue.svg)](https://www.python.org/downloads/release/python-370/) [![Python 2.7](https://img.shields.io/badge/python-2.7-green.svg)](https://www.python.org/downloads/release/python-270/) [![IronPython](https://img.shields.io/badge/ironpython-2.7-red.svg)](https://github.com/IronLanguages/ironpython2/releases/tag/ipy-2.7.8/)

# ladybug-geometry-polyskel

A library with straight skeleton methods using ladybug-geometry.

## Credits

Ladybug-geometry-polyskel is a derivative work of the the [polyskel package](https://github.com/Botffy/polyskel)
by [Ármin Scipiades](https://github.com/Botffy) (@Bottfy), which is, itself, a Python 3
implementation of the straight skeleton algorithm as described by Felkel and Obdržálek
in their 1998 conference paper [Straight skeleton implementation](https://github.com/Botffy/polyskel/blob/master/doc/StraightSkeletonImplementation.pdf).

Key differences between Bottfy's original implementation and this package are:

* It has been modified for compatibility with both Python 2.7 and Python 3.7.
* The code as been re-stylized to conform to the PEP8 style guide.
* Modules have been added to extract core/perimeter polygons from the straight skeleton.

## Installation

```console
pip install -U ladybug-geometry-polyskel
```

## QuickStart

```python
import ladybug_geometry_polyskel

```

## [API Documentation](http://ladybug-tools.github.io/ladybug-geometry-polyskel/docs)

## Local Development
1. Clone this repo locally
```console
git clone git@github.com:ladybug-tools/ladybug-geometry-polyskel

# or

git clone https://github.com/ladybug-tools/ladybug-geometry-polyskel
```
2. Install dependencies:
```console
cd ladybug-geometry-polyskel
pip install -r dev-requirements.txt
pip install -r requirements.txt
```

3. Run Tests:
```console
python -m pytest tests/
```

4. Generate Documentation:
```console
sphinx-apidoc -f -e -d 4 -o ./docs ./ladybug_geometry_polyskel
sphinx-build -b html ./docs ./docs/_build/docs
```

## Copyright 

Ladybug Geometry Polyskel, Copyright (c) 2021, Ármin Scipiades, Ladybug Tools LLC
and other contributors. All rights reserved.


%package help
Summary:	Development documents and examples for ladybug-geometry-polyskel
Provides:	python3-ladybug-geometry-polyskel-doc
%description help
[![Build Status](https://travis-ci.com/ladybug-tools/ladybug-geometry-polyskel.svg?branch=master)](https://travis-ci.com/ladybug-tools/ladybug-geometry-polyskel)
[![Coverage Status](https://coveralls.io/repos/github/ladybug-tools/ladybug-geometry-polyskel/badge.svg?branch=master)](https://coveralls.io/github/ladybug-tools/ladybug-geometry-polyskel)

[![Python 3.7](https://img.shields.io/badge/python-3.7-blue.svg)](https://www.python.org/downloads/release/python-370/) [![Python 2.7](https://img.shields.io/badge/python-2.7-green.svg)](https://www.python.org/downloads/release/python-270/) [![IronPython](https://img.shields.io/badge/ironpython-2.7-red.svg)](https://github.com/IronLanguages/ironpython2/releases/tag/ipy-2.7.8/)

# ladybug-geometry-polyskel

A library with straight skeleton methods using ladybug-geometry.

## Credits

Ladybug-geometry-polyskel is a derivative work of the the [polyskel package](https://github.com/Botffy/polyskel)
by [Ármin Scipiades](https://github.com/Botffy) (@Bottfy), which is, itself, a Python 3
implementation of the straight skeleton algorithm as described by Felkel and Obdržálek
in their 1998 conference paper [Straight skeleton implementation](https://github.com/Botffy/polyskel/blob/master/doc/StraightSkeletonImplementation.pdf).

Key differences between Bottfy's original implementation and this package are:

* It has been modified for compatibility with both Python 2.7 and Python 3.7.
* The code as been re-stylized to conform to the PEP8 style guide.
* Modules have been added to extract core/perimeter polygons from the straight skeleton.

## Installation

```console
pip install -U ladybug-geometry-polyskel
```

## QuickStart

```python
import ladybug_geometry_polyskel

```

## [API Documentation](http://ladybug-tools.github.io/ladybug-geometry-polyskel/docs)

## Local Development
1. Clone this repo locally
```console
git clone git@github.com:ladybug-tools/ladybug-geometry-polyskel

# or

git clone https://github.com/ladybug-tools/ladybug-geometry-polyskel
```
2. Install dependencies:
```console
cd ladybug-geometry-polyskel
pip install -r dev-requirements.txt
pip install -r requirements.txt
```

3. Run Tests:
```console
python -m pytest tests/
```

4. Generate Documentation:
```console
sphinx-apidoc -f -e -d 4 -o ./docs ./ladybug_geometry_polyskel
sphinx-build -b html ./docs ./docs/_build/docs
```

## Copyright 

Ladybug Geometry Polyskel, Copyright (c) 2021, Ármin Scipiades, Ladybug Tools LLC
and other contributors. All rights reserved.


%prep
%autosetup -n ladybug-geometry-polyskel-1.4.14

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ladybug-geometry-polyskel -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.14-1
- Package Spec generated