%global _empty_manifest_terminate_build 0
Name: python-django-advanced-filters
Version: 2.0.0
Release: 1
Summary: A Django application for advanced admin filters
License: MIT
URL: https://github.com/modlinltd/django-advanced-filters
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/eb/a5/47d761549782124270e97079c7920bec0ef6ae38e6ec47f612df3d87c7e8/django-advanced-filters-2.0.0.tar.gz
BuildArch: noarch
Requires: python3-simplejson
Requires: python3-coveralls
Requires: python3-factory-boy
Requires: python3-pycodestyle
Requires: python3-pytest-django
Requires: python3-pytest-cov
%description
+-----------+------------------+---------------------+----------+------------+
| Branch | Build | Coverage | PyPI | Gitter |
+===========+==================+=====================+==========+============+
| Master | |Build-Master| | |Coverage-Master| | |PyPI| | |Gitter| |
+-----------+------------------+---------------------+----------+------------+
| Develop | |Build-Develop| | |Coverage-Develop| | | |
+-----------+------------------+---------------------+----------+------------+
A django ModelAdmin mixin which adds advanced filtering abilities to the
admin.
Mimics the advanced search feature in
`VTiger `__, `see here for more
info `__
For release notes, see `Changelog `__
%package -n python3-django-advanced-filters
Summary: A Django application for advanced admin filters
Provides: python-django-advanced-filters
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-django-advanced-filters
+-----------+------------------+---------------------+----------+------------+
| Branch | Build | Coverage | PyPI | Gitter |
+===========+==================+=====================+==========+============+
| Master | |Build-Master| | |Coverage-Master| | |PyPI| | |Gitter| |
+-----------+------------------+---------------------+----------+------------+
| Develop | |Build-Develop| | |Coverage-Develop| | | |
+-----------+------------------+---------------------+----------+------------+
A django ModelAdmin mixin which adds advanced filtering abilities to the
admin.
Mimics the advanced search feature in
`VTiger `__, `see here for more
info `__
For release notes, see `Changelog `__
%package help
Summary: Development documents and examples for django-advanced-filters
Provides: python3-django-advanced-filters-doc
%description help
+-----------+------------------+---------------------+----------+------------+
| Branch | Build | Coverage | PyPI | Gitter |
+===========+==================+=====================+==========+============+
| Master | |Build-Master| | |Coverage-Master| | |PyPI| | |Gitter| |
+-----------+------------------+---------------------+----------+------------+
| Develop | |Build-Develop| | |Coverage-Develop| | | |
+-----------+------------------+---------------------+----------+------------+
A django ModelAdmin mixin which adds advanced filtering abilities to the
admin.
Mimics the advanced search feature in
`VTiger `__, `see here for more
info `__
For release notes, see `Changelog `__
%prep
%autosetup -n django-advanced-filters-2.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-django-advanced-filters -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.0.0-1
- Package Spec generated