%global _empty_manifest_terminate_build 0
Name:		python-urdfpy
Version:	0.0.22
Release:	1
Summary:	URDF parser and manipulator for Python
License:	MIT License
URL:		https://github.com/mmatl/urdfpy
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ba/a0/61fb688bcfa359f91f372dacfdbcf4e16a721e6d1ca8f215c068ae2a762e/urdfpy-0.0.22.tar.gz
BuildArch:	noarch

Requires:	python3-lxml
Requires:	python3-networkx
Requires:	python3-numpy
Requires:	python3-pillow
Requires:	python3-pycollada
Requires:	python3-pyrender
Requires:	python3-scipy
Requires:	python3-six
Requires:	python3-trimesh
Requires:	python3-flake8
Requires:	python3-pre-commit
Requires:	python3-pytest
Requires:	python3-pytest-cov
Requires:	python3-tox
Requires:	python3-sphinx
Requires:	python3-sphinx-rtd-theme
Requires:	python3-sphinx-automodapi

%description
URDF parser and manipulator for Python




%package -n python3-urdfpy
Summary:	URDF parser and manipulator for Python
Provides:	python-urdfpy
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-urdfpy
URDF parser and manipulator for Python




%package help
Summary:	Development documents and examples for urdfpy
Provides:	python3-urdfpy-doc
%description help
URDF parser and manipulator for Python




%prep
%autosetup -n urdfpy-0.0.22

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-urdfpy -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.22-1
- Package Spec generated