%global _empty_manifest_terminate_build 0
Name: python-autotrader
Version: 0.12.0
Release: 1
Summary: A Python-based platform for developing, optimising and deploying automated trading systems.
License: gpl-3.0
URL: https://kieran-mackle.github.io/AutoTrader/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a6/54/b48923bb1f96653e7b7520be835d023aaca8916f0d8816984ef5a660af6b/autotrader-0.12.0.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pandas
Requires: python3-art
Requires: python3-PyYAML
Requires: python3-bokeh
Requires: python3-scipy
Requires: python3-finta
Requires: python3-tqdm
Requires: python3-importlib-resources
Requires: python3-click
Requires: python3-requests
Requires: python3-telegram-bot
Requires: python3-psutil
Requires: python3-prometheus-client
Requires: python3-ccxt
Requires: python3-v20
Requires: python3-ib-insync
Requires: python3-yfinance
Requires: python3-pytest
Requires: python3-black
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-inline-tabs
Requires: python3-myst-parser
Requires: python3-furo
Requires: python3-sphinx-autobuild
Requires: python3-commitizen
Requires: python3-ccxt
Requires: python3-pytest
Requires: python3-black
Requires: python3-sphinx-copybutton
Requires: python3-sphinx-inline-tabs
Requires: python3-myst-parser
Requires: python3-furo
Requires: python3-sphinx-autobuild
Requires: python3-commitizen
Requires: python3-dydx-v3-python
Requires: python3-ib-insync
Requires: python3-v20
Requires: python3-yfinance
%description
AutoTrader
AutoTrader is Python-based platform intended to help in the development, optimisation and deployment of automated trading systems.
A basic level of experience with Python is recommended for using AutoTrader, but the [docs](https://autotrader.readthedocs.io/en/latest/)
aim to make using it as easy as possible with detailed tutorials and documentation.
## Latest News
- Version 0.7 has been released, adding integrations with [CCXT](https://github.com/ccxt/ccxt) and [dYdX](https://dydx.exchange/) crypto exchanges. Many more powerful upgrades too.
- AutoTrader has been featured in GitClone's recent article, [*Top Crypto Trader Open-Source Projects on Github*](https://gitclone.dev/top-crypto-trader-open-source-projects-on-github/).
## Features
- A feature-rich trading simulator, supporting [backtesting](https://autotrader.readthedocs.io/en/latest/features/backtesting.html) and
papertrading. The 'virtual broker' allows you to test your strategies in a risk-free, simulated environment before going live. Capable
of simulating multiple order types, stop-losses and take-profits, cross-exchange arbitrage and portfolio strategies, AutoTrader has
more than enough to build a profitable trading system.
- [Integrated data feeds](https://kieran-mackle.github.io/AutoTrader/tutorials/price-data), making OHLC data retrieval as easy as possible.
- [Automated interactive visualisation](https://autotrader.readthedocs.io/en/latest/features/visualisation.html) using [Bokeh](https://bokeh.org/)
- [Library of custom indicators](https://autotrader.readthedocs.io/en/latest/indicators.html).
- [Live trading](https://autotrader.readthedocs.io/en/latest/features/live-trading.html) supported for multiple venues.
- [Detailed documenation and tutorials](https://autotrader.readthedocs.io/en/latest/index.html)
- [Repository](https://github.com/kieran-mackle/autotrader-demo) of example strategies
## Supported Brokers and Exchanges
| Broker | Asset classes | Integration status |
| -------- | ------------- | ------------------ |
| [Oanda](https://www.oanda.com/) | Forex CFDs | Complete |
| [Interactive Brokers](https://www.interactivebrokers.com/en/home.php) | Many | In progress |
| [dYdX](https://dydx.exchange/) | Cryptocurrencies | Complete |
| [CCXT](https://github.com/ccxt/ccxt) | Cryptocurrencies | In progress |
## Installation
AutoTrader can be installed using pip:
```
pip install autotrader
```
### Updating
AutoTrader can be updated by appending the `--upgrade` flag to the install command:
```
pip install autotrader --upgrade
```
## Documentation
AutoTrader is very well documented in-code and on [Read the Docs](https://autotrader.readthedocs.io/en/latest/). There is also a [detailed walthrough](https://autotrader.readthedocs.io/en/latest/tutorials/walkthrough.html), covering everything from strategy concept to livetrading.
### Example Strategies
Example strategies can be found in the [demo repository](https://github.com/kieran-mackle/autotrader-demo).
## Backtest Demo
The chart below is produced by a backtest of the MACD trend strategy documented in the
[tutorials](https://autotrader.readthedocs.io/en/latest/tutorials/building-strategy.html) (and available in the
[demo repository](https://github.com/kieran-mackle/autotrader-demo)). Entry signals are defined by MACD crossovers, with exit targets defined
by a 1.5 risk-to-reward ratio. Stop-losses are automatically placed using the custom
[swing detection](https://autotrader.readthedocs.io/en/latest/indicators.html#swing-detection) indicator, and position sizes are dynamically calculated based
on risk percentages defined in the strategy configuration.
Running this strategy with AutoTrader in backtest mode will produce the following interactive chart.
[](https://autotrader.readthedocs.io/en/latest/tutorials/backtesting.html#interactive-chart)
Note that stop loss and take profit levels are shown for each trade taken. This allows you to see how effective your exit strategy is - are you being stopped out too
early by placing your stop losses too tight? Are you missing out on otherwise profitable trades becuase your take profits are too far away? AutoTrader helps you
visualise your strategy and answer these questions.
## Legal
### License
AutoTrader is licensed under the [GNU General Public License v3.0](https://www.gnu.org/licenses/gpl-3.0.en.html).
### Disclaimer
This platform is currently under heavy development and should not be considered stable for livetrading until version 1.0.0 is released.
Never risk money you cannot afford to lose. Always test your strategies on a paper trading account before taking it live.
%package -n python3-autotrader
Summary: A Python-based platform for developing, optimising and deploying automated trading systems.
Provides: python-autotrader
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-autotrader
AutoTrader
AutoTrader is Python-based platform intended to help in the development, optimisation and deployment of automated trading systems.
A basic level of experience with Python is recommended for using AutoTrader, but the [docs](https://autotrader.readthedocs.io/en/latest/)
aim to make using it as easy as possible with detailed tutorials and documentation.
## Latest News
- Version 0.7 has been released, adding integrations with [CCXT](https://github.com/ccxt/ccxt) and [dYdX](https://dydx.exchange/) crypto exchanges. Many more powerful upgrades too.
- AutoTrader has been featured in GitClone's recent article, [*Top Crypto Trader Open-Source Projects on Github*](https://gitclone.dev/top-crypto-trader-open-source-projects-on-github/).
## Features
- A feature-rich trading simulator, supporting [backtesting](https://autotrader.readthedocs.io/en/latest/features/backtesting.html) and
papertrading. The 'virtual broker' allows you to test your strategies in a risk-free, simulated environment before going live. Capable
of simulating multiple order types, stop-losses and take-profits, cross-exchange arbitrage and portfolio strategies, AutoTrader has
more than enough to build a profitable trading system.
- [Integrated data feeds](https://kieran-mackle.github.io/AutoTrader/tutorials/price-data), making OHLC data retrieval as easy as possible.
- [Automated interactive visualisation](https://autotrader.readthedocs.io/en/latest/features/visualisation.html) using [Bokeh](https://bokeh.org/)
- [Library of custom indicators](https://autotrader.readthedocs.io/en/latest/indicators.html).
- [Live trading](https://autotrader.readthedocs.io/en/latest/features/live-trading.html) supported for multiple venues.
- [Detailed documenation and tutorials](https://autotrader.readthedocs.io/en/latest/index.html)
- [Repository](https://github.com/kieran-mackle/autotrader-demo) of example strategies
## Supported Brokers and Exchanges
| Broker | Asset classes | Integration status |
| -------- | ------------- | ------------------ |
| [Oanda](https://www.oanda.com/) | Forex CFDs | Complete |
| [Interactive Brokers](https://www.interactivebrokers.com/en/home.php) | Many | In progress |
| [dYdX](https://dydx.exchange/) | Cryptocurrencies | Complete |
| [CCXT](https://github.com/ccxt/ccxt) | Cryptocurrencies | In progress |
## Installation
AutoTrader can be installed using pip:
```
pip install autotrader
```
### Updating
AutoTrader can be updated by appending the `--upgrade` flag to the install command:
```
pip install autotrader --upgrade
```
## Documentation
AutoTrader is very well documented in-code and on [Read the Docs](https://autotrader.readthedocs.io/en/latest/). There is also a [detailed walthrough](https://autotrader.readthedocs.io/en/latest/tutorials/walkthrough.html), covering everything from strategy concept to livetrading.
### Example Strategies
Example strategies can be found in the [demo repository](https://github.com/kieran-mackle/autotrader-demo).
## Backtest Demo
The chart below is produced by a backtest of the MACD trend strategy documented in the
[tutorials](https://autotrader.readthedocs.io/en/latest/tutorials/building-strategy.html) (and available in the
[demo repository](https://github.com/kieran-mackle/autotrader-demo)). Entry signals are defined by MACD crossovers, with exit targets defined
by a 1.5 risk-to-reward ratio. Stop-losses are automatically placed using the custom
[swing detection](https://autotrader.readthedocs.io/en/latest/indicators.html#swing-detection) indicator, and position sizes are dynamically calculated based
on risk percentages defined in the strategy configuration.
Running this strategy with AutoTrader in backtest mode will produce the following interactive chart.
[](https://autotrader.readthedocs.io/en/latest/tutorials/backtesting.html#interactive-chart)
Note that stop loss and take profit levels are shown for each trade taken. This allows you to see how effective your exit strategy is - are you being stopped out too
early by placing your stop losses too tight? Are you missing out on otherwise profitable trades becuase your take profits are too far away? AutoTrader helps you
visualise your strategy and answer these questions.
## Legal
### License
AutoTrader is licensed under the [GNU General Public License v3.0](https://www.gnu.org/licenses/gpl-3.0.en.html).
### Disclaimer
This platform is currently under heavy development and should not be considered stable for livetrading until version 1.0.0 is released.
Never risk money you cannot afford to lose. Always test your strategies on a paper trading account before taking it live.
%package help
Summary: Development documents and examples for autotrader
Provides: python3-autotrader-doc
%description help
AutoTrader
AutoTrader is Python-based platform intended to help in the development, optimisation and deployment of automated trading systems.
A basic level of experience with Python is recommended for using AutoTrader, but the [docs](https://autotrader.readthedocs.io/en/latest/)
aim to make using it as easy as possible with detailed tutorials and documentation.
## Latest News
- Version 0.7 has been released, adding integrations with [CCXT](https://github.com/ccxt/ccxt) and [dYdX](https://dydx.exchange/) crypto exchanges. Many more powerful upgrades too.
- AutoTrader has been featured in GitClone's recent article, [*Top Crypto Trader Open-Source Projects on Github*](https://gitclone.dev/top-crypto-trader-open-source-projects-on-github/).
## Features
- A feature-rich trading simulator, supporting [backtesting](https://autotrader.readthedocs.io/en/latest/features/backtesting.html) and
papertrading. The 'virtual broker' allows you to test your strategies in a risk-free, simulated environment before going live. Capable
of simulating multiple order types, stop-losses and take-profits, cross-exchange arbitrage and portfolio strategies, AutoTrader has
more than enough to build a profitable trading system.
- [Integrated data feeds](https://kieran-mackle.github.io/AutoTrader/tutorials/price-data), making OHLC data retrieval as easy as possible.
- [Automated interactive visualisation](https://autotrader.readthedocs.io/en/latest/features/visualisation.html) using [Bokeh](https://bokeh.org/)
- [Library of custom indicators](https://autotrader.readthedocs.io/en/latest/indicators.html).
- [Live trading](https://autotrader.readthedocs.io/en/latest/features/live-trading.html) supported for multiple venues.
- [Detailed documenation and tutorials](https://autotrader.readthedocs.io/en/latest/index.html)
- [Repository](https://github.com/kieran-mackle/autotrader-demo) of example strategies
## Supported Brokers and Exchanges
| Broker | Asset classes | Integration status |
| -------- | ------------- | ------------------ |
| [Oanda](https://www.oanda.com/) | Forex CFDs | Complete |
| [Interactive Brokers](https://www.interactivebrokers.com/en/home.php) | Many | In progress |
| [dYdX](https://dydx.exchange/) | Cryptocurrencies | Complete |
| [CCXT](https://github.com/ccxt/ccxt) | Cryptocurrencies | In progress |
## Installation
AutoTrader can be installed using pip:
```
pip install autotrader
```
### Updating
AutoTrader can be updated by appending the `--upgrade` flag to the install command:
```
pip install autotrader --upgrade
```
## Documentation
AutoTrader is very well documented in-code and on [Read the Docs](https://autotrader.readthedocs.io/en/latest/). There is also a [detailed walthrough](https://autotrader.readthedocs.io/en/latest/tutorials/walkthrough.html), covering everything from strategy concept to livetrading.
### Example Strategies
Example strategies can be found in the [demo repository](https://github.com/kieran-mackle/autotrader-demo).
## Backtest Demo
The chart below is produced by a backtest of the MACD trend strategy documented in the
[tutorials](https://autotrader.readthedocs.io/en/latest/tutorials/building-strategy.html) (and available in the
[demo repository](https://github.com/kieran-mackle/autotrader-demo)). Entry signals are defined by MACD crossovers, with exit targets defined
by a 1.5 risk-to-reward ratio. Stop-losses are automatically placed using the custom
[swing detection](https://autotrader.readthedocs.io/en/latest/indicators.html#swing-detection) indicator, and position sizes are dynamically calculated based
on risk percentages defined in the strategy configuration.
Running this strategy with AutoTrader in backtest mode will produce the following interactive chart.
[](https://autotrader.readthedocs.io/en/latest/tutorials/backtesting.html#interactive-chart)
Note that stop loss and take profit levels are shown for each trade taken. This allows you to see how effective your exit strategy is - are you being stopped out too
early by placing your stop losses too tight? Are you missing out on otherwise profitable trades becuase your take profits are too far away? AutoTrader helps you
visualise your strategy and answer these questions.
## Legal
### License
AutoTrader is licensed under the [GNU General Public License v3.0](https://www.gnu.org/licenses/gpl-3.0.en.html).
### Disclaimer
This platform is currently under heavy development and should not be considered stable for livetrading until version 1.0.0 is released.
Never risk money you cannot afford to lose. Always test your strategies on a paper trading account before taking it live.
%prep
%autosetup -n autotrader-0.12.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-autotrader -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.12.0-1
- Package Spec generated