%global _empty_manifest_terminate_build 0
Name: python-craps
Version: 2.0.2
Release: 1
Summary: A table game engine.
License: MIT
URL: https://github.com/mhegarty/craps
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/59/e4/1cb15eaba4b9356ee4d109f487942a893b729c6578b2ee5c8463a08ba105/craps-2.0.2.tar.gz
BuildArch: noarch
Requires: python3-appdirs
%description
[![Contributors][contributors-shield]][contributors-url]
[![Forks][forks-shield]][forks-url]
[![Stargazers][stars-shield]][stars-url]
[![Issues][issues-shield]][issues-url]
[![MIT License][license-shield]][license-url]
[![LinkedIn][linkedin-shield]][linkedin-url]
craps
## Installation
Install with pip (recommended)
```sh
pip install craps
```
## Usage
```python
!pip install craps
from craps import Game, PassBet, LineOddsBet, ComeBet, PointOddsBet
```
Collecting craps
Downloading craps-1.1.0-py3-none-any.whl (9.9 kB)
Installing collected packages: craps
Successfully installed craps-1.1.0
```python
# Start a game with $100 at a table with a $10 minimum
g = Game(arrival_cash = 100, minimum_bet=10)
# Place a bet for $10, then roll the dice!
g.bet(PassBet(10))
g.roll()
```
[Bet] You made a PassBet on the box for 10
[Rail] You have 990.0 on the rail
[Table] The shooter is ready, the point is off
[Table] PassBet for 10 is working on the box
[Roll] Shooter rolled 10
[Roll] The point is 10
[Rail] You have 990.0 on the rail
```python
# Put $20 odds on line bet
g.bet(LineOddsBet(20, g.puck))
# And place an additional come bet for the table minimum
g.bet(ComeBet(g.minimum_bet))
```
[Bet] You made a LineOddsBet on 10 for 20
[Rail] You have 970.0 on the rail
[Bet] You made a ComeBet on the box for 10.0
[Rail] You have 960.0 on the rail
```python
# Roll!
g.roll()
```
[Table] The shooter is ready, the point is 10
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on the box
[Roll] Shooter rolled 8
[Roll] 2+6=8 came easy
[Bet] ComeBet for 10.0 was moved to the 8
[Rail] You have 960.0 on the rail
```python
# Check your bets
g.callout()
```
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on 8
```python
# Put $30 odds on your 8
g.bet(PointOddsBet(30, 8))
```
[Bet] You made a PointOddsBet on 8 for 30
[Rail] You have 930.0 on the rail
```python
# Roll!
g.roll()
```
[Table] The shooter is ready, the point is 10
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on 8
[Table] PointOddsBet for 30 is working on 8
[Roll] Shooter rolled 10
[Roll] Winner!!, 10
[Payout] PassBet on 10 paid out 20
[Payout] LineOddsBet on 10 paid out 60.0
[Rail] You have 1010.0 on the rail
(back to top)
## Roadmap
- Add Bet types to model.py
- Add [place bets](https://www.liveabout.com/craps-place-bets-537453)
- Add [side bets](https://wizardofodds.com/games/craps/appendix/5/)
- Add the [Yo](https://www.lolcraps.com/craps/bets/yo/) first. That's fun.
- Strategy constructor / builder
- Logic layer to facilitate strategy construction in a low code environment. For example:
- `IF` the game puck is off `AND` I do not have a place bet, `THEN` make a place bet.
- `IF` the game puck is on `AND` I do not have odds on a place or come bet, `THEN` put f(x) odds on it.
See the [open issues](https://github.com/mhegarty/craps/issues) for a full list of proposed features (and known issues).
## Contributing
Contributions are what make the open source community such an amazing place to learn, inspire, and create. Any contributions you make are **greatly appreciated**.
If you have a suggestion that would make this better, please fork the repo and create a pull request. You can also simply open an issue with the tag "enhancement".
Don't forget to give the project a star! Thanks again!
1. Fork the Project
2. Create your Feature Branch (`git checkout -b feature/AmazingFeature`)
3. Commit your Changes (`git commit -m 'Add some AmazingFeature'`)
4. Push to the Branch (`git push origin feature/AmazingFeature`)
5. Open a Pull Request
## License
Distributed under the MIT License. See `LICENSE.txt` for more information.
## Contact
Mike Hegarty - [@mjhegarty](https://twitter.com/@mjhegarty) - mike@petorca.com
Project Link: [https://github.com/mhegarty/craps](https://github.com/mhegarty/craps)
## Acknowledgments
* Thanks to [@dhegarty19](https://www.instagram.com/dhegarty19/) for agreeing to celebrate our third aniversary at the casino.
* Big thanks to Othneil Drew for the awesome work on [the best readme template](https://github.com/othneildrew/Best-README-Template)
* [pikpng.com](https://www.pikpng.com/pngvi/hbRwTJb_png-clipart/) for the logo image.
[contributors-shield]: https://img.shields.io/github/contributors/mhegarty/craps.svg?style=for-the-badge
[contributors-url]: https://github.com/mhegarty/craps/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/mhegarty/craps.svg?style=for-the-badge
[forks-url]: https://github.com/mhegarty/craps/network/members
[stars-shield]: https://img.shields.io/github/stars/mhegarty/craps.svg?style=for-the-badge
[stars-url]: https://github.com/mhegarty/craps/stargazers
[issues-shield]: https://img.shields.io/github/issues/mhegarty/craps.svg?style=for-the-badge
[issues-url]: https://github.com/mhegarty/craps/issues
[license-shield]: https://img.shields.io/github/license/mhegarty/craps.svg?style=for-the-badge
[license-url]: https://github.com/mhegarty/craps/blob/master/LICENSE.txt
[linkedin-shield]: https://img.shields.io/badge/-LinkedIn-black.svg?style=for-the-badge&logo=linkedin&colorB=555
[linkedin-url]: https://linkedin.com/in/hegarty
%package -n python3-craps
Summary: A table game engine.
Provides: python-craps
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-craps
[![Contributors][contributors-shield]][contributors-url]
[![Forks][forks-shield]][forks-url]
[![Stargazers][stars-shield]][stars-url]
[![Issues][issues-shield]][issues-url]
[![MIT License][license-shield]][license-url]
[![LinkedIn][linkedin-shield]][linkedin-url]
craps
## Installation
Install with pip (recommended)
```sh
pip install craps
```
## Usage
```python
!pip install craps
from craps import Game, PassBet, LineOddsBet, ComeBet, PointOddsBet
```
Collecting craps
Downloading craps-1.1.0-py3-none-any.whl (9.9 kB)
Installing collected packages: craps
Successfully installed craps-1.1.0
```python
# Start a game with $100 at a table with a $10 minimum
g = Game(arrival_cash = 100, minimum_bet=10)
# Place a bet for $10, then roll the dice!
g.bet(PassBet(10))
g.roll()
```
[Bet] You made a PassBet on the box for 10
[Rail] You have 990.0 on the rail
[Table] The shooter is ready, the point is off
[Table] PassBet for 10 is working on the box
[Roll] Shooter rolled 10
[Roll] The point is 10
[Rail] You have 990.0 on the rail
```python
# Put $20 odds on line bet
g.bet(LineOddsBet(20, g.puck))
# And place an additional come bet for the table minimum
g.bet(ComeBet(g.minimum_bet))
```
[Bet] You made a LineOddsBet on 10 for 20
[Rail] You have 970.0 on the rail
[Bet] You made a ComeBet on the box for 10.0
[Rail] You have 960.0 on the rail
```python
# Roll!
g.roll()
```
[Table] The shooter is ready, the point is 10
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on the box
[Roll] Shooter rolled 8
[Roll] 2+6=8 came easy
[Bet] ComeBet for 10.0 was moved to the 8
[Rail] You have 960.0 on the rail
```python
# Check your bets
g.callout()
```
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on 8
```python
# Put $30 odds on your 8
g.bet(PointOddsBet(30, 8))
```
[Bet] You made a PointOddsBet on 8 for 30
[Rail] You have 930.0 on the rail
```python
# Roll!
g.roll()
```
[Table] The shooter is ready, the point is 10
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on 8
[Table] PointOddsBet for 30 is working on 8
[Roll] Shooter rolled 10
[Roll] Winner!!, 10
[Payout] PassBet on 10 paid out 20
[Payout] LineOddsBet on 10 paid out 60.0
[Rail] You have 1010.0 on the rail
(back to top)
## Roadmap
- Add Bet types to model.py
- Add [place bets](https://www.liveabout.com/craps-place-bets-537453)
- Add [side bets](https://wizardofodds.com/games/craps/appendix/5/)
- Add the [Yo](https://www.lolcraps.com/craps/bets/yo/) first. That's fun.
- Strategy constructor / builder
- Logic layer to facilitate strategy construction in a low code environment. For example:
- `IF` the game puck is off `AND` I do not have a place bet, `THEN` make a place bet.
- `IF` the game puck is on `AND` I do not have odds on a place or come bet, `THEN` put f(x) odds on it.
See the [open issues](https://github.com/mhegarty/craps/issues) for a full list of proposed features (and known issues).
## Contributing
Contributions are what make the open source community such an amazing place to learn, inspire, and create. Any contributions you make are **greatly appreciated**.
If you have a suggestion that would make this better, please fork the repo and create a pull request. You can also simply open an issue with the tag "enhancement".
Don't forget to give the project a star! Thanks again!
1. Fork the Project
2. Create your Feature Branch (`git checkout -b feature/AmazingFeature`)
3. Commit your Changes (`git commit -m 'Add some AmazingFeature'`)
4. Push to the Branch (`git push origin feature/AmazingFeature`)
5. Open a Pull Request
## License
Distributed under the MIT License. See `LICENSE.txt` for more information.
## Contact
Mike Hegarty - [@mjhegarty](https://twitter.com/@mjhegarty) - mike@petorca.com
Project Link: [https://github.com/mhegarty/craps](https://github.com/mhegarty/craps)
## Acknowledgments
* Thanks to [@dhegarty19](https://www.instagram.com/dhegarty19/) for agreeing to celebrate our third aniversary at the casino.
* Big thanks to Othneil Drew for the awesome work on [the best readme template](https://github.com/othneildrew/Best-README-Template)
* [pikpng.com](https://www.pikpng.com/pngvi/hbRwTJb_png-clipart/) for the logo image.
[contributors-shield]: https://img.shields.io/github/contributors/mhegarty/craps.svg?style=for-the-badge
[contributors-url]: https://github.com/mhegarty/craps/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/mhegarty/craps.svg?style=for-the-badge
[forks-url]: https://github.com/mhegarty/craps/network/members
[stars-shield]: https://img.shields.io/github/stars/mhegarty/craps.svg?style=for-the-badge
[stars-url]: https://github.com/mhegarty/craps/stargazers
[issues-shield]: https://img.shields.io/github/issues/mhegarty/craps.svg?style=for-the-badge
[issues-url]: https://github.com/mhegarty/craps/issues
[license-shield]: https://img.shields.io/github/license/mhegarty/craps.svg?style=for-the-badge
[license-url]: https://github.com/mhegarty/craps/blob/master/LICENSE.txt
[linkedin-shield]: https://img.shields.io/badge/-LinkedIn-black.svg?style=for-the-badge&logo=linkedin&colorB=555
[linkedin-url]: https://linkedin.com/in/hegarty
%package help
Summary: Development documents and examples for craps
Provides: python3-craps-doc
%description help
[![Contributors][contributors-shield]][contributors-url]
[![Forks][forks-shield]][forks-url]
[![Stargazers][stars-shield]][stars-url]
[![Issues][issues-shield]][issues-url]
[![MIT License][license-shield]][license-url]
[![LinkedIn][linkedin-shield]][linkedin-url]
craps
## Installation
Install with pip (recommended)
```sh
pip install craps
```
## Usage
```python
!pip install craps
from craps import Game, PassBet, LineOddsBet, ComeBet, PointOddsBet
```
Collecting craps
Downloading craps-1.1.0-py3-none-any.whl (9.9 kB)
Installing collected packages: craps
Successfully installed craps-1.1.0
```python
# Start a game with $100 at a table with a $10 minimum
g = Game(arrival_cash = 100, minimum_bet=10)
# Place a bet for $10, then roll the dice!
g.bet(PassBet(10))
g.roll()
```
[Bet] You made a PassBet on the box for 10
[Rail] You have 990.0 on the rail
[Table] The shooter is ready, the point is off
[Table] PassBet for 10 is working on the box
[Roll] Shooter rolled 10
[Roll] The point is 10
[Rail] You have 990.0 on the rail
```python
# Put $20 odds on line bet
g.bet(LineOddsBet(20, g.puck))
# And place an additional come bet for the table minimum
g.bet(ComeBet(g.minimum_bet))
```
[Bet] You made a LineOddsBet on 10 for 20
[Rail] You have 970.0 on the rail
[Bet] You made a ComeBet on the box for 10.0
[Rail] You have 960.0 on the rail
```python
# Roll!
g.roll()
```
[Table] The shooter is ready, the point is 10
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on the box
[Roll] Shooter rolled 8
[Roll] 2+6=8 came easy
[Bet] ComeBet for 10.0 was moved to the 8
[Rail] You have 960.0 on the rail
```python
# Check your bets
g.callout()
```
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on 8
```python
# Put $30 odds on your 8
g.bet(PointOddsBet(30, 8))
```
[Bet] You made a PointOddsBet on 8 for 30
[Rail] You have 930.0 on the rail
```python
# Roll!
g.roll()
```
[Table] The shooter is ready, the point is 10
[Table] PassBet for 10 is working on 10
[Table] LineOddsBet for 20 is working on 10
[Table] ComeBet for 10.0 is working on 8
[Table] PointOddsBet for 30 is working on 8
[Roll] Shooter rolled 10
[Roll] Winner!!, 10
[Payout] PassBet on 10 paid out 20
[Payout] LineOddsBet on 10 paid out 60.0
[Rail] You have 1010.0 on the rail
(back to top)
## Roadmap
- Add Bet types to model.py
- Add [place bets](https://www.liveabout.com/craps-place-bets-537453)
- Add [side bets](https://wizardofodds.com/games/craps/appendix/5/)
- Add the [Yo](https://www.lolcraps.com/craps/bets/yo/) first. That's fun.
- Strategy constructor / builder
- Logic layer to facilitate strategy construction in a low code environment. For example:
- `IF` the game puck is off `AND` I do not have a place bet, `THEN` make a place bet.
- `IF` the game puck is on `AND` I do not have odds on a place or come bet, `THEN` put f(x) odds on it.
See the [open issues](https://github.com/mhegarty/craps/issues) for a full list of proposed features (and known issues).
## Contributing
Contributions are what make the open source community such an amazing place to learn, inspire, and create. Any contributions you make are **greatly appreciated**.
If you have a suggestion that would make this better, please fork the repo and create a pull request. You can also simply open an issue with the tag "enhancement".
Don't forget to give the project a star! Thanks again!
1. Fork the Project
2. Create your Feature Branch (`git checkout -b feature/AmazingFeature`)
3. Commit your Changes (`git commit -m 'Add some AmazingFeature'`)
4. Push to the Branch (`git push origin feature/AmazingFeature`)
5. Open a Pull Request
## License
Distributed under the MIT License. See `LICENSE.txt` for more information.
## Contact
Mike Hegarty - [@mjhegarty](https://twitter.com/@mjhegarty) - mike@petorca.com
Project Link: [https://github.com/mhegarty/craps](https://github.com/mhegarty/craps)
## Acknowledgments
* Thanks to [@dhegarty19](https://www.instagram.com/dhegarty19/) for agreeing to celebrate our third aniversary at the casino.
* Big thanks to Othneil Drew for the awesome work on [the best readme template](https://github.com/othneildrew/Best-README-Template)
* [pikpng.com](https://www.pikpng.com/pngvi/hbRwTJb_png-clipart/) for the logo image.
[contributors-shield]: https://img.shields.io/github/contributors/mhegarty/craps.svg?style=for-the-badge
[contributors-url]: https://github.com/mhegarty/craps/graphs/contributors
[forks-shield]: https://img.shields.io/github/forks/mhegarty/craps.svg?style=for-the-badge
[forks-url]: https://github.com/mhegarty/craps/network/members
[stars-shield]: https://img.shields.io/github/stars/mhegarty/craps.svg?style=for-the-badge
[stars-url]: https://github.com/mhegarty/craps/stargazers
[issues-shield]: https://img.shields.io/github/issues/mhegarty/craps.svg?style=for-the-badge
[issues-url]: https://github.com/mhegarty/craps/issues
[license-shield]: https://img.shields.io/github/license/mhegarty/craps.svg?style=for-the-badge
[license-url]: https://github.com/mhegarty/craps/blob/master/LICENSE.txt
[linkedin-shield]: https://img.shields.io/badge/-LinkedIn-black.svg?style=for-the-badge&logo=linkedin&colorB=555
[linkedin-url]: https://linkedin.com/in/hegarty
%prep
%autosetup -n craps-2.0.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-craps -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.2-1
- Package Spec generated