%global _empty_manifest_terminate_build 0
Name: python-wagtail-autocomplete
Version: 0.10.0
Release: 1
Summary: An Autocomplete edit handler for Pages, Snippets, and more.
License: BSD-3-Clause
URL: https://github.com/wagtail/wagtail-autocomplete
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a7/19/f8cd2bfe620037ad456a99772a2e6fd51323d0db43dfce188f435fb2bea2/wagtail-autocomplete-0.10.0.tar.gz
BuildArch: noarch
Requires: python3-wagtail
Requires: python3-Sphinx
Requires: python3-sphinx-rtd-theme
Requires: python3-tox
Requires: python3-pytest
Requires: python3-pytest-django
Requires: python3-beautifulsoup4
Requires: python3-html5lib
Requires: python3-pytest-pythonpath
%description
An edit handler for the Wagtail content editor allowing single or multi autocompleted selection of Pages, Snippets, or other models.
The widget is written in React and can be used outside the Wagtail admin, if desired.
Features
~~~~~~~~
* Rapidly select related objects via a smooth autocomplete interface
* A drop-in alternative to ``PageChooserPanel`` or ``SnippetChooserPanel``
* Create new objects from the autocomplete input if your search turns up blank
* React component can be used outside of the Wagtail admin for public-facing forms
* Default theme shares the color scheme and styles of the Wagtail admin
* Easy to re-theme with `BEM `_ methodology
Who’s using it?
~~~~~~~~~~~~~~~
* The `U.S. Press Freedom Tracker `_ makes extensive use of this edit handler with its public-facing filters and content editor to rapidly select and create new related metadata objects.
Merge into wagtail/wagtail
~~~~~~~~~~~~~~~~~~~~~~~~~~
Eventually we would like this to be merged into `wagtail/wagtail `_.
This will require some work on the Wagtail API.
* Support endpoints for non-``Page`` models
* Support standard `Django field lookups `_ such as ``id__in``
* Create objects from the API
* Permission system for non-administrator access to the API
Documentation
~~~~~~~~~~~~~
Our documentation is on `Read the Docs `_ and includes `basic usage instructions `_ as well as `contribution guidelines `_.
Contributors
~~~~~~~~~~~~
* Harris Lapiroff (Little Weaver Web Collective) for the UX and UI design
* Rachel Stevens (Little Weaver Web Collective)
* Emily Horsman (Little Weaver Web Collective)
%package -n python3-wagtail-autocomplete
Summary: An Autocomplete edit handler for Pages, Snippets, and more.
Provides: python-wagtail-autocomplete
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-wagtail-autocomplete
An edit handler for the Wagtail content editor allowing single or multi autocompleted selection of Pages, Snippets, or other models.
The widget is written in React and can be used outside the Wagtail admin, if desired.
Features
~~~~~~~~
* Rapidly select related objects via a smooth autocomplete interface
* A drop-in alternative to ``PageChooserPanel`` or ``SnippetChooserPanel``
* Create new objects from the autocomplete input if your search turns up blank
* React component can be used outside of the Wagtail admin for public-facing forms
* Default theme shares the color scheme and styles of the Wagtail admin
* Easy to re-theme with `BEM `_ methodology
Who’s using it?
~~~~~~~~~~~~~~~
* The `U.S. Press Freedom Tracker `_ makes extensive use of this edit handler with its public-facing filters and content editor to rapidly select and create new related metadata objects.
Merge into wagtail/wagtail
~~~~~~~~~~~~~~~~~~~~~~~~~~
Eventually we would like this to be merged into `wagtail/wagtail `_.
This will require some work on the Wagtail API.
* Support endpoints for non-``Page`` models
* Support standard `Django field lookups `_ such as ``id__in``
* Create objects from the API
* Permission system for non-administrator access to the API
Documentation
~~~~~~~~~~~~~
Our documentation is on `Read the Docs `_ and includes `basic usage instructions `_ as well as `contribution guidelines `_.
Contributors
~~~~~~~~~~~~
* Harris Lapiroff (Little Weaver Web Collective) for the UX and UI design
* Rachel Stevens (Little Weaver Web Collective)
* Emily Horsman (Little Weaver Web Collective)
%package help
Summary: Development documents and examples for wagtail-autocomplete
Provides: python3-wagtail-autocomplete-doc
%description help
An edit handler for the Wagtail content editor allowing single or multi autocompleted selection of Pages, Snippets, or other models.
The widget is written in React and can be used outside the Wagtail admin, if desired.
Features
~~~~~~~~
* Rapidly select related objects via a smooth autocomplete interface
* A drop-in alternative to ``PageChooserPanel`` or ``SnippetChooserPanel``
* Create new objects from the autocomplete input if your search turns up blank
* React component can be used outside of the Wagtail admin for public-facing forms
* Default theme shares the color scheme and styles of the Wagtail admin
* Easy to re-theme with `BEM `_ methodology
Who’s using it?
~~~~~~~~~~~~~~~
* The `U.S. Press Freedom Tracker `_ makes extensive use of this edit handler with its public-facing filters and content editor to rapidly select and create new related metadata objects.
Merge into wagtail/wagtail
~~~~~~~~~~~~~~~~~~~~~~~~~~
Eventually we would like this to be merged into `wagtail/wagtail `_.
This will require some work on the Wagtail API.
* Support endpoints for non-``Page`` models
* Support standard `Django field lookups `_ such as ``id__in``
* Create objects from the API
* Permission system for non-administrator access to the API
Documentation
~~~~~~~~~~~~~
Our documentation is on `Read the Docs `_ and includes `basic usage instructions `_ as well as `contribution guidelines `_.
Contributors
~~~~~~~~~~~~
* Harris Lapiroff (Little Weaver Web Collective) for the UX and UI design
* Rachel Stevens (Little Weaver Web Collective)
* Emily Horsman (Little Weaver Web Collective)
%prep
%autosetup -n wagtail-autocomplete-0.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-wagtail-autocomplete -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.10.0-1
- Package Spec generated