%global _empty_manifest_terminate_build 0
Name:		python-ossfs
Version:	2023.4.0
Release:	1
Summary:	fsspec filesystem for OSS
License:	Apache-2.0
URL:		https://github.com/fsspec/ossfs
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8e/a4/08a1c328d05b2819be7e2847782cc37f7031e188adcbfec15eee39679ad4/ossfs-2023.4.0.tar.gz
BuildArch:	noarch

Requires:	python3-fsspec
Requires:	python3-oss2
Requires:	python3-aiooss2
Requires:	python3-pytest
Requires:	python3-pytest-sugar
Requires:	python3-pytest-cov
Requires:	python3-pytest-mock
Requires:	python3-pylint
Requires:	python3-pylint-pytest
Requires:	python3-mypy
Requires:	python3-requests
Requires:	python3-aliyun-python-sdk-sts
Requires:	python3-mkdocs
Requires:	python3-mkdocs-gen-files
Requires:	python3-mkdocs-material
Requires:	python3-mkdocs-section-index
Requires:	python3-mkdocstrings-python
Requires:	python3-mkdocs
Requires:	python3-mkdocs-gen-files
Requires:	python3-mkdocs-material
Requires:	python3-mkdocs-section-index
Requires:	python3-mkdocstrings-python
Requires:	python3-pytest
Requires:	python3-pytest-sugar
Requires:	python3-pytest-cov
Requires:	python3-pytest-mock
Requires:	python3-pylint
Requires:	python3-pylint-pytest
Requires:	python3-mypy
Requires:	python3-requests
Requires:	python3-aliyun-python-sdk-sts

%description
|PyPI| |Status| |Python Version| |License|
|Tests| |Codecov| |pre-commit| |Black|
**OSSFS** is a Python-based interface for file systems that enables interaction with
OSS (Object Storage Service). Through **OSSFS**, users can utilize fsspec's standard
API to operate on OSS objects

%package -n python3-ossfs
Summary:	fsspec filesystem for OSS
Provides:	python-ossfs
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ossfs
|PyPI| |Status| |Python Version| |License|
|Tests| |Codecov| |pre-commit| |Black|
**OSSFS** is a Python-based interface for file systems that enables interaction with
OSS (Object Storage Service). Through **OSSFS**, users can utilize fsspec's standard
API to operate on OSS objects

%package help
Summary:	Development documents and examples for ossfs
Provides:	python3-ossfs-doc
%description help
|PyPI| |Status| |Python Version| |License|
|Tests| |Codecov| |pre-commit| |Black|
**OSSFS** is a Python-based interface for file systems that enables interaction with
OSS (Object Storage Service). Through **OSSFS**, users can utilize fsspec's standard
API to operate on OSS objects

%prep
%autosetup -n ossfs-2023.4.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ossfs -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.4.0-1
- Package Spec generated