%global _empty_manifest_terminate_build 0
Name:		python-mcuuid
Version:	1.1.0
Release:	1
Summary:	Getting Minecraft Player Information from Mojang API.
License:	MIT License
URL:		https://github.com/clerie/mcuuid
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/79/6f/64f48c6915d9b17199eaff7f368ff4a9ed50ca0c761a03c86a2bf1dc3a72/mcuuid-1.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
# MCUUID
Getting Minecraft Player Information from Mojang API.

## Usage
1. `pip install mcuuid`
2. Use the module like this:

### API
```
> from mcuuid import MCUUID
> player = MCUUID(name="gronkh")
> player.name
'Gronkh'
> player.names
{0: 'Gronkh'}
> player.uuid
'a2080281c2784181b961d99ed2f3347c'
```

You can also use an existing uuid to start from:

```
> player = MCUUID(uuid="a2080281c2784181b961d99ed2f3347c")
> player.name
'Gronkh'
```

### Tools
Check syntax of an username:

```
>from mcuuid.tools import is_valid_minecraft_username
> is_valid_minecraft_username('gronkh'):
True
```

Check syntax of an UUID:

```
> from mcuuid.tools import is_valid_mojang_uuid
> is_valid_mojang_uuid('a2080281c2784181b961d99ed2f3347c'):
True
```

### Version information
There is a wrapper around the new MCUUID class to still be usable using former api versions.
They are deprecated and not recommended for future use.

## License
This software is licensed under the MIT license. Feel free to use it however you like.


%package -n python3-mcuuid
Summary:	Getting Minecraft Player Information from Mojang API.
Provides:	python-mcuuid
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mcuuid
# MCUUID
Getting Minecraft Player Information from Mojang API.

## Usage
1. `pip install mcuuid`
2. Use the module like this:

### API
```
> from mcuuid import MCUUID
> player = MCUUID(name="gronkh")
> player.name
'Gronkh'
> player.names
{0: 'Gronkh'}
> player.uuid
'a2080281c2784181b961d99ed2f3347c'
```

You can also use an existing uuid to start from:

```
> player = MCUUID(uuid="a2080281c2784181b961d99ed2f3347c")
> player.name
'Gronkh'
```

### Tools
Check syntax of an username:

```
>from mcuuid.tools import is_valid_minecraft_username
> is_valid_minecraft_username('gronkh'):
True
```

Check syntax of an UUID:

```
> from mcuuid.tools import is_valid_mojang_uuid
> is_valid_mojang_uuid('a2080281c2784181b961d99ed2f3347c'):
True
```

### Version information
There is a wrapper around the new MCUUID class to still be usable using former api versions.
They are deprecated and not recommended for future use.

## License
This software is licensed under the MIT license. Feel free to use it however you like.


%package help
Summary:	Development documents and examples for mcuuid
Provides:	python3-mcuuid-doc
%description help
# MCUUID
Getting Minecraft Player Information from Mojang API.

## Usage
1. `pip install mcuuid`
2. Use the module like this:

### API
```
> from mcuuid import MCUUID
> player = MCUUID(name="gronkh")
> player.name
'Gronkh'
> player.names
{0: 'Gronkh'}
> player.uuid
'a2080281c2784181b961d99ed2f3347c'
```

You can also use an existing uuid to start from:

```
> player = MCUUID(uuid="a2080281c2784181b961d99ed2f3347c")
> player.name
'Gronkh'
```

### Tools
Check syntax of an username:

```
>from mcuuid.tools import is_valid_minecraft_username
> is_valid_minecraft_username('gronkh'):
True
```

Check syntax of an UUID:

```
> from mcuuid.tools import is_valid_mojang_uuid
> is_valid_mojang_uuid('a2080281c2784181b961d99ed2f3347c'):
True
```

### Version information
There is a wrapper around the new MCUUID class to still be usable using former api versions.
They are deprecated and not recommended for future use.

## License
This software is licensed under the MIT license. Feel free to use it however you like.


%prep
%autosetup -n mcuuid-1.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mcuuid -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
- Package Spec generated