%global _empty_manifest_terminate_build 0
Name: python-urlcanon
Version: 0.3.1
Release: 1
Summary: url canonicalization library for python and java
License: Apache Software License
URL: https://github.com/iipc/urlcanon
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cb/65/222a5733af4c6d728fa90b0dcead218b3b0460eacdae22bb9ecdea1bbe5d/urlcanon-0.3.1.tar.gz
BuildArch: noarch
%description
A URL canonicalization (normalization) library for Python and Java.
It currently provides:
* A URL parser which preserves the input bytes exactly
* A precanned canonicalization ruleset that tries to match the normalization
implicit in the `parsing rules used by browsers
`_
* An alternative URL serialization suitable for sorting and prefix-matching:
`SSURT `_.
**Status:** Stable and in production use for some time. But no API or output
stability guarantees yet. There are differences in features between Java and
Python versions.
%package -n python3-urlcanon
Summary: url canonicalization library for python and java
Provides: python-urlcanon
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-urlcanon
A URL canonicalization (normalization) library for Python and Java.
It currently provides:
* A URL parser which preserves the input bytes exactly
* A precanned canonicalization ruleset that tries to match the normalization
implicit in the `parsing rules used by browsers
`_
* An alternative URL serialization suitable for sorting and prefix-matching:
`SSURT `_.
**Status:** Stable and in production use for some time. But no API or output
stability guarantees yet. There are differences in features between Java and
Python versions.
%package help
Summary: Development documents and examples for urlcanon
Provides: python3-urlcanon-doc
%description help
A URL canonicalization (normalization) library for Python and Java.
It currently provides:
* A URL parser which preserves the input bytes exactly
* A precanned canonicalization ruleset that tries to match the normalization
implicit in the `parsing rules used by browsers
`_
* An alternative URL serialization suitable for sorting and prefix-matching:
`SSURT `_.
**Status:** Stable and in production use for some time. But no API or output
stability guarantees yet. There are differences in features between Java and
Python versions.
%prep
%autosetup -n urlcanon-0.3.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-urlcanon -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.3.1-1
- Package Spec generated