%global _empty_manifest_terminate_build 0
Name: python-piprepo
Version: 0.1.3
Release: 1
Summary: piprepo creates PEP-503 compliant package repositories.
License: MIT
URL: https://github.com/colinhoglund/piprepo
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/12/e2/47fb5f33df50dbe22aa52fc6c64ccd44d27e5795c009f3ad1b83c1d24957/piprepo-0.1.3.tar.gz
BuildArch: noarch
Requires: python3-pip
Requires: python3-boto3
Requires: python3-flake8
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-moto
%description
piprepo is a tool for building and synchronizing `PEP-503 `_ compliant package repositories.
It currently supports synchronization to a local directory as well as AWS S3.
%package -n python3-piprepo
Summary: piprepo creates PEP-503 compliant package repositories.
Provides: python-piprepo
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-piprepo
piprepo is a tool for building and synchronizing `PEP-503 `_ compliant package repositories.
It currently supports synchronization to a local directory as well as AWS S3.
%package help
Summary: Development documents and examples for piprepo
Provides: python3-piprepo-doc
%description help
piprepo is a tool for building and synchronizing `PEP-503 `_ compliant package repositories.
It currently supports synchronization to a local directory as well as AWS S3.
%prep
%autosetup -n piprepo-0.1.3
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-piprepo -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.3-1
- Package Spec generated